レジストリ キーへの書き込みアクセス権がないと Drwtsn32 が動作しない

文書翻訳 文書翻訳
文書番号: 255674 - 対象製品
この記事は、以前は次の ID で公開されていました: JP255674
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

目次

現象

HKEY_LOCAL_MACHINE\Software\Microsoft レジストリ キーに対するログオン ユーザーのアクセス権が制限されていて、このキーにサブキーを作成する権利が与えられていない場合、Drwtsn32 が正常に動作せず、Drwtsn32.log ファイルの更新や User.dmp ファイルの生成が行われません。

原因

Drwtsn32.exe は、使用する構成を決定するために、実行時に KEY_CREATE_SUB_KEY 特権を要求してレジストリ キーを開きます。ログオン ユーザーにこれらの特権が与えられていない場合、Drwtsn32 は正しく動作せず、ログ ファイルやユーザー ダンプ ファイルが生成されません。

解決方法

Windows 2000

この問題を解決するには、Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法

Windows NT 4.0

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。

この問題を解決するには、Microsoft Product Support Services にお問い合わせのうえ、修正プログラムを入手してください。Microsoft Product Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web ページを参照してください。
http://support.microsoft.com/contactus/
: Microsoft Support 担当者が、特定の更新プログラムを適用することにより問題が解決されると判断した場合、まれに通常サポート依頼にかかる料金が免除されることがあります。ただし、特定の更新プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。

更新プログラム (英語版) の属性は次のとおりです。ただし、これより新しい更新プログラムがリリースされている可能性もあります。
   日付         時刻    サイズ       ファイル名     プラットフォーム
   --------------------------------------------------
   05/26/2000  05:46p  66,832  Drwtsn32.exe  x86
   05/26/2000  05:45p  90,384  Drwtsn32.exe  Alpha
				

状況

Windows 2000

マイクロソフトでは、この問題を Windows 2000 の問題として認識しています。 この問題は、Windows 2000 Service Pack 1 で最初に修正されました。

Windows NT 4.0

マイクロソフトでは、この問題を Windows NT 4.0 の問題として認識しています。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 255674 (最終更新日 2003-05-14) を基に作成したものです。

プロパティ

文書番号: 255674 - 最終更新日: 2014年1月24日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
キーワード:?
kbnosurvey kbarchive kbhotfixserver kbbug kbfix kbwin2000sp1fix KB255674
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com