Le processus Store.exe peut consommer des ressources processeur excessives et mémoire par intermittence lorsqu'un utilisateur ouvre un élément de calendrier à l'aide de OWA dans un environnement Exchange Server 2007 SP3

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Symptômes

Lorsqu'un utilisateur ouvre un élément de calendrier à l'aide d'Outlook Web Access (OWA) dans un environnement Microsoft Exchange Server 2007 Service Pack 3 (SP3), le processus Store.exe peut consommer trop de ressources du processeur sur le serveur Exchange par intermittence. En outre, la mémoire utilisée par le processus Store.exe augmente considérablement. En outre, l'événement suivant est enregistré dans le journal des applications :

Type d'événement : erreur
Source d'événements : MSExchangeIS
Catégorie d'événement : performances
L'ID d'événement : 9582
Description :
La mémoire virtuelle nécessaire pour exécuter votre serveur Exchange est fragmentée de telle sorte que les opérations normales peuvent commencer à échouer. Il est vivement recommandé de redémarrer tous les services Exchange pour corriger ce problème.
Remarque Lorsque ce problème se produit, le serveur Exchange peut cesser de répondre à toutes les demandes du client.

Cause

Ce problème se produit car l'élément de calendrier présente une exception et chaque exception comporte des pièces jointes qui sont aussi des messages (iCal) iCalendar. Ceci provoque le processus Store.exe entrent dans une boucle infinie.

Résolution

Pour résoudre ce problème, installez le correctif cumulatif suivant :
2602324 Description du correctif cumulatif de 5 pour Exchange Server 2007 Service Pack 3
Important Cette section, une méthode ou une tâche contient des étapes qui vous indiquent comment modifier le Registre. Toutefois, les problèmes sérieux peuvent survenir si vous modifiez le Registre de manière incorrecte. Par conséquent, assurez-vous de suivre ces étapes scrupuleusement. Pour une protection supplémentaire, sauvegarder le Registre avant de le modifier. Ensuite, vous pouvez restaurer le Registre si un problème survient. Pour plus d'informations sur la façon de sauvegarder et restaurer le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows

Après avoir installé le correctif logiciel, procédez comme suit pour limiter le nombre des pièces jointes :
  1. Cliquez sur Début
    Réduire cette imageAgrandir cette image
    bouton Démarrer
    , type Regedit dans la Démarrer la recherche zone et appuyez sur ENTRÉE.
  2. Recherchez et cliquez sur la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\Software\Microsoft\EXCDO\Parameters
  3. Cliquez sur Modifier, pointez sur Nouveau, puis cliquez sur DWORDValeur, type Total limite des pièces jointes, puis appuyez sur ENTRÉE.
  4. Clic droit Total limite des pièces jointes, puis cliquez sur Modifier.
  5. Dans la Données de la valeur zone, tapez <number></number>, puis cliquez sur OK.
  6. Quittez l'Éditeur du Registre.
Notes
  • Le Total limite des pièces jointes valeur peut être n'importe quel nombre en fonction de votre environnement. Si la valeur est 0, il n'y a pas de nombre de limite des pièces jointes.
  • Après avoir modifié l'entrée de Registre, vous devez redémarrer le service de banque d'informations Microsoft Exchange.
  • Une fois que vous tapez l'entrée de Registre et un utilisateur essaie d'ouvrir un élément de calendrier contient trop de pièces jointes qui dépassent le nombre prédéfini, l'événement suivant est enregistré dans le journal des applications :
    Type d'événement : erreur
    Source d'événements : EXCDO
    Catégorie d'événement : général
    L'ID d'événement : 8273
    Description :
    Dépassé la limite de pièce jointe par élément de calendrier au cours de la conversion. Boîte aux lettres <mailbox address=""></mailbox>, élément <the path="" of="" the="" calendar="" item=""></the>.

Statut

Microsoft a confirmé qu'il s'agit d'un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Propriétés

Numéro d'article: 2557304 - Dernière mise à jour: jeudi 22 septembre 2011 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Exchange Server 2007 Service Pack 3 sur le système suivant
    • Microsoft Exchange Server 2007 Standard Edition
    • Microsoft Exchange Server 2007 Enterprise Edition
Mots-clés : 
kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2557304 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 2557304
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