How to use the Orca database editor to edit Windows Installer files

Article translations Article translations
Article ID: 255905
This article was previously published under Q255905
Expand all | Collapse all

On This Page

SUMMARY

Due to limitations in the existing Windows Installer tools, you may need to edit the Windows Installer package (.msi) files directly. The Orca database editor is a table-editing tool available in the Windows Installer SDK and it can be used to edit your .msi files. The Orca editor edits and creates merge module (.msm) files , Internal Consistency Evaluator (.cub) files, and patch creation files (.pcp). This article discusses how to use the Orca editor to modify your .msi files.

MORE INFORMATION

Warning Editing an MSI file can cause serious problems that may leave your system in an unstable state. Microsoft cannot guarantee that problems resulting from the incorrect use of the MSI file editor can be solved. Modifications of the MSI file of a shipping product should only be attempted under direct instruction from the product's vendor.

Installing and Running Orca

To install and run the Orca editor, follow these steps:
  1. Download the Windows Installer SDK samples, tools, and documentation from the following Web page:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=A55B6B43-E24F-4EA3-A93E-40C0EC4F68E5&displaylang=en
  2. Install the Orca editor by double-clicking the Orca.msi file in the \Microsoft SDK\bin folder.
  3. Click Start, point to Programs, and then click Orca.
  4. On the File menu, click Open, and then browse to the .msi file that you want to edit.

Tables

The tables in the .msi file are listed in the left pane. Select the table to edit. The fields of the table appear at the top of the right pane. You can expand and collapse these fields.

To add standard tables that do not appear, click Add Table on the Tables menu. To remove a table, click Drop Table on the Tables menu, . You must select a table for the Drop Table option to appear on the menu.

The Export Tables and Import Tables options are located on the Tables menu. The Export Tables option exports a table to a text format that can be edited with a text editor, such as Notepad. The exported table has a .idt extension. You can import these IDT tables into the Orca editor by using the Import Tables action.

Rows

To add a row to a table, click Add Row on the Tables menu. A dialog box appears with the fields of the selected table. Fields with a gold key beside them are the primary keys for that table. The field name is indicated above the edit box, followed by the field type. If the word "Required" follows the field type, this field is required and the row cannot be added until a value appears in this field.

To remove a row, select the row of the table, and then click Drop Row on the Tables menu.

To edit an existing field in a row, double-click inside the field that you want to edit.

Validation

Validation runs from within the Orca editor when you click Validate from the Tools menu. If you are using the Orca editor that is included in the latest Windows Installer SDK, there is a drop-down list of the available evaluation files that you can run.

To validate a file, follow these steps:
  1. Select an available evaluation file suite from the drop-down menu in the Orca editor of the latest Windows Installer SDK.
    • Select Full MSI Validation Suite to validate a MSI file with all of the available validators.
    • Select Windows 2000 Logo Program Suite to run a subset of the validators that are used for logo certification.
    • Select Merge Module Validation Suite to validate an MSM file.
  2. Click to clear Show "INFO" messages to avoid informational messages which do not indicate a problem with the database.
  3. Click Go.
After validation is complete, you can copy the results to a text editor for viewing.

Dialog Boxes

If the open .msi file in the Orca editor contains dialog boxes for the user interface, preview these dialog boxes by using the Dialog Preview option on the Tools menu. You must use the appropriate tables for editing the dialog boxes.

Summary Information

To edit the summary information, click Summary Information on the View menu.

Note The ProductID field is the package code for the .msi file, not the product code. The product code is stored in the Property table in the ProductCode property. If you save the .msi file in the Orca editor, the package code is not automatically changed. You must make this change manually.

REFERENCES

All information about the specific tables or fields in a .msi file is located in the Windows Installer Help file (Msi.chm). The help file is installed in the MsiIntel.SDK\Help directory when the Windows Installer SDK is installed. The standard tables information is at the following location in the help file:

Installer Database\Installer Database Reference\Database Tables.
To install and Run the SDK Update ActiveX Control:
http://www.microsoft.com/downloads/details.aspx?FamilyId=A55B6B43-E24F-4EA3-A93E-40C0EC4F68E5&displaylang=en
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 255905 - Last Review: July 2, 2010 - Revision: 5.0
Keywords: 
kbappsetup kbhowto KB255905
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com