Verwenden des Orca-Datenbank-Editors zum Bearbeiten von Windows Installer-Dateien

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 255905 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
255905 How to use the Orca database editor to edit Windows Installer files
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
Alles erweitern | Alles schließen

Auf dieser Seite

Zusammenfassung

Aufgrund von Einschränkungen in den bestehenden Windows Installer-Tools müssen Sie möglicherweise die Windows Installer-Paketdateien (.msi-Dateien) direkt bearbeiten. Der Orca-Datenbank-Editor ist ein im Windows Installer SKD verfügbares Tabellenbearbeitungsprogramm und kann verwendet werden, um Ihre .msi-Dateien zu bearbeiten. Der Orca-Editor bearbeitet und erstellt Mergemoduldateien (.msm-Dateien), Internal Consistency Evaluator-Dateien (.cub-Dateien) und Patcherstellungsdateien (.pcp-Dateien). In diesem Artikel wird beschrieben, wie Sie den Orca-Editor verwenden können, um Ihre .msi-Dateien zu ändern.

Weitere Informationen

Warnung Das Bearbeiten einer MSI-Datei kann schwerwiegende Probleme verursachen und dazu führen, dass sich Ihr System anschließend in einem instabilen Zustand befindet. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des MSI-Datei-Editors herrühren, behoben werden können. Änderungen der MSI-Datei eines gelieferten Produkts sollten nur anhand von direkten Anweisungen vom Produkthersteller durchgeführt werden.

Installieren und Ausführen von Orca

Gehen Sie folgendermaßen vor, um den Orca-Editor zu installieren und auszuführen:
  1. Downloaden Sie die Windows Installer SDK-Beispiele, -Tools und -Dokumentation von folgender Webseite:
    http://www.microsoft.com/downloads/details.aspx?FamilyId=A55B6B43-E24F-4EA3-A93E-40C0EC4F68E5&displaylang=en
  2. Installieren Sie den Orca-Editor, indem Sie im Ordner \Microsoft SDK\bin auf die Datei Orca.msi doppelklicken.
  3. Klicken Sie auf Start, zeigen Sie auf Programme, und klicken Sie anschließend auf Orca.
  4. Klicken Sie im Menü File (Datei) auf Open (Öffnen), und gehen Sie anschließend zu der .msi-Datei, die Sie bearbeiten möchten.

Tabellen

Die Tabellen in der .msi-Datei sind im linken Fenster aufgelistet. Wählen Sie die Tabelle, die Sie bearbeiten möchten. Die Felder der Tabelle werden im rechten Fenster oben angezeigt. Sie können diese Felder erweitern und reduzieren.

Um Standardtabellen hinzuzufügen, die nicht angezeigt werden, klicken Sie im Menü Tables (Tabellen) auf Add Table (Tabelle hinzufügen). Um eine Tabelle zu entfernen, klicken Sie im Menü Tables (Tabellen) auf Drop Table (Tabelle löschen). Sie müssen eine Tabelle markieren, damit die Option Drop Table (Tabelle löschen) im Menü angezeigt wird.

Die Optionen Export Tables (Tabellen exportieren) und Import Tables (Tabellen importieren) befinden sich ebenfalls im Menü Tables (Tabellen). Die Option Export Tables (Tabellen exportieren) exportiert eine Tabelle in ein Textformat, das mit einem Texteditor, wie z. B. Microsoft Editor, bearbeitet werden kann. Die exportierte Tabelle hat die Erweiterung ".idt". Sie können diese IDT-Tabellen mithilfe der Option Import Tables (Tabellen importieren) in den Orca-Editor importieren.

Zeilen

Um eine Zeile zu einer Tabelle hinzuzufügen, klicken Sie im Menü Tables (Tabellen) auf Add Row (Zeile hinzufügen). Ein Dialogfeld mit den Feldern der markierten Tabelle wird angezeigt. Felder mit einem daneben angezeigten goldenen Schlüssel sind die Primärschlüssel für diese Tabelle. Der Feldname wird über dem Bearbeitungsfeld angezeigt, gefolgt von Feldtyp. Wenn das Wort "Required (Erforderlich)" neben dem Feldtyp steht, ist dieses Feld erforderlich, und die Zeile kann nicht hinzugefügt werden, bis ein Wert in diesem Feld angezeigt wird.

Um eine Zeile zu entfernen, markieren Sie die Zeile in der Tabelle, und klicken Sie anschließend im Menü Tables (Tabellen) auf Drop Row (Zeile löschen).

Um ein vorhandenes Feld in einer Zeile zu bearbeiten, doppelklicken Sie in das Feld, das Sie bearbeiten möchten.

Überprüfung

Die Überprüfung wird innerhalb des Orca-Editors ausgeführt, wenn Sie im Menü Tools (Extras) auf Validate (Überprüfen) klicken. Wenn Sie die Version von Orca-Editor verwenden, die im neuesten Windows Installer SDK enthalten ist, steht Ihnen eine Dropdownliste mit allen verfügbaren Evaluierungsdateien, die Sie ausführen können, zur Verfügung.

Gehen Sie folgendermaßen vor, um eine Datei zu überprüfen:
  1. Wählen Sie eine verfügbare Evaluierungsdateifolge aus dem Dropdownmenü im Orca-Editor des neuesten Windows Installer SDK.
    • Wählen Sie Full MSI Validation Suite (Vollständige MSI-Überprüfung), um eine MSI-Datei mit allen verfügbaren Validatoren zu überprüfen.
    • Wählen Sie Windows 2000 Logo Program Suite (Windows 2000 Logo-Programmsuite), um einen Teil der Validatoren, die für die Logozertifizierung verwendet werden, auszuführen.
    • Wählen Sie Merge Module Validation Suite (Mergemodulüberprüfung), um eine MSM-Datei zu überprüfen.
  2. Deaktivieren Sie das Kontrollkästchen Show "INFO" messages (INFO-Meldungen anzeigen), um zu verhindern, dass informative Meldungen angezeigt werden, die nicht auf ein Problem mit der Datenbank hinweisen.
  3. Klicken Sie auf Go (Ausführen).
Nachdem die Überprüfung abgeschlossen ist, können Sie die Ergebnisse zum Anzeigen in einen Texteditor kopieren.

Dialogfelder

Wenn die im Orca-Editor geöffnete .msi-Datei Dialogfelder für die Benutzeroberfläche enthält, können Sie diese Dialogfelder in der Voransicht anzeigen, indem Sie die Option Dialog Preview (Dialogvoransicht) im Menü Tools (Extras) verwenden. Sie müssen die entsprechenden Tabellen für die Bearbeitung der Dialogfelder verwenden.

Zusammenfassung

Um die Zusammenfassung zu bearbeiten, klicken Sie im Menü View (Ansicht) auf Summary Information (Zusammenfassung).

Hinweis Das Feld ProductID ist der Verpackungscode für die .msi-Datei, nicht der Produktcode. Der Produktcode ist in der Tabelle Property (Eigenschaften) in der Eigenschaft "ProductCode" gespeichert. Wenn Sie die .msi-Datei im Orca-Editor speichern, wird der Verpackungscode nicht automatisch geändert. Sie müssen diese Änderungen manuell durchführen.

Informationsquellen

Alle Informationen über die spezifischen Tabellen oder Felder in einer .msi-Datei befinden sich in der Windows Installer-Hilfedatei (Msi.chm). Die Hilfedatei wird im Verzeichnis MsiIntel.SDK\Help installiert, wenn das Windows Installer SDK installiert wird. Die Standardtabelleninformationen befinden sich in folgendem Speicherort in der Hilfedatei:

Installer Database\Installer Database Reference\Database Tables.
Informationen zum Installieren und Ausführen des SDK-Update-ActiveX-Steuerelements finden Sie auf folgender Webseite:
http://www.microsoft.com/downloads/details.aspx?FamilyId=A55B6B43-E24F-4EA3-A93E-40C0EC4F68E5&displaylang=en

Eigenschaften

Artikel-ID: 255905 - Geändert am: Samstag, 21. Januar 2006 - Version: 4.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Installer 1.0
  • Microsoft Windows Installer 1.1
  • Microsoft Windows Installer 1.2
  • Microsoft Windows Installer 2.0
Keywords: 
kbappsetup kbhowto KB255905
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.
Disclaimer zu nicht mehr gepflegten KB-Inhalten
Dieser Artikel wurde für Produkte verfasst, für die Microsoft keinen Support mehr anbietet. Der Artikel wird deshalb in der vorliegenden Form bereitgestellt und nicht mehr weiter aktualisiert.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com