Windows NT Service Pack では再起動後にローカル管理者のアクセス許可を使用したログオンが必要

文書翻訳 文書翻訳
文書番号: 255987 - 対象製品
この記事は、以前は次の ID で公開されていました: JP255987
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

現象

Windows NT 4.0 Service Pack アップデート処理の仕様では、Update.exe によってコンピュータが再起動された後、ローカル管理者の資格情報による追加のログオンが必要です。

Service Pack セットアップ処理が実行された直後、管理者以外のユーザーがログオンを行うと、ProtectedStorage 関連のエラーとして、以下の 2 つのアプリケーション イベントが記録されます。
ProtectedStorage error: 5; OpenSCManager failed.

ProtectedStorage error: 203; Install Service failed.
ローカル管理者がログオンを行うまで、ログオンのたびにこれらのイベントが記録されます。

原因

次のキーの下にあるレジストリ値をすべて正常に処理し、削除するためには、ローカル管理者のアクセス許可が必要です。
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
RunOnce 値は、コンピュータで現在有効なログイン資格情報を使用して処理されます。しかし、管理者以外のユーザーには、"4. 'Install pstores.exe'='pstores.exe -install'" RunOnce エントリを正常に処理するために必要なアクセス許可が与えられていません。このため、上記のイベントが記録されます。

また、管理者以外のユーザーに対しては、デフォルトで RunOnce キーに "Everyone=read" アクセス許可が設定されているため、このキーのエントリを削除できません。

他の Microsoft やサードパーティ製のセットアップ処理でも、再起動後のログオンで RunOnce または RunOnceEx キーを使用してセットアップ処理を完了させる場合には、同様の問題が発生することがあります。

回避策

次のいずれかの操作を行います。
  • ローカル管理者のアクセス許可を持つユーザーがコンピュータにログオンする。
  • 管理者の AutoAdminLogon を使用する。このとき、Mouclass および Kbdclass ドライバを無効にして、ユーザーの割り込みを防止することもできます。

    この方法にはいくつかの問題があります。ローカル管理者のパスワードは、テキスト形式でレジストリ (および対応するスクリプト ファイル) に格納されます。また、ドライバを無効にすることによって、システムにアクセスできなくなることがあります。また、以下の「サポート技術情報」 (Microsoft Knowledge Base) に記載されている情報にもご注意ください。
    159969 AutoLogon Fails If DontDisplayLastUserName Is Also Enabled
    159969 [NT]DontDisplayLastUserName が有効時 AutoLogon が失敗する
    このような問題があるため、マイクロソフトでは最初に記載した方法をお勧めします。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 255987 (最終更新日 2001-08-08) をもとに作成したものです。

プロパティ

文書番号: 255987 - 最終更新日: 2014年2月23日 - リビジョン: 2.1
この資料は以下の製品について記述したものです。
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
キーワード:?
kbnosurvey kbarchive kberrmsg kbenv kbsetup kbprb KB255987
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com