Article ID: 256276 - Last Review: March 11, 2000 - Revision: 1.0 Error Message: There Is No CatalogThis article was previously published under Q256276 SYMPTOMS
When you type in a query, and then click the Go button to execute the query, the query does not return. Instead, you receive a page that displays the following error message:
There is no catalog
CAUSE
The catalog specified in either the code of the query page or the default catalog path in the registry is invalid.
RESOLUTION
If you do not specify a catalog in your code, Index Server finds the path to the default catalog using following registry key, and then uses that catalog:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ContentIndex
The path is located under the IsapiDefaultCatalogDirectory value and should be the same as the physical path to the directory that contains the Catalog.wci directory.
If you choose to specify your catalog in the code of your pages, the method you use depends on how you are doing your queries. In an IDQ file, use a command line similar to the following: where <catalogpath> is the same as the path to the directory that contains the Catalog.wci directory. For example, if the physical path to your Catalog.wci folder is C:\Inetpub\Catalogs\Catalog.wci, then your CiCatalog line will be similar to the following: The CiCatalog variable should be located in the [Query] section of the IDQ file. In an ASP file, use the Q.Catalog line to specify the name of the catalog to be queried. NOTE: This example uses the IXSSO object and is based on Query.asp, which is installed by default with Index Server. In the Query.asp page, find the section that resembles the following: MORE INFORMATIONFor additional information, click the article number below
to view the article in the Microsoft Knowledge Base:
238791
(http://support.microsoft.com/kb/238791/EN-US/
)
Specifying a Catalog in ASP Code (IXSSO Query)
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