Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You customize the settings of the Large Message Threshold option and of the Large Message Fragment size option.

  • An incoming BizTalk batch includes many messages.


In this scenario, the server that is running Microsoft BizTalk Server experiences decreased performance when the server processes the messages.

For example, you keep the following default settings for a BizTalk group:

Large Message Threshold (bytes): 1,000,000

Large Message Fragment size (bytes): 102,400 The server that is running BizTalk Server 2009 receives a batch of 9,000 messages. In this example, it takes 2 minutes for the server to finish processing all the messages.

Now, you specify the following settings in the BizTalk group:

Large Message Threshold (bytes): 10,000,000

Large Message Fragment size (bytes): 1,000,000When the server that is running BizTalk Server 2009 receives the same batch of 9,000 messages, it now takes 7 minutes for the server to finish processing all the messages.

Cause

This problem occurs because unnecessary delete operations occur for message properties that are already deleted.

Resolution

Cumulative update information

BizTalk Server 2009

The fix for this issue was first released in cumulative update package 3 for BizTalk Server 2009. For more information about how to obtain this cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2557149 Cumulative update package 3 for BizTalk Server 2009

For BizTalk Server 2010

The hotfix that resolves this issue is included in cumulative update package 2 for BizTalk Server 2010.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2573000 Cumulative update package 2 for BizTalk Server 2010

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about how to resolve performance issues, visit the following Microsoft Developer Network (MSDN) website:

Maintaining PerformanceFor more information about how to configure global properties for your BizTalk Server group, visit the following MSDN website:

How to Modify Group PropertiesFor more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixes

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×