Symptomen
Wanneer u probeert te installeren of verwijderen van een hotfix voor Microsoft Host Integration Server, de bewerking kunnen mislukken en wordt het volgende foutbericht weergegeven:
Fout bij openen installatielogboekbestand. Controleer of het opgegeven logboekbestand bestaat en schrijfbaar is.
Opmerking Dit is een bekend probleem optreedt op een computer dat is sommige antivirus programma's, zoals Forefront Endpoint Protection 2010 geïnstalleerd en ingeschakeld.
Oorzaak
Dit probleem treedt op vanwege een timingprobleem. Bij het installeren of een hotfix verwijdert het installatieprogramma (Setup.exe) wordt uitgevoerd, vergrendelt het logboekbestand in de exclusieve modus. Vervolgens start het Setup-programma Msiexec.exe. Het Setup-programma probeert te schrijven naar het bestand voordat het programma wordt afgesloten. Sommige antivirussoftware kan echter leiden tot het sluiten van het logboek wordt vertraagd als u de antivirussoftware bestanden scannen. Dit probleem kan veroorzaken Msiexec.exe ontvangen een deelfout bij een poging toegang te krijgen tot het bestand Setup.log.
Oplossing
Informatie over de hotfix
Microsoft Host integratieserver 2010
De hotfix om dit probleem is opgenomen in de cumulatieve updatepakket 2 voor de Host Integration Server 2010.
Voor meer informatie over het verkrijgen van het cumulatieve updatepakket, klikt u op het volgende artikel in de Microsoft Knowledge Base:
2616519 cumulatieve updatepakket 2 voor Host Integration Server 2010
Microsoft Host integratieserver 2009
De hotfix om dit probleem is opgenomen in de cumulatieve updatepakket 2 voor 2009 van Host Integration Server.
Voor meer informatie over het verkrijgen van het cumulatieve updatepakket, klikt u op het volgende artikel in de Microsoft Knowledge Base:
2645939 cumulatieve updatepakket 2 voor Host Integration Server 2009
Status
Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.