Article ID: 2566790 - Last Review: December 16, 2011 - Revision: 18.0

Automatic sign-in, domain federation, and other features do not work as expected in Lync Online when you use a custom domain in Office 365

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SYMPTOMS

One or more of the following features do not work as expected in Microsoft Lync Online in Microsoft Office 365:
  • Lync Online Autodiscover and automatic sign-in
  • Lync Online federation with external users
  • Public Internet Connectivity (PIC) together with Windows Live, MSN, and Hotmail users
  • Outlook Web Access instant messaging
  • Sign in from Lync Mobile clients by using the Auto-Detect Server option

CAUSE

This issue occurs if all the following conditions are true:
  • You use a custom or vanity domain in Office 365.
  • Domain Name System (DNS) service (SRV) resource records, alias (CNAME) resource records, or both kinds of records are configured incorrectly for your domain.

RESOLUTION

Make sure that you add the following SRV and CNAME records to your DNS host.

SRV records
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TypeServiceProtocolPortWeightPriorityTTLNameTarget
SRV_sip_tls44311001 hour<DomainName>sipdir.online.lync.com
SRV_sipfederationtls_tcp506111001 hour<DomainName>sipfed.online.lync.com
Note The placeholder <DomainName> is the name of the Session Initiation Protocol (SIP) domain of your organization such as, for example, contoso.com.

CNAME records
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TypeHost nameDestinationTTL
CNAMEsip.<DomainName>sipdir.online.lync.com1 hour
CNAMElyncdiscover.<DomainName>webdir.online.lync.com1 hour
Note<DomainName> is your domain. For example, contoso.com.

MORE INFORMATION

Troubleshoot Lync Online DNS records

To check the SRV and CNAME records to verify that they are correct, use the Nslookup command-line tool to view the values that were entered. To do this, follow these steps:
  1. Open a Command Prompt window. To do this, click Start, click Run, type cmd, and then press Enter.
  2. At a command prompt, type the following commands. Press Enter after each command:
    nslookup
    set type=all
  3. If the domain names do not resolve, the internal name server might not allow the Nslookup command. To work around this issue, type server 4.2.2.2, and then press Enter. This command changes the default server to a public server that will work.
  4. To query specific SRV records, type the following SRV records, where <domain> is the specific vanity domain that is being used, and then press Enter:
    _sip._tls.<domain>.

    _sipfederationtls._tcp.<domain>

    sip.<domain>.

    lyncdiscover.<domain>.

    Note Make sure that you include the trailing period in your query, or certain records may not appear
The following screen shot shows how Nslookup is used to verify that the SRV records are added successfully to the domain by using a public name server.

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Third-party websites for network diagnostics

In addition to using Nslookup, or as an alternative to using Nslookup, you can use third-party web tools that perform many of these network tests automatically. One such website is http://www.network-tools.com (http://www.network-tools.com/) . This website offers a collection of network-related tools that can be used to verify DNS records, domain registrars, and hosts. Select the DNS records, enter the specific DNS records that you want to query, and the website will perform the DNS query and return the results.

If you cannot add SRV records through your DNS host

Some DNS hosts cannot host SRV records, or the DNS hosts do not have options to host SRV records. This blocks the ability to communicate with external users (Federated and PIC). In these cases, there is currently no workaround except to change DNS hosts or to manage DNS through an on-premises DNS host.

REFERENCES

For more information about how to create and verify DNS SRV records if you have an on-premises DNS host, visit the following Microsoft TechNet website:
Create and Verify DNS SRV Records (http://technet.microsoft.com/en-us/library/gg398680.aspx)
For Office 365 for professionals and small businesses, click the following article number to view the article in the Microsoft Knowledge Base:
2526143 (http://support.microsoft.com/kb/2526143) You cannot sign in to Lync Online by using a domain that is configured for Full Redelegation

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

APPLIES TO
  • Microsoft Office 365 for enterprises
  • Microsoft Office 365 for small businesses
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