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Symptoms

The following issues occur in Microsoft Team Foundation Server (TFS) 2010.

Issue 1

Consider the following scenario:

  • You configure two or more build agents to allow for concurrent build requests in a build controller.

  • You select gated check-in as the trigger type when you define a build definition.

  • The build definition has two or more build requests in the Queued state while another build request has the InProgress state.


In this scenario, some builds in the build definition might incorrectly run concurrently in the build definition after the build in the InProgress state finishes.

Issue 2

When you try to run build requests in the build controller, the following exceptions are encountered, and the job fails:

<ResultMessage>[Build Warehouse Sync]: ---> Microsoft.TeamFoundation.Server.WarehouseException: TF221122: An error occurred running job Build Warehouse Sync for team project collection or Team Foundation server RXD. ---> Microsoft.TeamFoundation.Framework.Server.DatabaseOperationTimeoutException: TF246018: The database operation exceeded the timeout limit and has been cancelled. Verify that the parameters of the operation are correct. ---> System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding


Cause

Cause of Issue 1

This issue occurs because of an error in the logic that decides which build is the next build.

When the InProgress build is finished, the incorrect logic might start more than one gated submission on a definition.

Cause of Issue 2

This issue occurs because errors exist in the build warehouse adapter and in the test management adapter.

Resolution


Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft Visual Studio 2010 Service Pack 1 (SP1) installed.

Restart requirement

You have to restart the computer after you apply this hotfix if the affected files are being used.

Hotfix replacement information

This hotfix does not replace a previously released hotfix. 

File information



The global version of this has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Microsoft.teamfoundation.admin.dll

10.0.40219.349

24,715,128

20-Sep- 2011

21:49

x86

Microsoft.teamfoundation.server.deploy.tfcollection.dll

10.0.40219.349

561,576

20-Sep- 2011

21:49

x86

Microsoft.teamfoundation.workitemtracking.server.dataaccesslayer.dll

10.0.40219.349

589,256

20-Sep- 2011

21:49

x86

Microsoft.teamfoundation.workitemtracking.server.dataservices.dll

10.0.40219.349

142,784

20-Sep-2011

21:49

x86


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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