Office va lento o puede dejar de responder (colgarse) al abrir un archivo desde una ubicación de red

Síntomas

Cuando intenta abrir un archivo desde una ubicación de red en un programa de Microsoft Office como PowerPoint 2003, Excel 2003, Publisher 2003 o una versión posterior de ellos, el programa de Office puede ejecutarse muy lentamente o parece que deja de responder (se cuelga).

Causa

Este comportamiento puede producirse si la conexión a la ubicación de red se pierde durante el tiempo en que el programa de Office abre el archivo.

Solución alternativa

Importante

Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. No obstante, pueden producirse problemas graves si modifica el registro de manera incorrecta. En consecuencia, asegúrese de seguir estos pasos cuidadosamente. Para mayor protección, cree una copia de seguridad del registro antes de modificarlo. Después, puede restaurar el registro si se produce un problema. Para obtener más información sobre cómo hacer una copia de seguridad del Registro y cómo restaurarlo, consulte Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows.

Para evitar este comportamiento, añadael valor EnableShellDataCaching al Registro de Microsoft Windows. Para ello, siga estos pasos:

  1. Cierre los programas de Office.

  2. Haga clic en Inicio y luego en Ejecutar.

  3. En el cuadro Abrir, escriba regedit y luego haga clic en Aceptar.

  4. Busque una de las claves siguientes del Registro y haga clic en ella para seleccionarla:

    • Aplicaciones de Microsoft 365, Office LTSC 2021, Office 2019 y Office 2016:

      HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common\Open Find

    • Office 2013:

      HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Open Find

    • Office 2010:

      HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\Open Find

    • Office 2007:

      HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\Open Find

    • Office 2003:

      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Open Find

  5. Después de seleccionar la clave especificada en el paso 4, apunte a Nuevo en el menú Editar y, después, haga clic en Valor DWORD.

  6. Escriba EnableShellDataCaching y presione Entrar.

  7. Haga clic con el botón derecho en EnableShellDataCaching y luego haga clic en Modificar.

  8. En el cuadro Información del valor, escriba 1 y haga clic en Aceptar.

    Nota:

    Cualquier número distinto de cero en el cuadro Información del valor activará el almacenamiento en caché. Un número cero o dejarlo en blanco (predeterminado) desactivará el almacenamiento en caché.

  9. En el menú Archivo, haga clic en Salir para salir del Editor del Registro.

¿Esta información le ha ayudado a solucionar el problema?

Compruebe si se ha solucionado el problema. Si se ha solucionado, ya ha terminado con esta sección. En caso contrario, puede comunicarse con el soporte técnico.

Más información

Esta situación puede producirse después de hacer clic en Abrir en el cuadro de diálogo Abrir (en el menú Archivo, haga clic en Abrir) para abrir un archivo desde una ubicación de red (por ejemplo, un servidor de red). Durante el proceso de apertura del archivo, se pierde la conexión de red o la ubicación de red que contiene el archivo que está intentando abrir se bloquea. Durante el proceso de apertura del archivo, el programa de Office intenta añadir el nombre de archivo y la información de ruta del archivo que está intentando abrir en la lista de archivos recientes de Windows. Dado que la ubicación de red (ruta) ahora no existe, el programa de Office puede ejecutarse lentamente y puede parecer que deja de responder (se cuelga).

Nota:

Esta situación también puede producirse si la conexión a la red va lenta porque el programa de Office debe realizar varias consultas a la red para obtener la información de archivo correcta.