Works Suite Err Msg: Winword Caused an Invalid Page Fault in Module User32.dll

Article translations Article translations
Article ID: 257417 - View products that this article applies to.
This article was previously published under Q257417
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

Symptoms

When you close a Microsoft Word 2000 document, you may receive an error message stating that an illegal operation has occurred. When you click Details, you receive the following error message:
Winword caused an invalid page fault in module User32.dll.

Cause

This behavior can occur if the following conditions are true:
  • You open a Word 2000 document that was created from a Word in Works Suite Add-in template while the Word 2000 Office Assistant was enabled.
  • You close the Word 2000 document by clicking the close button in the upper-right corner of the document window.
A closing conflict between the Office Assistant in Word 2000 and the Word in Works Suite Add-in template produces the error message. You should not experience any loss of data as a result of this behavior.

Resolution

To work around this behavior, use the following methods in the order in which they are presented.

Turn Off Office Assistant and Re-create the Word 2000 Document

To turn off the Office Assistant and re-create the Word 2000 document:
  1. Start Works Suite.
  2. In the Works Suite Task Launcher, click the Programs tab, and then click Word.
  3. Click the task that you want to use, and then click Start.
  4. Click the template that you want to use, and then click Finish.
  5. Open the original Word 2000 document.
  6. Select the text on the first page of the document.
  7. On the Edit menu, click Copy.
  8. Click the taskbar button to switch to the new document.
  9. In the new document, position the insertion point at the top of the first page, and then click Paste on the Edit menu.
  10. Click the taskbar button to switch to the original document.
  11. Repeat steps 6 through 10 for each page that you have to re-create in the new document.
  12. In the new document, click Hide the Office Assistant on the Help menu.
  13. On the File menu, click Save As.
  14. In the Save As dialog box, browse to the location where you want to save the document.
  15. In the File name box, type a name for the document, and then click Save.
NOTE: This method does not fix any problem documents that trigger the error message mentioned in the "Symptoms" section of this article. For each of these problem documents, you have to follow this method to re-create the original document.

If you do not want to turn off the Office Assistant, or if there are too many documents to re-create in the manner described in the earlier method, continue to the next method.

Remove the Word in Works Suite Add-in

To prevent the closing conflict that produces the error message mentioned in the "Symptoms" section of this article, you have to remove the Word in Works Suite Add-in. But before you proceed with this method, see the "More Information" section of this article for information about the disadvantages of removing the Word in Works Suite Add-in.

To remove the Word in Works Suite Add-in:
  1. Insert the Works Suite Disc 1 CD-ROM into the CD-ROM drive. Press and hold down the SHIFT key as you insert the CD-ROM to prevent Works Setup from starting automatically.
  2. Click Start, point to Settings, and then click Control Panel.
  3. Double-click Add/Remove Programs.
  4. Click Word in Works Suite Add-in, and then click Add/Remove.
  5. Click Next, click Remove, and then click Next.
  6. Click Remove, and then click Finish.
  7. Click OK, and then close Control Panel.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

More information

Microsoft recommends that you consider the following disadvantages to removing the Word in Works Suite Add-in before you remove it.

When you remove the Word in Works Suite Add-in:
  • You remove Word 2000 from the Works Suite Task Launcher.
  • You lose the word processor functions on the Works Suite Task Launcher.
  • You must start Word 2000 in the following manner:

    Click Start, point to Programs, and then click Microsoft Word.
To reinstall the Word in Works Suite Add-in:
  1. Double-click the My Computer icon on the desktop.
  2. Right-click the CD-ROM drive icon, and then click Explore.
  3. In the left pane, double-click the WordAdd folder.
  4. In the right pane, double click Setup.exe.
  5. Follow the instructions on the screen to reinstall the Word in Works Suite Add-in.
  6. Quit Windows Explorer, and then close the My Computer window.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 257417 - Last Review: October 24, 2013 - Revision: 1.0
Applies to
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004
  • Microsoft Works Suite 2003
  • Microsoft Works Suite 2001
  • Microsoft Works Suite 2000
  • Microsoft Works Suite 2006
Keywords: 
kbnosurvey kbarchive kbaddin kbbug kberrmsg kbpending kbui KB257417

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com