Message d'erreur Works Suite : Winword a causé une défaillance de page dans le module User32.dll

Traductions disponibles Traductions disponibles
Numéro d'article: 257417 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F257417
Cet article a été archivé. Il est proposé « en l'état » et ne sera plus mis à jour.
Cet article peut contenir des liens vers des informations en langue anglaise (pas encore traduites).
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous fermez un document Microsoft Word 2000, un message d'erreur indiquant qu'une opération non conforme s'est produite peut apparaître. Cliquez sur Détails pour afficher le message d'erreur suivant :
Winword a causé une défaillance de page dans le module User32.dll

Cause

Ce problème peut se produire dans les conditions suivantes :
  • Vous ouvrez un document Word 2000 créé à partir d'un modèle de complément Word dans Works Suite pendant que le Compagnon Office de Word 2000 est activé.
  • Vous fermez le document Word 2000 en cliquant sur le bouton de fermeture situé dans l'angle supérieur droit de la fenêtre du document.
Un conflit de fermeture entre le Compagnon Office de Word 2000 et le modèle de Complément Word dans Works Suite provoque le message d'erreur. Aucune perte de données ne résulte de ce problème.

Résolution

Pour contourner ce problème, appliquez les méthodes ci-dessous en respectant l'ordre dans lequel elles sont présentées.

Désactiver le Compagnon Office et recréer le document Word 2000

Pour désactiver le Compagnon Office et recréer le document Word 2000 :
  1. Démarrez Works Suite.
  2. Dans le Lanceur de tâches Works Suite, cliquez sur l'onglet Programmes, puis sur Word.
  3. Sélectionnez la tâche à utiliser, puis cliquez sur Démarrer.
  4. Sélectionnez le modèle à utiliser, puis cliquez sur Terminer.
  5. Ouvrez le document Word 2000 initial.
  6. Sélectionnez le texte sur la première page du document.
  7. Dans le menu Edition, cliquez sur Copier.
  8. Cliquez sur le bouton correspondant dans la barre des tâches pour passer au nouveau document.
  9. Dans le nouveau document, placez le point d'insertion en haut de la première page, puis cliquez sur Coller dans le menu Edition.
  10. Cliquez sur le bouton correspondant dans la barre des tâches pour repasser au document original.
  11. Répétez les étapes 6 à 10 pour chacune des pages à recréer dans le nouveau document.
  12. Dans le nouveau document, cliquez sur Masquer le Compagnon Office dans le menu ? (Aide).
  13. Dans le menu Fichier, cliquez sur Enregistrer sous.
  14. Dans la boîte de dialogue Enregistrer sous, recherchez l'emplacement sur lequel enregistrer le document.
  15. Dans la zone Nom du fichier, tapez le nom du document, puis cliquez sur Enregistrer.
REMARQUE : cette méthode ne résout pas les problèmes de document à l'origine du message d'erreur mentionné dans la section Symptômes de cet article. Pour chacun de ces documents à problème, vous devez suivre cette méthode pour recréer le document original.

Si vous ne souhaitez pas désactiver le Compagnon Office ou s'il y a trop de documents à recréer selon la méthode ci-dessus, appliquez la méthode suivante.

Supprimer le Complément Word dans Works Suite

Pour éviter le conflit de fermeture, qui génère le message d'erreur mentionné dans la section « Symptômes » de cet article, vous devez supprimer le Complément Word dans Works Suite. Toutefois, avant d'effectuer cette opération, consultez la section « Plus d'informations » de cet article pour connaître les inconvénients liés à la suppression de ce complément.

Pour supprimer le Complément Word dans Works Suite :
  1. Insérez le Disque 1 de Works Suite dans le lecteur de CD-ROM. Ce faisant, maintenez enfoncée la touche MAJ pour éviter le démarrage automatique du programme d'installation de Works.
  2. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.
  3. Double-cliquez sur Ajout/Suppression de programmes.
  4. Cliquez sur Complément Word dans Works Suite, puis sur Ajouter/Supprimer.
  5. Cliquez sur Suivant, sur Supprimer, puis sur Suivant.
  6. Cliquez sur Supprimer, puis sur Terminer.
  7. Cliquez sur OK, puis fermez le Panneau de configuration.

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés au début de cet article.

Plus d'informations

Microsoft vous recommande de prendre en compte les inconvénients liés à la suppression du Complément Word dans Works Suite avant de le supprimer.

Lorsque vous supprimez le Complément Word dans Works Suite :
  • Vous supprimez Word 2000 du Lanceur de tâches Works Suite.
  • Vous perdez les fonctions de traitement de texte sur le Lanceur de tâches Works Suite.
  • Vous devez démarrer Word 2000 de la manière suivante :

    Cliquez sur Démarrer, pointez sur Programmes, puis cliquez sur Microsoft Word.
Pour réinstaller le Complément Word dans Works Suite :
  1. Double-cliquez sur l'icône Poste de travail du Bureau.
  2. Cliquez avec le bouton droit sur l'icône du lecteur de CD-ROM, puis cliquez sur Explorateur.
  3. Dans le volet gauche, double-cliquez sur le dossier WordAdd.
  4. Dans le volet droit, double-cliquez sur Setup.exe.
  5. Suivez les instructions affichées pour réinstaller le Complément Word dans Works Suite.
  6. Quittez l'Explorateur Windows, puis fermez la fenêtre Poste de travail.

Propriétés

Numéro d'article: 257417 - Dernière mise à jour: samedi 8 février 2014 - Version: 5.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Works Suite 2005 Standard Edition
  • Microsoft Works Suite 2004 Standard Edition
  • Microsoft Works Suite 2003 Standard
  • Microsoft Works Suite 2001 Standard
  • Microsoft Works Suite 2000 Standard Edition
  • Microsoft Works Suite 2006
Mots-clés : 
kbnosurvey kbarchive kbaddin kbbug kberrmsg kbpending kbui KB257417
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com