Mensagem de erro do Works Suite: Winword causou um erro página inválida no módulo user32.dll

Traduções de Artigos Traduções de Artigos
Artigo: 257417 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando fecha um documento do Microsoft Word 2000, poderá receber uma mensagem de erro indicando que ocorreu uma operação ilegal. Quando clicar em Detalhes , recebe a seguinte mensagem de erro:
WINWORD causou um erro de página inválida no módulo user32.dll.

Causa

Este comportamento pode ocorrer se se verificarem as seguintes condições:
  • Abrir um documento do Word 2000 que foi criado a partir de um modelo de suplemento do Works Suite do Word enquanto o ' Assistente do Word 2000 Office ' foi activado.
  • Feche o documento de Word 2000 clicando no botão Fechar no canto superior esquerdo da janela do documento.
Um conflito de fecho entre o Assistente do Office no Word 2000 e o Word no modelo de suplemento do Works Suite gera a mensagem de erro. Não deverão ter qualquer perda de dados deste comportamento.

Resolução

Para contornar este comportamento, utilize os seguintes métodos pela ordem em que são apresentados.

Activar desactivar Office Assistente e recriar o documento do Word 2000

Para desactivar o Assistente do Office e o documento recriar o Word 2000:
  1. Inicie o Works Suite.
  2. No painel de tarefas do Works Suite, clique no separador programas e, em seguida, clique em Word .
  3. Clique na tarefa que pretende utilizar e, em seguida, clique em Iniciar .
  4. Clique no modelo que pretende utilizar e, em seguida, clique em Concluir .
  5. Abra o documento original do Word 2000.
  6. Seleccione o texto na primeira página do documento.
  7. No menu Editar , clique em Copiar .
  8. Clique no botão da barra de tarefas para mudar para o novo documento.
  9. No documento novo, posicione o ponto de inserção na parte superior da primeira página e, em seguida, clique em Colar no menu Editar .
  10. Clique no botão de barra de tarefas para mudar para o documento original.
  11. Repita os passos 6 a 10 para cada página que tiver de recriar no novo documento.
  12. Novo documento, clique em Ocultar o Office Assistant no menu Ajuda .
  13. No menu ficheiro , clique em Guardar como .
  14. Na caixa de diálogo Guardar como , procure a localização onde pretende guardar o documento.
  15. Na caixa nome do ficheiro , escreva um nome para o documento e, em seguida, clique em Guardar .
Nota : Este método não resolve o problema documentos que accionam a mensagem de erro mencionada na secção "Sintomas" deste artigo. Para cada um destes documentos problema, terá de seguir este método para recriar o documento original.

Se não pretender desactivar o Assistente do Office, ou se existirem demasiados documentos para recriar os métodos descritos no método anterior, avance para o método seguinte.

Remover a palavra no suplemento do Works Suite

Para evitar o conflito de fecho que gera a mensagem de erro mencionada na secção "Sintomas" deste artigo, terá de remover o Word de suplemento do Works Suite. Mas antes de continuar com este método, ver a secção "Mais informação" deste artigo para obter informações sobre as desvantagens de remover o Word no suplemento do Works Suite.

Para remover o Word do Works Suite Add-in:
  1. Introduza o Works Suite disco 1 CD-ROM na unidade de CD-ROM. Prima e mantenha premida a tecla SHIFT à medida que insere o CD-ROM para impedir que o Works programa de configuração seja iniciado automaticamente.
  2. Clique em Iniciar , aponte para definições e, em seguida, clique em Painel de controlo .
  3. Faça duplo clique em Adicionar/remover programas .
  4. Clique em Word do Works Suite Add-in e, em seguida, clique em Adicionar/remover .
  5. Clique em seguinte , clique em Remover e, em seguida, clique em seguinte .
  6. Clique em Remover e, em seguida, clique em Concluir .
  7. Clique em OK e, em seguida, feche o painel de controlo.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no início deste artigo.

Mais Informação

A Microsoft recomenda que considere as seguintes desvantagens para remover o Word no suplemento do Works Suite antes de removê-lo.

Quando remover o Word do Works Suite Add-in:
  • Remover o Word 2000 a tarefa do Works Suite painel.
  • Perderá as funções do processador no Works Suite ' Painel de tarefas '.
  • Tem de iniciar o Word 2000 da seguinte forma:

    Clique em Iniciar , aponte para programas e, em seguida, clique em Microsoft Word .
Para reinstalar o Word do Works Suite Add-in:
  1. Faça duplo clique no ícone o Meu computador no ambiente de trabalho.
  2. Clique com o botão direito do rato sobre o ícone da unidade CD-ROM e, em seguida, clique em explorar .
  3. No painel da esquerda, faça duplo clique na pasta WordAdd .
  4. No painel da direita, faça duplo clique em Setup.exe .
  5. Siga as instruções apresentadas no ecrã para reinstalar o Word do Works Suite Add-in.
  6. Saia do Explorador do Windows e, em seguida, feche a janela o Meu computador .

Propriedades

Artigo: 257417 - Última revisão: 14 de fevereiro de 2014 - Revisão: 5.1
A informação contida neste artigo aplica-se a:
  • Microsoft Works Suite 2005 Standard Edition
  • Microsoft Works Suite 2004 Standard Edition
  • Microsoft Works Suite 2003 Standard Edition
  • Microsoft Works Suite 2001 Standard Edition
  • Microsoft Works Suite 2000 Standard Edition
  • Microsoft Works Suite 2006
Palavras-chave: 
kbnosurvey kbarchive kbmt kbaddin kbbug kberrmsg kbpending kbui KB257417 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 257417

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com