Mensagem de erro do Works Suite: Winword causou um falha de página inválido no módulo User32.dll

Traduções deste artigo Traduções deste artigo
ID do artigo: 257417 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você fechar um documento do Microsoft Word 2000, você pode receber uma mensagem de erro informando que uma operação ilegal ocorreu. Quando você clica em detalhes , você recebe a seguinte mensagem de erro:
Winword causou uma falha de página inválida no módulo User32.dll.

Causa

Esse comportamento pode ocorrer se as seguintes condições forem verdadeiras:
  • Abrir um documento Word 2000 que foi criado de uma palavra no modelo de suplemento do Works Suite enquanto o Assistente do Office 2000 Word estava ativado.
  • Fechar o documento de Word 2000 clicando no botão Fechar no canto superior direito da janela do documento.
Um conflito de fechamento entre o Assistente do Office no Word 2000 e do Word no Works Suite Add-in modelo produz a mensagem de erro. Você não deve enfrentar qualquer perda de dados desse comportamento.

Resolução

Para contornar esse comportamento, use os seguintes métodos na ordem em que eles são apresentados.

Ativar desativar Office Assistant e recriar o documento do Word 2000

Para desativar o Assistente do Office e o documento de recriar o Word 2000:
  1. Inicie o Works Suite.
  2. No recurso Iniciar tarefa do Works Suite, clique na guia programas e, em seguida, clique em Word .
  3. Clique na tarefa que você deseja usar e, em seguida, clique em Iniciar .
  4. Clique no modelo que você deseja usar e, em seguida, clique em Concluir .
  5. Abra o documento original do Word 2000.
  6. Selecione o texto na primeira página do documento.
  7. No menu Editar , clique em Copiar .
  8. Clique no botão da barra de tarefas para alternar para o novo documento.
  9. No novo documento, posicione o ponto de inserção na parte superior da primeira página e clique em Colar no menu Editar .
  10. Clique no botão de barra de tarefas para alternar para o documento original.
  11. Repita as etapas 6 a 10 para cada página que você tiver de recriar no novo documento.
  12. No novo documento, clique Ocultar o Office Assistente no menu Ajuda .
  13. No menu arquivo , clique em Salvar como .
  14. Na caixa de diálogo Salvar como , procure o local onde você deseja salvar o documento.
  15. Na caixa nome do arquivo , digite um nome para o documento e, em seguida, clique em Salvar .
Observação : este método não corrige quaisquer documentos com problema que disparam a mensagem de erro mencionada na seção "Sintomas" deste artigo. Para cada um desses documentos com problema, você precisará seguir este método para recriar o documento original.

Se você não deseja desativar o Assistente do Office, ou se houver muitos documentos para recriar da maneira descrita no método anterior, vá para o próximo método.

Remover o Word no Works Suite Add-in

Para evitar o conflito de fechamento que produz a mensagem de erro mencionada na seção "Sintomas" deste artigo, você precisará remover o Word no Works Suite Add-in. Mas antes de continuar com esse método, consulte a seção "Mais informações" deste artigo para obter informações sobre as desvantagens de remover o Word no Works Suite Add-in.

Para remover o Word no Works Suite Add-in:
  1. Insira o Works Suite disco 1 na unidade de CD-ROM. Mantenha pressionada a tecla SHIFT assim que você inserir o CD-ROM para evitar que o Works Instalação inicie automaticamente.
  2. Clique em Iniciar , aponte para configurações e, em seguida, clique em Painel de controle .
  3. Clique duas vezes em Adicionar ou remover programas .
  4. Clique em Word no Works Suite Add-in e, em seguida, clique em Adicionar/remover .
  5. Clique em Avançar , clique em Remover e, em seguida, clique em Avançar .
  6. Clique em Remover e, em seguida, clique em Concluir .
  7. Clique em OK e feche o painel de controle.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados no começo deste artigo.

Mais Informações

A Microsoft recomenda que você considere as seguintes desvantagens para remover o Word no Works Suite Add-in antes de você removê-lo.

Quando você remover o Word no Works Suite Add-in:
  • Você remover o Word 2000 do Works Suite tarefa iniciar.
  • Você perderá as funções de processador no Works Suite recurso Iniciar tarefa.
  • Deve iniciar o Word 2000 da seguinte maneira:

    Clique em Iniciar , aponte para programas e, em seguida, clique em Microsoft Word .
Para reinstalar o Word no Works Suite Add-in:
  1. Clique duas vezes no ícone Meu computador na área de trabalho.
  2. Clique com o botão direito do mouse no ícone de unidade de CD-ROM e, em seguida, clique em explorar .
  3. No painel a esquerda, clique duas vezes na pasta WordAdd .
  4. No painel direito, clique duas vezes em Setup.exe .
  5. Siga as instruções na tela para reinstalar o Word no Works Suite Add-in.
  6. Feche o Windows Explorer e, em seguida, feche a janela Meu computador .

Propriedades

ID do artigo: 257417 - Última revisão: domingo, 20 de outubro de 2013 - Revisão: 5.1
A informação contida neste artigo aplica-se a:
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004 Standard Edition
  • Microsoft Works Suite 2003 Standard Edition
  • Microsoft Works Suite 2001 Standard Edition
  • Microsoft Works Suite 2000 Standard Edition
  • Microsoft Works Suite 2006
Palavras-chave: 
kbnosurvey kbarchive kbmt kbaddin kbbug kberrmsg kbpending kbui KB257417 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 257417

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com