Der Remotedesktop-Gatewayserver-Dienst blockiert fälschlicherweise ein Benutzerkonto, dessen Name lokalisierte Zeichen in Windows Server 2008 R2 enthält

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Artikel-ID: 2578133 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Sie konfigurieren einen Server mit Web Access (RD-Webzugriff) auf einem Computer, auf der Windows Server 2008 R2 ausgeführt wird.
  • Verwenden Sie ein Benutzerkonto auf einem Remotedesktopserver über Web Access für Remotedesktop-Server herstellen.
  • Der Namen des Benutzerkontos enthält lokalisierte Zeichen.
In diesem Szenario können nicht Sie mit dem remote desktop-Server verbinden. Darüber hinaus wird die folgende Fehlermeldung angezeigt:
Remote Desktop kann nicht mit dem Remotecomputer verbinden"Name> "dieser Gründen:

1) Ihr Benutzerkonto ist nicht autorisiert, auf dem RD-Gateway zugreifen "Name>"
2) Auf Ihrem Computer ist nicht autorisiert, auf dem RD-Gateway zugreifen"Name>"
3) Sie verwenden inkompatible Authentifizierungsmethode (z. B. die RD-Gateway eine Smartcard erwartet werden kann, aber Sie ein Kennwort angegeben)

Wenden Sie sich an Ihren Netzwerkadministrator, um Unterstützung zu erhalten.

Ursache

Dieses Problem tritt auf, weil der Remotedesktop-Gatewayserver-Dienst eine falsche Methode verwendet, um Benutzer Namenszeichen zu codieren.

Der Remotedesktop-Gatewayserver-Dienst nutzt die Vorteile des Dienstes (Network Policy Server, NPS) zur Authentifizierung von Benutzeranfragen. Der Remotedesktop-Gatewayserver-Dienst codieren jedoch nicht Zeichen für Benutzer mithilfe der encoding-Methode, die der NPS-Dienst verwendet. Daher wird der Benutzer kann keine Verbindung zum remote desktop-Server herstellen und sie erhalten eine Fehlermeldung.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Dieser Hotfix ist jedoch nur das Problem zu beheben, das in diesem Artikel beschriebenen vorgesehen. Wenden Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix möglicherweise weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist gibt es ein Abschnitt "Hotfixdownload available" (Hotfixdownload verfügbar"am oberen Rand dieser Knowledge Base-Artikel. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Support-Kosten gilt für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage zu erstellen finden Sie auf die folgende Microsoft-Website:
http://support.Microsoft.com/contactus/?WS=Support
Hinweis Das Formular "Hotfixdownload available" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, ist es, da ein Hotfix nicht für diese Sprache verfügbar ist.

Voraussetzungen

Um diesen Hotfix anwenden zu können, müssen Sie eine der folgenden Betriebssysteme ausgeführt werden:
  • WindowsServer 2008 R2
  • Windows Server 2008 R2 Servicepack 1 (SP1)
Darüber hinaus muss der Remotedesktopgateway-Rollendienst auf dem Computer installiert werden.

Weitere Informationen dazu, wie Sie ein Windows Server 2008 R2 Servicepack zu erhalten, klicken Sie auf die folgenden Artikelnummer der Microsoft Knowledge Base:
976932Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Informationen zur Registrierung

Um den Hotfix in diesem Paket verwenden zu können, müssen Sie keinen Änderungen an der Registrierung vornehmen.

Neustart erforderlich ist.

Sie müssen nicht den Computer neu starten, nachdem Sie diesen Hotfix anwenden. Allerdings müssen Sie den Remotedesktop-Gatewayserver-Dienst zu beenden, bevor Sie den Hotfix, um zu vermeiden, einen Neustart des Computers installieren.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit die Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datumsangaben und Uhrzeiten für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Berücksichtigung der aktuellen Daylight Saving Time (DST) angezeigt. Darüber hinaus können die Datums- und Uhrzeitangaben ändern, wenn Sie bestimmte Operationen auf die Dateien ausführen.
Hinweise zu den Dateiinformationen für Windows Server 2008 R2
Wichtig Windows 7-Updates und Windows Server 2008 R2-Hotfixes sind im selben Paket enthalten. Allerdings sind Hotfixes, die auf der Seite Hotfix Anforderung unter beiden Betriebssystemen aufgeführt. Wenn das Hotfix-Paket, das auf eine oder beide Betriebssysteme angewendet wird, aktivieren Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 R2" aufgeführt ist. Beachten Sie im Abschnitt "Gilt für" in Artikel, um das aktuelle Betriebssystem bestimmen, dem für jeden Hotfix gilt.
  • Die Dateien für bestimmte Produkte, SR_Level (RTM, SP geltenn), und Servicebereiche (LDR, GDR) identifiziert werden kann, indem Sie die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt.
    Tabelle minimierenTabelle vergrößern
    VersionProduktSR_LevelServicebereich
    6.1.760 0. 17xxxWindowsServer 2008 R2RTMDDR
    6.1.760 0 . 21xxxWindowsServer 2008 R2RTMLDR
    6.1.760 1 . 17xxxWindowsServer 2008 R2SP1DDR
    6.1.760 1 . 22xxxWindowsServer 2008 R2SP1LDR
  • Die MANIFESTEN-Dateien (. Manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sind. separat aufgeführt im Abschnitt "Weitere Dateiinformationen für WindowsServer 2008 R2". MUM- und MANIFEST-Dateien sowie die zugehörigen Sicherheitskatalogdateien (.cat) Dateien sind sehr wichtig, den Status der aktualisierten Komponenten zu verwalten. Die Sicherheitskatalogdateien, die die Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten x 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameVersion der DateiGröße der DateiDatumZeitPlattform
Aaedge.dll6.1.7600.17045305,66416-Jun-201205: 23X 64
Aatspp.dll6.1.7600.1704565,02416-Jun-201205: 23X 64
Tsproxy-Edgeadapter-ppdlic.xrm-msNicht zutreffend3,01816-Jun-201205: 39Nicht zutreffend
Aaedge.dll6.1.7600.21238305,66416-Jun-201205: 28X 64
Aatspp.dll6.1.7600.2123865,02416-Jun-201205: 28X 64
Tsproxy-Edgeadapter-ppdlic.xrm-msNicht zutreffend3,01816-Jun-201205: 47Nicht zutreffend
Aaedge.dll6.1.7601.17866308,73616-Jun-201205: 15X 64
Aaedge.MOFNicht zutreffend1.26805-Nov-201001: 52Nicht zutreffend
Aatspp.dll6.1.7601.1786665,02416-Jun-201205: 15X 64
Aatspp.MOFNicht zutreffend1.27105-Nov-201001: 52Nicht zutreffend
RAP.XmlNicht zutreffend89505-Nov-201001: 52Nicht zutreffend
Tsgateway.XmlNicht zutreffend42905-Nov-201001: 52Nicht zutreffend
Tsproxy-Edgeadapter-ppdlic.xrm-msNicht zutreffend3,01816-Jun-201205: 31Nicht zutreffend
Aaedge.dll6.1.7601.22024308,22416-Jun-201205: 28X 64
Aaedge.MOFNicht zutreffend1.26805-Nov-201001: 52Nicht zutreffend
Aatspp.dll6.1.7601.2202465,02416-Jun-201205: 28X 64
Aatspp.MOFNicht zutreffend1.27105-Nov-201001: 52Nicht zutreffend
RAP.XmlNicht zutreffend89505-Nov-201001: 52Nicht zutreffend
Tsgateway.XmlNicht zutreffend42905-Nov-201001: 52Nicht zutreffend
Tsproxy-Edgeadapter-ppdlic.xrm-msNicht zutreffend3,01816-Jun-201205: 58Nicht zutreffend

Abhilfe

Um dieses Problem zu umgehen, benennen Sie das Benutzerkonto, um die lokalisierten Zeichen zu entfernen. Dieses Problem tritt nicht auf, wenn alle Benutzer Namenszeichen aus dem ASCII-Zeichen festgelegt werden.

Status

Microsoft hat bestätigt, dass dieses Problem auf die im Abschnitt "Gilt für" aufgeführten Microsoft-Produkte zutrifft.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates klicken Sie auf die folgende Artikelnummer klicken, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Microsoft-Softwareupdates verwendet wird
Weitere Informationen über Web Access für Remotedesktop finden Sie auf die folgende Microsoft TechNet-Website:
Allgemeine Informationen über Web Access für Remotedesktop

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows Server 2008 R2

Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameAmd64_153cbfa19d565d1904f821714c5d6e3e_31bf3856ad364e35_6.1.7601.17866_none_df7cab310b5f5c25.Manifest
Version der DateiNicht zutreffend
Größe der Datei711
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameAmd64_8aa2b9486e7ea13f0cdc1efdca3a3bef_31bf3856ad364e35_6.1.7600.17045_none_5ed2f6f0b97f0b7d.Manifest
Version der DateiNicht zutreffend
Größe der Datei711
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameAmd64_9218468266efff1e808ef37e470ff71d_31bf3856ad364e35_6.1.7601.22024_none_ceaead278ad767ce.Manifest
Version der DateiNicht zutreffend
Größe der Datei711
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameAmd64_96451ee4c4ef13188298470d22bf77c4_31bf3856ad364e35_6.1.7600.21238_none_94f230f18e70a7a6.Manifest
Version der DateiNicht zutreffend
Größe der Datei711
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-Tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.17045_none_9a2a8846e64608a1.manifest
Version der DateiNicht zutreffend
Größe der Datei99,560
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-Tsproxy-edgeadapter_31bf3856ad364e35_6.1.7600.21238_none_9ac1f7c1ff58d5a6.manifest
Version der DateiNicht zutreffend
Größe der Datei99,560
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-Tsproxy-edgeadapter_31bf3856ad364e35_6.1.7601.17866_none_9bfc6f82e37b8fab.manifest
Version der DateiNicht zutreffend
Größe der Datei99,560
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameAmd64_microsoft-Windows-Tsproxy-edgeadapter_31bf3856ad364e35_6.1.7601.22024_none_9caf238bfc7ac045.manifest
Version der DateiNicht zutreffend
Größe der Datei99,560
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameUpdate-bf.mum
Version der DateiNicht zutreffend
Größe der Datei1.921
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend
DateinameUpdate.mum
Version der DateiNicht zutreffend
Größe der Datei1.959
Datum (UTC)16-Jun-2012
Zeit (UTC)09: 33
PlattformNicht zutreffend

Eigenschaften

Artikel-ID: 2578133 - Geändert am: Mittwoch, 15. August 2012 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2578133 KbMtde
Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2578133
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