Artikel-ID: 257859 - Geändert am: Dienstag, 6. September 2005 - Version: 4.0

BitWare verursacht Programmfehler bei Spoolsv.exe in Windows

Dieser Artikel wurde zuvor veröffentlicht unter D257859
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
257859  (http://support.microsoft.com/kb/257859/EN-US/ ) BitWare Causes Spoolsv.exe Program Error in Windows
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie in folgendem Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/DE/ ) Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Die folgende Fehlermeldung wird möglicherweise angezeigt, wenn Sie Ihren Computer starten oder versuchen, einen Drucker zu verwenden bzw. ein Programm zu starten, das mit einem Drucker interagiert:
Spoolsv.exe hat Fehler verursacht und wird geschlossen. Starten Sie das Programm neu. Ein Fehlerprotokoll wird erstellt.
Der Spooler-Dienst wird anschließend angehalten, kann jedoch neu gestartet werden. Wenn der Spooler angehalten wird, erscheint die folgende Fehlermeldung:
Der Vorgang kann aufgrund mangelnder Ressourcen nicht fortgesetzt werden.

Ursache

Es kann zu dieser Situation kommen, wenn BitWare für Windows installiert ist. Die aktuellen Versionen von BitWare sind 3.30 und 7.0. Diese sind nicht vollständig mit den Versionen von Windows kompatibel, die im Abschnitt "Die Informationen in diesem Artikel beziehen sich auf" aufgeführt sind. Um zu prüfen, ob BitWare ausgeführt wird, suchen Sie im Task-Manager nach Instanzen der Datei Bwagent.exe oder Bwprnmon.exe.

Lösung

Warnung: Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende, das gesamte System betreffende Probleme verursachen, die eine Neuinstallation Ihres Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.
Die Deinstallation der BitWare-Software stellt die beste Maßnahme dar. Sie steht jedoch nicht für alle Versionen zur Verfügung.

Falls keine Deinstallation verfügbar ist, können Sie sämtliche Registrierungseinträge und Treiber, die sich auf BitWare beziehen, manuell entfernen:
  1. Starten Sie den Registrierungseditor (Regedt32.exe).
  2. Suchen Sie Verweise auf BitWare in den folgenden Registrierungsschlüsseln:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-2

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Monitors

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Printers
  3. Klicken Sie im Menü Bearbeiten auf Löschen für jeden BitWare-Unterpunkt.
  4. Beenden Sie den Registrierungs-Editor.
  5. Löschen Sie alle BitWare-Treiber aus dem Ordner %SystemRoot%\System32\Spool\Drivers\W32x86.
  6. Starten Sie Windows neu.

Weitere Informationen

Die in diesem Artikel genannten Fremdanbieterprodukte stammen von Herstellern, die von Microsoft unabhängig sind. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Weitere Informationen finden Sie auf der folgenden Website von Computer Associates:
http://www.2point.com/ (http://www.2point.com/)

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
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