Help and Support

文書番号: 257859 - 最終更新日: 2005年9月14日 - リビジョン: 4.0

BitWare により Windows で Spoolsv.exe プログラムのエラーが発生

この記事は、以前は次の ID で公開されていました: JP257859
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
256986? (http://support.microsoft.com/kb/256986/ ) Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

現象

コンピュータの起動時、プリンタの使用時、またはプリンタとの対話を行うプログラムの起動時に、次のエラー メッセージが表示されます。
エラーが発生したため、Spoolsv.exe を終了します。プログラムをもう一度開始する必要があります。エラー ログを作成しています。
その後 Spooler サービスが停止しますが、これは再開することができます。Spooler サービスの停止中には、次のエラー メッセージが表示されます。
リソース不足のため、プリンタの操作を続行できません。

原因

この状況は、BitWare for Windows がインストールされている場合に発生します。BitWare の現行バージョンは 3.30 と 7.0 ですが、いずれもこの資料の対象製品の一覧に記載されたバージョンの Windows と完全には互換性がありません。BitWare を実行しているかどうかを確認するには、タスク マネージャで Bwagent.exe または Bwprnmon.exe のインスタンスを探します。

解決方法

警告 : レジストリ エディタの使い方を誤ると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリ エディタの誤用により発生した問題に関しては、一切責任を負わないものとします。レジストリ エディタは、自己の責任においてご使用ください。
BitWare ソフトウェアをアンインストールするのが最善の解決方法ですが、一部のバージョンではアンインストールを行うことができません。

アンインストールができない場合は、次の手順を実行して、BitWare に関するレジストリ エントリとドライバをすべて手動で削除します。
  1. レジストリ エディタ (Regedt32.exe) を起動します。
  2. レジストリ内の以下のキーで、BitWare への参照を見つけます。
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-2

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Monitors

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Printers
  3. BitWare サブツリーごとに、[編集] メニューの [削除] をクリックします。
  4. レジストリ エディタを終了します。
  5. %SystemRoot%\System32\Spool\Drivers\W32x86 フォルダからすべての BitWare ドライバを削除します。
  6. Windows を再起動します。

詳細

この資料に記載されているサードパーティ製品は、マイクロソフトと関連のない他社の製品です。明示または黙示にかかわらず、これらの製品のパフォーマンスや信頼性についてマイクロソフトはいかなる責任も負わないものとします。

詳細については、次の ACCPAC の Web サイトを参照してください。
http://www.2point.com/ (http://www.2point.com/)

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 257859? (http://support.microsoft.com/kb/257859/EN-US/ ) (最終更新日 2005-08-12) を基に作成したものです。

この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
キーワード:?
kbappdev kbdriver kbfax kbperformance kbprb kbprint KB257859
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳

 

Related Support Centers