Artigo: 257859 - Última revisão: sexta-feira, 23 de Dezembro de 2005 - Revisão: 4.0

BitWare provoca um erro no programa Spoolsv.exe no Windows

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Este artigo foi publicado anteriormente em PT257859
Importante: este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o pode restaurar se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
256986  (http://support.microsoft.com/kb/256986/PT/ ) Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Sintomas

Poderá receber a seguinte mensagem de erro quando efectuar o arranque do computador, tentar utilizar uma impressora ou iniciar um programa que interage com uma impressora:
Spoolsv.exe gerou erros e irá ser fechado pelo Windows. Necessita de reiniciar o programa. Está a ser criado um registo de erros.
Em seguida, o serviço Spooler pára, mas pode ser reiniciado. Enquanto o spooler está parado, é gerada a mensagem de erro seguinte:
A operação de impressora não pode continuar devido à falta de recursos.

Causa

Esta situação poderá ocorrer se o software BitWare for Windows estiver instalado. As versões actuais do BitWare são a 3.30 e 7.0, que não são completamente compatíveis com as versões do Windows listadas na secção "Aplica-se a" deste artigo. Para verificar se o BitWare se encontra em execução, procure instâncias dos programas Bwagent.exe ou Bwprnmon.exe no Gestor de tarefas.

Resolução

AVISO: a utilização incorrecta do Editor de registo poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. Todo e qualquer risco decorrente da utilização do Editor de registo é da responsabilidade do utilizador.
A acção mais recomendável consiste em desinstalar o software BitWare, mas esta opção não está disponível para todas as versões.

Se a desinstalação não estiver disponível, poderá eliminar manualmente todas as entradas do registo e os controladores referentes ao BitWare:
  1. Inicie o Editor de registo (Regedt32.exe).
  2. Localize as referências ao BitWare nas seguintes chaves do registo:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Environments\Windows NT x86\Drivers\Version-2

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Monitors

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Printers
  3. No menu Editar, clique em Eliminar para cada subárvore do BitWare.
  4. Saia do Editor de registo.
  5. Elimine todos os controladores BitWare da pasta %SystemRoot%\System32\Spool\Drivers\W32x86.
  6. Reinicie o Windows.

Mais Informação

Os produtos de outros fabricantes referidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não concede nenhuma garantia, implícita ou de outra natureza, relativamente ao desempenho ou à fiabilidade destes produtos.

Para mais informações, consulte o seguinte Web site da Computer Associates:
http://www.2point.com/ (http://www.2point.com/)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
kbappdev kbdriver kbfax kbperformance kbprb kbprint KB257859