Event 4999 is generated when clients try to connect using Exchange Web Services

Article ID: 2579159 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

Symptoms

Some clients that connect using Exchange Web Services may be unable to connect to Exchange. When the issue occurs, the following event is generated in the application log of the Client Access Server:

Source: MSExchange Common
Category: General
Event ID: 4999
Description:
Watson report about to be sent to dw20.exe for process id: xxxx, with parameters: E12IIS, c-RTL-AMD64, 08.02.0176.002, WS, M.E.Services, M.E.S.C.PerfCounterReader.FindCountersForProcess, System.FormatException, fe65, 08.02.0254.000. ErrorReportingEnabled: False.

Cause

This issue has been known to occur when Performance counters on the Exchange server become corrupted.

Resolution

Rebuild the Windows Performance Counter Library values on the Client Access Server(s).

WARNING:  When rebuilding the Windows Performance Library values you may wipe the Exchange Server 2007 counters and these need to be rebuilt as well.  If any third party software is installed on the server, and that software uses its own performance counters, you may need to contact the software vendor for assistance in rebuilding the counters.

Use the following steps to resolve the issue for Windows Server 2003 and Windows 2008 (Windows 2008 R2 is not included):

1. Launch the Windows Command Prompt (cmd), ensure that you run the Command Prompt as the Administrator. For example, click Start, click All Programs, click Accessories, right click Command Prompt and click Run As Administrator.

2. Change Directory to <root drive>\Windows\System32, the root drive is typically C:.  Run the following command

lodctr /R

This will restore the base or core counters

3. Check the registry value under HKLM/Software/Microsoft/WindowsNT/CurrentVersion/Perflib/009 and ensure that the value Counter is no longer corrupted.

4. In the Command Prompt window, run the following command:

wmiadap /f

This will force the reload of all counters in to the WMI repository.

5. Open Performance Monitor (perfmon.exe) and click the green + to Add, this will open Add Counters. Verify that the MSExchange counters exist and have Instances populated.

6. Restart the Microsoft Exchange Server computer.

NOTE: This step is required.

More information

How to manually rebuild Performance Counter Library values (Win2k3)
http://support.microsoft.com/kb/300956

How to fix/repair broken Exchange 2007 counters
http://blogs.technet.com/b/mikelag/archive/2009/10/21/how-to-fix-repair-broken-exchange-2007-counters.aspx
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2579159 - Last Review: November 2, 2013 - Revision: 3.0
Applies to
  • Microsoft Exchange Server 2007 Service Pack 2
Keywords: 
kbnosurvey kbarchive kbsurveynew KB2579159

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com