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Screen Saver Policy May Not Be Applied

Article ID:257939
Last Review:February 19, 2007
Revision:3.3
This article was previously published under Q257939

SYMPTOMS

The screen saver settings for a user or group policy may not be applied.

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CAUSE

The problem occurs because this policy is now applied in the registry to the following key:
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop
Instead of directly to the following key:
HKEY_CURRENT_USER\Control Panel\Desktop
But the user code component (Win32k.sys) was not modified to check the policy key location when reading the screen saver information.

Also, the original Group Policy snap-in System Administration template (System.adm) sets the ScreenSaveActive and ScreenSaverIsSecure values using REG_DWORD values instead of REG_SZ values, therefore the user mode component (Win32k.sys) does not apply the screen saver policy unless the policy is created by using the new updated System.adm administration template.

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RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 (http://support.microsoft.com/kb/260910/EN-US/) How to Obtain the Latest Windows 2000 Service Pack


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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was first corrected in Windows 2000 Service Pack 1.

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MORE INFORMATION

For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149 (http://support.microsoft.com/kb/249149/EN-US/) Installing Microsoft Windows 2000 and Windows 2000 Hotfixes

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition

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Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000sp1fix KB257939

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