可能未被应用屏幕保护程序策略

文章翻译 文章翻译
文章编号: 257939 - 查看本文应用于的产品
展开全部 | 关闭全部

症状

屏幕保护程序设置为用户或组策略可能不会应用。

原因

出现该问题的原因是此策略现在在注册表中应用到下列项:
HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop
而不是直接到以下项:
HKEY_CURRENT_USER\Control Panel\Desktop
但是,用户代码组件 (Win32k.sys) 没有被修改时读取屏幕保护程序信息,请检查策略项位置。

而且,将原始组策略管理单元系统管理模板 (System.adm) 集 ScreenSaveActive 和 ScreenSaverIsSecure 值使用 REG_DWORD 值而不 REG_SZ 值,因此用户模式组件 (Win32k.sys) 不应用屏幕保护程序策略除非该策略创建由使用新的更新 System.adm 管理模板。

解决方案

若要解决此问题,获得最新的 service pack,对于 Windows 2000。有关更多的信息请单击下面的文章编号,以查看 Microsoft 知识库中相应的文章:
260910如何获取最新的 Windows 2000 服务软件包


状态

Microsoft 已经确认这是在本文开头列出的 Microsoft 产品中的问题。

Windows 2000 Service Pack 1 中,第一次已得到纠正此问题。

更多信息

有关如何一次安装 Windows 2000 和 Windows 2000 修补程序的其他信息请单击下面文章编号,以查看 Microsoft 知识库中相应的文章:
249149安装 Microsoft Windows 2000 和 Windows 2000 程序修补程序

属性

文章编号: 257939 - 最后修改: 2007年2月19日 - 修订: 3.3
这篇文章中的信息适用于:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
关键字:?
kbmt kbhotfixserver kbqfe kbbug kbfix kbqfe kbwin2000sp1fix KB257939 KbMtzh
机器翻译
注意:这篇文章是由无人工介入的微软自动的机器翻译软件翻译完成。微软很高兴能同时提供给您由人工翻译的和由机器翻译的文章, 以使您能使用您的语言访问所有的知识库文章。然而由机器翻译的文章并不总是完美的。它可能存在词汇,语法或文法的问题,就像是一个外国人在说中文时总是可能犯这样的错误。虽然我们经常升级机器翻译软件以提高翻译质量,但是我们不保证机器翻译的正确度,也不对由于内容的误译或者客户对它的错误使用所引起的任何直接的, 或间接的可能的问题负责。
点击这里察看该文章的英文版: 257939
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com