Article ID: 258034 - Last Review: January 27, 2007 - Revision: 2.2 OLEXP: Error Message: Msimn.exe Has Generated Errors and Will Be Closed by WindowsThis article was previously published under Q258034 For information about the differences between Microsoft Outlook Express and Microsoft Outlook e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base: 257824
(http://support.microsoft.com/kb/257824/EN-US/
)
OL2000: Differences Between Outlook and Outlook Express On This PageSYMPTOMS
When you use Outlook Express, you may receive any of the following error messages:
Msimn.exe has generated errors and will be closed by Windows.
You will need to restart the program. An error log is being created.
MSIMN caused an invalid page fault in module MSOE.DLL.
CAUSE
This error may be a result of one of the following circumstances:
RESOLUTION
Before you resolve this problem, it is recommended that you back up your messages and addresses. For additional information about backing up messages and addresses, click the article numbers below
to view the articles in the Microsoft Knowledge Base:
270670
(http://support.microsoft.com/kb/270670/EN-US/
)
How to Back Up and Recover Outlook Express Data
175017
(http://support.microsoft.com/kb/175017/EN-US/
)
How to Import and Export Address Books in Outlook Express
To resolve this issue, first ensure that your .DBX files are not Read Only. If the issue remains unresolved, then regenerate the identities registry key. The steps to do this follow.
Ensure that your .DBX files are not Read OnlyYour .DBX files are the store files for your Outlook Express folders. If your files are marked as Read Only, they cannot be accessed. An example of a cause of this would be if you recently restored the files from a backup on a CD-ROM. To remove the Read Only attribute, perform the following steps:
Drive:\Documents and Settings\username\Local Settings\Application Data\Identities\{114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}\Microsoft\Outlook Express
-or-
Drive:\Windows\Application Data\Identities\{114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}\Microsoft\Outlook Express
where Drive is the letter of the drive.The GUID number above, {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}, is an example only. Your findings will vary. Regenerating the Identities Registry KeyImportant This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:322756
(http://support.microsoft.com/kb/322756/
)
How to back up and restore the registry in Windows To regenerate the Identities registry key:
MORE INFORMATION
In the event that multiple Identities exist on your system, use the following steps to determine the GUID number (such as the one displayed above {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6} as an example):
APPLIES TO
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