OLEXP: Fehlermeldung: "Msimn.exe" hat Fehler verursacht und wird geschlossen

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Artikel-ID: 258034 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
258034 OLEXP: Error Message: Msimn.exe Has Generated Errors and Will Be Closed by Windows
Weitere Informationen zu den Unterschieden zwischen den E-Mail-Clients Microsoft Outlook und Microsoft Outlook Express finden Sie im folgenden Artikel der Microsoft Knowledge Base:
257824 OL2002: Unterschiede zwischen Outlook und Outlook Express
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986 Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn Sie mit Outlook Express arbeiten, kann eine der folgenden Fehlermeldungen angezeigt werden:
"Msimn.exe" hat Fehler verursacht und wird geschlossen. Starten Sie das Programm neu. Ein Fehlerprotokoll wird erstellt.
-oder-
MSIMN verursachte einen Fehler durch eine ungültige Seite in Modul MSOE.DLL.

Ursache

Dieser Fehler kann die folgenden Ursachen haben:
  • Ihre .DBX-Dateien sind schreibgeschützt.
  • Der Schlüssel "Identities" in der Registrierung ist beschädigt.

Lösung

Bevor Sie mit der Problembehandlung beginnen, sollten Sie Sicherungskopien Ihrer Nachrichten und Adressen erstellen. Weitere Informationen zum Erstellen von Sicherungskopien Ihrer Nachrichten und Adressen finden Sie in den folgenden Artikeln der Microsoft Knowledge Base:
270670 Sichern und Wiederherstellen von Outlook Express-Daten
175017 OLEXP: Importieren und Exportieren von Adressbüchern in Outlook Express
Vergewissern Sie sich, dass Ihre .DBX-Dateien nicht schreibgeschützt sind, bevor Sie mit der eigentlichen Problembehandlung beginnen. Wenn das Problem weiterhin ungelöst ist, erstellen Sie den Registrierungsschlüssel "Identities" neu. Wie Sie dies tun können, wird an späterer Stelle in diesem Artikel beschrieben.

Stellen Sie sicher, dass Ihre .DBX-Dateien nicht schreibgeschützt sind

In den .DBX-Dateien sind Ihre Outlook Express-Ordner gespeichert. Sind diese .DBX-Dateien schreibgeschützt, ist ein Zugriff auf die Ordner nicht möglich. Dies kann zum Beispiel der Fall sein, wenn Sie kürzlich Ihre Dateien aus Sicherungskopien wiederhergestellt haben, die auf einer CD-ROM gespeichert waren. Gehen Sie folgendermaßen vor, um den Schreibschutz für diese Dateien aufzuheben:
  1. Klicken Sie auf Start, auf Suchen und anschließend auf Dateien/Ordner.
  2. Geben Sie im Feld Name die Zeichenfolge *.dbx ein, und legen Sie anschließend fest, dass die lokalen Festplatten in den Suchvorgang einbezogen werden.
  3. Klicken Sie auf Jetzt suchen bzw. auf Suche starten. Wenn die Suchergebnisse angezeigt werden, klicken Sie bitte auf die Spaltenüberschrift Im Ordner, um die gefundenen Elemente nach Ihrem jeweiligen Speicherort ordnen zu lassen. Notieren Sie sich, in welchem Ordner die gefundenen Dateien gespeichert sind, und navigieren Sie dann mit Windows Explorer zu diesem Ordner.
  4. Klicken Sie mit der rechten Maustaste auf die erste Datei in diesem Ordner, klicken Sie auf der Registerkarte Allgemein auf Eigenschaften, deaktivieren Sie das Kontrollkästchen Schreibgeschützt, und klicken Sie anschließend auf OK.
  5. Wiederholen Sie Schritt 4 für alle weiteren Dateien in dem Ordner, und testen Sie danach Outlook Express.
Hinweis: Standardmäßig sind diese Dateien in einem Ordner "Identities" unter einem Pfad gespeichert, der dem folgenden ähnelt:
Laufwerk:\Dokumente und Einstellungen\Benutzername\Lokale Einstellungen\Anwendungsdaten\Identities\{114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}\Microsoft\Outlook Express
-oder-
Laufwerk:\Windows\Anwendungsdaten\Identities\{114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}\Microsoft\Outlook Express
Dabei steht Laufwerk für den jeweiligen Laufwerksbuchstaben.

Die vorstehende GUID-Nummer {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6} ist nur ein unverbindliches Beispiel. Ihre Suchergebnisse werden davon abweichen.

Wiederherstellung des Registrierungsschlüssels "Identities"

Achtung: Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallierung des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungs-Editors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.

Gehen Sie folgendermaßen vor, um den Registrierungsschlüssel Identities neu erstellen zu lassen:
  1. Klicken Sie auf die Schaltfläche Start, klicken Sie auf Ausführen, und geben Sie dann regedit ein. Klicken Sie auf OK.
  2. Gehen Sie zu dem folgenden Registrierungsschlüssel:
    HKEY_CURRENT_USER/Identities
  3. Klicken Sie im Menü Registrierung auf Registrierungsdatei exportieren.
  4. Klicken Sie im Dialogfeld Speichern in auf Desktop.
  5. In das Feld Dateiname geben Sie Identities ein. Klicken Sie anschließend auf Speichern.
  6. Klicken Sie im Registrierungseditor mit der rechten Maustaste auf den Registrierungsschlüssel Identities, und klicken Sie danach auf Löschen.
  7. Beenden Sie den Registrierungseditor und starten Sie Outlook Express, um das Programm auf korrekte Funktionalität zu testen.
Jetzt können Sie Ihre Nachrichten, Adressen und Konteneinstellungen wiederherstellen.

Weitere Informationen

Falls auf Ihrem Computer mehrere Identitäten definiert sind, gehen Sie bitte wie folgt vor, um die entsprechende GUID-Nummer zu ermitteln (wie die vorstehend als Beispiel angegebene GUID-Nummer {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}):
  1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie regedit ein, und klicken Sie anschließend auf OK.
  2. Gehen Sie zu dem folgenden Registrierungsschlüssel:
    HKEY_CURRENT_USER/Identities
  3. Klicken Sie auf das + (Pluszeichen) neben Identities.
  4. Klicken Sie auf die GUID-Nummer im linken Fenster, um zu ermitteln, welche GUID zu welcher Identität gehört. Im rechten Fenster suchen Sie dann nach dem Eintrag "Benutzername" (dies ist der Name der Outlook Express-Identität).

Eigenschaften

Artikel-ID: 258034 - Geändert am: Donnerstag, 17. November 2005 - Version: 2.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.01 Service Pack 2
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.02
  • Microsoft Outlook Express 5.01 Service Pack 1
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kbprb KB258034
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