Id. de artículo: 258034 - Última revisión: miércoles, 19 de octubre de 2005 - Versión: 2.0

OLEXP: Mensaje de error: Msimn.exe ha generado errores y será cerrado por Windows

Este artículo se publicó anteriormente con el número E258034
Para obtener información acerca de las diferencias entre los clientes de correo electrónico Microsoft Outlook Express y Microsoft Outlook, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
257824  (http://support.microsoft.com/kb/257824/ ) OL2000: Diferencias entre Outlook y Outlook Express
IMPORTANTE: este artículo contiene información acerca de cómo modificar el Registro. Antes de hacerlo, asegúrese de que hace una copia de seguridad del mismo y de que sabe cómo restaurarlo en caso de que surja algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad, restaurar y editar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Definición del Registro de Microsoft Windows

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Síntomas

Cuando utiliza Outlook Express, puede recibir cualquiera de los mensajes de error siguientes:
Msimn.exe ha generado errores y será cerrado por Windows. Debe reiniciar el programa. Se creará un registro de errores.
O bien
MSIMN provocó un error de página no válida en el módulo MSOE.DLL.

Causa

Este error puede ser consecuencia de una de las circunstancias siguientes:
  • Los archivos .DBX están marcados como de Sólo lectura.
  • La clave Identities del Registro está dañada.

Solución

Antes de resolver este problema, se recomienda hacer copia de seguridad de los mensajes y las direcciones. Para obtener información adicional acerca de cómo hacer copias de seguridad de los mensajes y las direcciones, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
270670  (http://support.microsoft.com/kb/270670/ ) Cómo hacer copia de seguridad y recuperar datos de Outlook Express
175017  (http://support.microsoft.com/kb/175017/ ) Cómo importar y exportar Libretas de direcciones en Outlook Express
Para resolver este problema, asegúrese primero de que los archivos .DBX no son de Sólo lectura. Si el problema persiste, vuelva a generar la clave de identidades del Registro. A continuación se describen los pasos que debe seguir.

Asegurarse de que los archivos .DBX no son de Sólo lectura

Los archivos .DBX son los archivos de almacenamiento de las carpetas de Outlook Express. Si estos archivos están marcados como de Sólo lectura, no se puede tener acceso a ellos. Esto podría suceder, por ejemplo, si restauró los archivos recientemente desde una copia de seguridad en CD-ROM. Para quitar el atributo de Sólo lectura, siga estos pasos:
  1. Haga clic en Inicio, en Buscar y, a continuación, haga clic en Archivos y carpetas.
  2. En el campo Nombre, escriba *.dbx y, a continuación, configure la búsqueda de forma que se incluyan las unidades de disco duro locales.
  3. Haga clic en Buscar ahora y, cuando se muestren los resultados, haga clic en el encabezado de la columna En la carpeta para agrupar los elementos según su ubicación. Anote la ubicación de los archivos encontrados y utilice el Explorador de Windows para desplazarse hasta el directorio que contiene su almacén actual.
  4. Haga clic con el botón secundario del mouse (ratón) en el primer archivo de la carpeta, haga clic en Propiedades, en la ficha General, desactive la casilla de verificación Sólo lectura y, a continuación, haga clic en Aceptar.
  5. Repita el paso 4 para cada archivo de la carpeta y pruebe Outlook Express.
Nota: de manera predeterminada, los archivos se almacenan en una carpeta Identities bajo una ruta similar a una de las siguientes:
Unidad:\Documents and Settings\nombre de usuario\Configuración local\Datos de programa\Identities\{114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}\Microsoft\Outlook Express
O bien
Unidad:\Windows\Datos de programa\Identities\{114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}\Microsoft\Outlook Express
donde Unidad es la letra de la unidad.

El número GUID anterior, {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}, es sólo un ejemplo. Los resultados de su búsqueda variarán.

Volver a generar la clave Identities del Registro

ADVERTENCIA: la utilización incorrecta del Editor del Registro puede provocar problemas graves que hagan necesario volver a instalar el sistema operativo. Microsoft no garantiza que pueda solucionar los problemas resultantes del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.

Para volver a generar la clave Identities del Registro:
  1. Haga clic en el botón Inicio, haga clic en Ejecutar y, a continuación, escriba regedit. Haga clic en Aceptar.
  2. Desplácese por el Registro hasta llegar a la clave siguiente:
    HKEY_CURRENT_USER/Identities
  3. En el menú Registro, haga clic en Exportar archivo del Registro.
  4. En el cuadro Guardar en, haga clic en Escritorio.
  5. En el cuadro Nombre de archivo, escriba Identities y haga clic en Guardar.
  6. En el Editor del Registro, haga clic con el botón secundario del mouse en la clave Identities y, a continuación, haga clic en Eliminar.
  7. Salga del Editor del Registro e inicie Outlook Express para probar la funcionalidad.
Ya puede restaurar la configuración del correo, las direcciones y las cuentas.

Más información

En caso de que existan varias claves Identities en el sistema, siga estos pasos para determinar el número GUID (como el que se mostraba en un ejemplo anterior, {114378F3-CC8A-4992-B5B4-CCEA0A42A2B6}):
  1. Haga clic en Inicio, en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. Desplácese por el Registro hasta llegar a la clave siguiente:
    HKEY_CURRENT_USER/Identities
  3. Haga clic en el signo más ("+") situado junto a Identities.
  4. Para determinar qué GUID pertenece a qué identidad, haga clic en el GUID que se encuentra en la ventana de la izquierda. En la ventana de la derecha, busque el nombre de datos "User Name"; éste es el nombre de la clave de identidad de Outlook Express.

La información de este artículo se refiere a:
  • Microsoft Outlook Express 5.5 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.0
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 5.01 Service Pack 2
  • Microsoft Outlook Express 5.02
  • Microsoft Outlook Express 6.0
Palabras clave: 
kbprb KB258034
 

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