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Terminal Services Licensing Does Not Accept a Valid License Key Pack

Article ID:258045
Last Review:March 1, 2007
Revision:4.3
This article was previously published under Q258045
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SYMPTOMS

The Terminal Services Licensing server does not accept the license key pack after being activated. The activation process functions normally, however the installation of license key packs may not work when you configure the License Server with a valid license key, and you may receive the following error message:
One or more license codes were not validated. To view the status of your license codes, click Back. Correct or remove any invalid license codes, then resubmit your requests. If the problem persists, contact Microsoft Technical Support.

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CAUSE

This problem can occur if the license key is not valid, or, if the license is known to be valid, the license database may be damaged.

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RESOLUTION

To resolve this problem, verify the license key pack is from a valid key, and that it is being entered correctly. To validate a Terminal Services License Key, contact the Microsoft Registration Authority and Clearinghouse as described in the "More Information" section. If the Terminal Services License Database is damaged, it must be rebuilt. To rebuild a damaged Terminal Services License Database:
1.Remove Terminal Services Licensing:
1.Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
2.Click Add/Remove Windows Components, and then click to clear the Terminal Services Licensing check box.
3.Reboot the server to ensure that the License Server database is rebuilt.
2.Reinstall Terminal Services Licensing:
1.Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
2.Click Add/Remove Windows Components, and then click to select the Terminal Services Licensing check box.
3.Reboot the server to ensure that the License Server database is rebuilt.
3.Reconfigure the activated Terminal Services Licensing server with the valid license key:
1.Open the Terminal Services Licensing management console.
2.Right-click on the icon for the License Server.
3.Click Activate Server and follow the steps in the Licensing Wizard.
The license database has now been fully rebuilt.

If the problem persists, it may be necessary to verify the RDP-tcp listener is active, and that the Terminal Device Driver is started. For information about how to do so, see the Microsoft Knowledge Base articles in the "More Information" section.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

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MORE INFORMATION

258021 (http://support.microsoft.com/kb/258021/EN-US/) Event 52 when starting Terminal Services
248430 (http://support.microsoft.com/kb/248430/EN-US/) How to Transfer TS CAL from One Computer to Another
237811 (http://support.microsoft.com/kb/237811/EN-US/) Activating a Terminal Services License Server Over the Internet
244749 (http://support.microsoft.com/kb/244749/EN-US/) Licenses Required When Using Terminal Services Client Software
Terminal Services Licensing technical White Paper:
http://www.microsoft.com/windows/server/Technical/terminal/TSLicensing.asp (http://www.microsoft.com/windows/server/Technical/terminal/TSLicensing.asp)
The Terminal Services chapter of the Windows 2000 Deployment Planning Guide:
http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/default.mspx?mfr=true (http://www.microsoft.com/technet/prodtechnol/windows2000serv/reskit/default.mspx?mfr=true)

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Microsoft Registration Authority and Clearinghouse

To validate a Terminal Services License Key, contact the Microsoft Registration Authority and Clearinghouse by calling 1-888-571-2048 (in the United States). To contact the Registration Authority and Clearinghouse outside of the United States, perform the following steps to obtain the phone number by country:
1.Start the Terminal Services Licensing tool.
2.Right-click License Server, and then click Properties.
3.Click Connection Method, and then click Set To Telephone.
4.Select the appropriate country, and then click OK.
5.On the Action menu, click Install Licenses, and then click Next.
6.Call the appropriate Customer Service Center using the telephone number displayed.
7.Click Cancel to close the Terminal Services Licensing tool.

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server

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Keywords: 
kberrmsg kbprb kbtermserv KB258045

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