FIX: A question mark (?) is displayed before every blank space in batched interchanges in BizTalk Server 2010

Article ID: 2581142 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You install Microsoft BizTalk Server 2010 on a computer.
  • You configure the value of the Release Indicator (UNA4) property in the Charset and Separators settings for outgoing messages from a certain sender to a question mark (?).
  • You configure the value of the Repetition Separator (UNA5) property in the Charset and Separators settings for outgoing messages from the sender to a blank space.
  • The sender sends some batched interchanges by using the EdiSend pipeline in BizTalk server. 
In this scenario, a question mark is displayed before every blank space in the batched interchanges.

Note This issue does not occur in unbatched interchanges.

RESOLUTION

Cumulative update information

For BizTalk Server 2010

The hotfix that resolves this issue is included in cumulative update package 5 for BizTalk Server 2010.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2689458 Cumulative update package 5 for BizTalk Server 2010

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the UNA segment, go to the following Microsoft TechNet website:
General information about the UNA segment
For information about the service packs and cumulative update list for BizTalk Server, click the following article number to view the article in the Microsoft Knowledge Base:
2555976 Service pack and cumulative update list for BizTalk Server
For more information about BizTalk hotfixes and service pack support, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk hotfixes and service pack support
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2581142 - Last Review: July 9, 2012 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Server Enterprise 2010
  • Microsoft BizTalk Server Branch 2010
  • Microsoft BizTalk Server Developer 2010
  • Microsoft BizTalk Server Standard 2010
Keywords: 
kbqfe kbfix kbexpertiseadvanced kbsurveynew kbbiztalk2010presp1fix KB2581142

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com