Ошибка мастера в Access 2010 после установки Office 2010 с пакетом обновления 1 (SP1)

Симптомы

При использовании встроенных мастеров в Microsoft Access 2010, русская версия (64-разрядная версия) с пакетом обновления 1 (SP1) появляется следующее сообщение об ошибке:

Невозможно открыть базу данных, так как проект VBA, содержащийся в ней, не может быть прочитан. Базу данных можно открыть только в том случае, если проект VBA сначала удален. При удалении проекта VBA удаляется весь код из модулей, форм и отчетов. Перед попыткой открыть базу данных и удалить проект VBA необходимо создать резервную копию.

После нажатия кнопки ОК в этом сообщении может появить любое из следующих сообщений об ошибках:

Обновление невозможно. База данных или объект доступны только для чтения.

Проект Visual Basic для приложений в базе данных поврежден.

Microsoft Access не может найти мастер. Этот мастер не установлен, или в реестре Windows указан неверный параметр, либо этот мастер отключен.

Примечание.

Эта проблема связана с 64-разрядной версией Access 2010 (64-разрядная версия). Она не встречается в 32-разрядной версии Access 2010.

Причина

При установке Access 2010 с пакетом обновления 1 (SP1) встроенные файлы мастера не обновляются.

Решение

Чтобы устранить эту неполадку, выполните следующие действия:

  1. Закройте все экземпляры Access 2010.

  2. Откройте проводник. Для этого нажмите кнопку Пуск, введите файл и выберите проводник в списке результатов.

  3. Убедитесь, что расширения файлов отображаются. Для этого выберите ленту Вид, а затем выберите проверка поле Расширения имен файлов в группе Показать и скрыть.

    Снимок экрана: выбор проверка расширения имен файлов.

  4. Переименуйте следующие файлы в (<filename.old> extension).

    Исходное имя файла Переименуйте в:
    Acwzmain.accde Acwzmain.old
    Acwzlib.accde Acwzlib.old
    Acwztool.accde Acwztool.old
    Utility.accda Utility.old

    Примечание.

    Эти файлы находятся по адресу c:\Program Files\Microsoft Office\Office14\ACCWIZ\.

  5. Запустите Access.

Проблема устранена?

Если проблема не устранена, обратитесь в службу поддержки.

Ссылки

Дополнительная информация

Требуется дополнительная помощь? Зайдите на сайт сообщества Майкрософт.