컴퓨터 부팅 시 오류 c000021a가 발생하거나 검은 화면이 표시된다 [Step by Step]

기술 자료 번역 기술 자료 번역
기술 자료: 2583705 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

현상

컴퓨터 부팅 시 다음과 같은 현상이 발생하면서 컴퓨터가 부팅이 안 됩니다.?

  • Windows 부팅 도중 블루 스크린이 나타납니다.

    그림 축소그림 확대
    2584972


  • 검은 화면에 마우스 커서만 보이고 아무 반응 없습니다.
  • 안전 모드로도 부팅되지 않습니다.


원인

Windows?시스템 파일인?ws2help.dll이 바이러스에 감염되어 이런 문제가 발생합니다.


해결 방법

Windows 복구 환경에서?명령 프롬프트를 이용하여 ws2help.dll 파일을 복구하여 문제를 해결할 수 있습니다.

다음 방법을 순서대로 따라해 보세요.



Windows XP 및 Windows Server 2003인 경우

  1. Windows XP 설치 CD를 넣은 후 컴퓨터를 다시 시작하세요.

  2. 컴퓨터 BIOS의 부팅 순서에서 첫 번째를 cd-rom으로 설정하세요.

    표 축소표 확대
    그림 축소그림 확대
    주의
    컴퓨터?제조사마다 BIOS 진입 및 설정 방법이 다를 수 있으므로 정확한 방법은 각 컴퓨터 제조사에 문의하시길 바랍니다.

  3. 다음 화면이 나오면 아무 키나 누르세요.

    그림 축소그림 확대
    2585029


  4. Windows XP 설치 화면이 나타나면 R 키를 누르세요.

    그림 축소그림 확대
    2585030


  5. Windows?XP 복구 콘솔 화면에서 복구하려는 Windows 설치를 선택하세요(이 문서에서는 1을 선택하였습니다).

    그림 축소그림 확대
    2585031


  6. Administrator 암호를 입력한 후 Enter를 누르세요. Administrator 암호가 없다면?Enter를 누르세요.

    그림 축소그림 확대
    2586118


  7. ws2help.dll 파일이 들어있는 system32?폴더로 이동하기 위해?cd system32를 입력한 후 Enter를 누르세요.

    그림 축소그림 확대
    2586134


  8. ws3help.dll 파일이 존재하는지 확인하기 위해 dir?ws3help.dll을 입력한 후 Enter를 누르세요.

    그림 축소그림 확대
    2586135


  9. 다음과 같은 화면이 나타난다면 ws3help.dll 파일이 존재합니다. 다음 단계를 계속하여 진행하세요.

    그림 축소그림 확대
    2586136


  10. del ws2help.dll을 입력한 후 Enter를 누르세요.

    그림 축소그림 확대
    2586137


  11. ren ws3help.dll ws2help.dll을 입력한 후 Enter를 누르세요.

    그림 축소그림 확대
    2586138


  12. exit를 입력한 후 Enter를 눌러 컴퓨터를 다시 시작하세요.

    그림 축소그림 확대
    2586139


  13. 백신 프로그램으로 컴퓨터를 다시 한번 점검해 보세요. 만약 설치된 백신 프로그램이 없다면 다음 링크를 클릭하여 마이크로소프트 무료 백신 프로그램인 Microsoft Security Essentials를 다운로드 및 설치하고 바이러스 검사를 해보세요.




Windows Vista 및 Windows 7인 경우

  1. 컴퓨터를 시작하자마자 F8?키를 연속하여 누르세요.

    표 축소표 확대
    그림 축소그림 확대
    팁
    만약?고급 부팅 옵션 화면이 나타나지 않는다면 컴퓨터를 다시 시작하고 다시?F8?키를 연속하여 누르시기 바랍니다.

  2. 다음 화면이 나타나면 방향 키를 이용하여 [컴퓨터를 복구]를 선택하고 Enter를 누르세요.

    그림 축소그림 확대
    2583733


  3. 시스템 복구 옵션 화면이 나타나면 [다음]을 클릭하세요.

    그림 축소그림 확대
    2583734


  4. 사용자 이름암호를 입력하고 [확인]을 클릭하세요.

    그림 축소그림 확대
    2583735


  5. [명령 프롬프트]를 클릭하세요.

    그림 축소그림 확대
    2583736


  6. 명령 프롬프트 화면에서 ws3help.dll 파일이 존재하는지 확인하기 위해?dir?ws3help.dll을 입력한?후 Enter를 누르세요.

    그림 축소그림 확대
    2585642


  7. ?다음과 같은 화면이 나타난다면?ws3help.dll 파일이 존재합니다. 다음 단계를 계속하여 진행하세요.

    그림 축소그림 확대
    2585643


  8. del ws2help.dll을 입력한 후 Enter를 누르세요.

    그림 축소그림 확대
    2585644


  9. ren ws3help.dll ws2help.dll을 입력한 후 Enter를 누르세요.

    그림 축소그림 확대
    2585645


  10. exit를 입력한 후 Enter를 누르세요.

    그림 축소그림 확대
    2585646


  11. 시스템 복구 옵션 화면에서 [다시 시작]을 클릭하여 컴퓨터를 다시 시작하세요.

    그림 축소그림 확대
    2583740


  12. 백신 프로그램으로 컴퓨터를 다시 한번 점검해 보세요. 만약 설치된 백신 프로그램이 없다면 다음 링크를 클릭하여 마이크로소프트 무료 백신 프로그램인 Microsoft Security Essentials를 다운로드 및 설치하고 바이러스 검사를 해보세요.



추가?정보

다음 링크를 클릭하여 해당?바이러스에 대한 정보를 참고하십시오.




참고?자료

의견 보내기

표 축소표 확대
그림 축소그림 확대
의견 보내기

Microsoft 고객지원 사이트에서는 고객님의 소리를 귀담아 듣습니다. 아래 의견 보내기로 소중한 의견 보내주시기 바랍니다.

속성

기술 자료: 2583705 - 마지막 검토: 2014년 5월 26일 월요일 - 수정: 2.4
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Windows Vista Home Premium
  • Windows Vista Business
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 7 Enterprise
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
키워드:?
kbstepbystep kbtshoot KB2583705

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com