Ralentissement des performances lorsque vous utilisez le client Microsoft Dynamics CRM 2011 pour Outlook

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Symptômes

Vous trouverez les performances lentes pour le client Microsoft Dynamics CRM 2011, comme lorsque vous naviguez entre les dossiers CRM. Lorsque vous examinez le trafic réseau Microsoft Dynamics CRM client et serveur, vous constatez qu'il existe un trafic même s'il n'y a aucune activité de l'utilisateur Microsoft Dynamics CRM qui se produit.

Cause

Le client Microsoft Dynamics CRM pour Microsoft Outlook s'exécute en arrière-plan les activités d'interrogation qui communiquent avec le serveur et de réagissent aux modifications côté serveur même s'il n'y a aucune activité côté client.

Il existe des caches pour diverses fonctionnalités Microsoft Dynamics CRM telles que le carnet d'adresses, des rappels et des vues. L'intervalle d'interrogation par défaut pour les caches MAPI est toutes les 15 minutes.

L'interrogation régulière génère l'activité de Microsoft Dynamics CRM en arrière-plan, et cette activité peut influencer les performances.

Résolution

Il existe un ensemble de valeurs de Registre et des sous-clés qui peuvent être modifiés pour régler les intervalles d'interrogation.

Le tableau suivant contient la liste des clients de Microsoft Dynamics CRM pour les entrées de Registre Outlook et des sous-clés qui influencent l'arrière-plan activité CRM. Testez et rechercher les valeurs optimales pour votre environnement. Comme point de départ, il existe une Suggéré de test colonne double les valeurs par défaut.

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Entrée de RegistreClient/serveurTypeUnité de mesureValeur de la durée par défautSous-clé de RegistreSuggéré de test
NotificationPollInterval Client(Clé de Registre DWORD) MS180000 (Décimal)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Incrément à 3600000 (décimal)
StateManagerPollIntervalClient(Clé de Registre DWORD)Min5 (Décimal)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Incrément de 10 (décimal)
TagPollingPeriodClient(Clé de Registre DWORD)MS300000 (Décimal)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\ {ORGGUID}
Incrément à 600000 (décimal)
TagMaxAggressiveCyclesClient(Clé de Registre DWORD)Non Applicable2
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\ {ORGGUID}
La valeur 0
ActiveCachesUpdatingPeriodMillisecondsClient(Clé de Registre DWORD)MS1500000 (Décimal)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Incrément à 3000000 (décimal)
IncrementalDataCachesInclusionUpdatingPeriodMillisecondsClient(Clé de Registre DWORD)MS300000 (Décimal)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Incrément à 6000000 (décimal)
IncrementalDataCachesExclusionUpdatingPeriodMillisecondsClient(Clé de Registre DWORD)MS300000 (Décimal)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Incrément à 6000000 (décimal)

Plus d'informations

En outre, vous pouvez également essayer d'augmenter l'intervalle de synchronisation Outlook. Par défaut, cet intervalle est défini sur 15 minutes. Pour augmenter l'interne, procédez comme suit :
  1. Ouvrez le Client Web CRM.
  2. Cliquez sur Paramètres, cliquez sur Administration, puis cliquez sur Paramètres système.
  3. Cliquez sur le Outlook onglet, puis examinez le Temps minimal entre les synchronisations option.

Un utilisateur de Microsoft Dynamics CRM pouvez ajuster la valeur de synchronisation pour ce serveur de configuration de la valeur minimale est définie dans les options de Microsoft Dynamics CRM personnelles de l'utilisateur dans Outlook. Pour mettre à jour la valeur minimale de Outlook, procédez comme suit :
  1. Ouvrez Microsoft Outlook 2010.
  2. Cliquez sur Fichier, cliquez sur CRM, puis cliquez sur Options.
  3. Sous le Synchronisation onglet, mettre à jour la valeur de la Synchroniser les éléments CRM dans Mes dossiers Outlook minutes « x » option.

Propriétés

Numéro d'article: 2585157 - Dernière mise à jour: lundi 15 avril 2013 - Version: 3.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Dynamics CRM 2011
Mots-clés : 
kbmbsmigrate kbsurveynew kbmt KB2585157 KbMtfr
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