Ralentissement des performances lorsque vous utilisez le client Microsoft Dynamics CRM 2011 pour Outlook

Cet article fournit une solution à un problème où les performances lentes pour Microsoft Dynamics CRM client 2011 pour Outlook.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 2585157

Symptômes

Vous constatez que les performances du client Microsoft Dynamics CRM 2011 sont lentes. Lorsque vous examinez Microsoft Dynamics CRM trafic réseau client et serveur, vous constatez qu’il y a du trafic même s’il n’y a aucune activité utilisateur Microsoft Dynamics CRM qui se produit.

Cause

Le client Microsoft Dynamics CRM pour Microsoft Outlook exécute des activités d’interrogation en arrière-plan qui communiquent avec le serveur et réagissent aux modifications côté serveur, même s’il n’y a pas d’activité côté client.

Il existe des caches pour diverses fonctionnalités Microsoft Dynamics CRM telles que le carnet d’adresses, les rappels et les vues. L’intervalle d’interrogation par défaut pour les caches MAPI est toutes les 15 minutes.

L’interrogation régulière génère Microsoft Dynamics CRM’activité en arrière-plan, et cette activité peut influencer les performances.

Résolution

Il existe un ensemble de valeurs de Registre et de sous-clés qui peuvent être modifiées pour régler les intervalles d’interrogation.

Le tableau suivant contient la liste des Microsoft Dynamics CRM client pour les entrées et sous-clés de Registre Outlook qui influencent l’activité CRM en arrière-plan. Testez et recherchez les valeurs optimales pour votre environnement. Comme point de départ, il existe une colonne Test suggéré qui double les valeurs par défaut.

Entrée de Registre Serveur/client Type Unité de mesure Durée/valeur par défaut Sous-clé de Registre Test suggéré
NotificationPollInterval Client (Clé de registre DWORD) Ms 180000 (décimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Incrémenter à 3600000 (décimal)
StateManagerPollInterval Client (Clé de registre DWORD) Min 5 (décimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Incrémenter à 10 (décimal)
TagDisabled (cette clé désactive l’étiquetage automatique des Email) Client (Clé de registre DWORD) Non applicable 0 HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Définir sur 1
TagPollingPeriod Client (Clé de registre DWORD) Ms 300000 (décimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Incrémenter à 600000 (décimal)
TagMaxAggressiveCycles Client (Clé de registre DWORD) Non applicable 2 HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Définir sur 0
ActiveCachesUpdatingPeriodMilliseconds Client (Clé de registre DWORD) Ms 1500000 (décimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Incrémenter à 3000000 (décimal)
IncrementalDataCachesInclusionUpdatingPeriodMilliseconds Client (Clé de registre DWORD) Ms 300000 (décimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Incrémenter à 6000000 (décimal)
IncrementalDataCachesExclusionUpdatingPeriodMilliseconds Client (Clé de registre DWORD) Ms 300000 (décimal) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Incrémenter à 6000000 (décimal)

En outre, vous pouvez également essayer d’augmenter l’intervalle de synchronisation Outlook. Par défaut, cet intervalle est défini sur 15 minutes. Pour augmenter le nombre interne, procédez comme suit :

  1. Ouvrez le client web CRM.
  2. Sélectionnez Paramètres, Administration, puis Paramètres système.
  3. Sélectionnez l’onglet Outlook , puis examinez l’option Durée minimale entre les synchronisations .

Un utilisateur Microsoft Dynamics CRM peut ajuster la valeur de synchronisation de ce serveur à la valeur minimale définie dans les options de Microsoft Dynamics CRM personnelles de l’utilisateur dans Outlook. Pour mettre à jour la valeur minimale Outlook, procédez comme suit :

  1. Ouvrez Microsoft Outlook 2010.
  2. Sélectionnez Fichier, CRM, puis Options.
  3. Sous l’onglet Synchronisation , mettez à jour la valeur de l’option Synchroniser les éléments CRM dans mon dossier Outlook toutes les « x » minutes .