Desempenho lento ao usar o cliente Microsoft Dynamics CRM 2011 para o Outlook
Este artigo fornece uma solução para um problema em que o desempenho lento para Microsoft Dynamics CRM cliente de 2011 para o Outlook.
Aplica-se a: Microsoft Dynamics CRM 2011
Número de KB original: 2585157
Sintomas
Você acha o desempenho lento para o cliente Microsoft Dynamics CRM 2011. Ao investigar Microsoft Dynamics CRM tráfego de rede do cliente e do servidor, você descobre que há tráfego mesmo que não haja Microsoft Dynamics CRM atividade do usuário que esteja ocorrendo.
Motivo
O cliente Microsoft Dynamics CRM do Microsoft Outlook executa atividades de pesquisa em segundo plano que se comunicam com o servidor e reagem a alterações no lado do servidor, mesmo que não haja atividade do lado do cliente.
Há caches para vários recursos Microsoft Dynamics CRM, como catálogo de endereços, lembretes e exibições. O intervalo de votação padrão para caches MAPI é a cada 15 minutos.
A sondagem regular gera Microsoft Dynamics CRM atividade em segundo plano e essa atividade pode influenciar o desempenho.
Resolução
Há um conjunto de valores de registro e subchaves que podem ser modificados para ajustar os intervalos de votação.
A tabela a seguir contém a lista de Microsoft Dynamics CRM cliente para entradas de registro do Outlook e subchaves que influenciam a atividade de CRM em segundo plano. Teste e localize os valores ideais para seu ambiente. Como ponto de partida, há uma coluna teste sugerido que dobra os valores padrão.
Entrada do Registro | Servidor/Cliente | Tipo | Unidade de Medida | Duração/valor padrão | Subchave do Registro | Teste sugerido |
---|---|---|---|---|---|---|
NotificationPollInterval | Cliente | (DWORD Reg Key) | Ms | 180000 (Decimal) | HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient |
Incrementar para 3600000 (Decimal) |
StateManagerPollInterval | Cliente | (DWORD Reg Key) | Min | 5 (Decimal) | HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient |
Incrementar para 10 (Decimal) |
TagDisabled (essa chave desabilita a Marcação automática de Email) | Cliente | (DWORD Reg Key) | Não aplicável | 0 | HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} |
Definido como 1 |
TagPollingPeriod | Cliente | (DWORD Reg Key) | Ms | 300000 (Decimal) | HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} |
Incrementar para 600000 (Decimal) |
TagMaxAggressiveCycles | Cliente | (DWORD Reg Key) | Não aplicável | 2 | HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} |
Definido como 0 |
ActiveCachesUpdatingPeriodMilliseconds | Cliente | (DWORD Reg Key) | Ms | 1500000 (Decimal) | HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient |
Incrementar para 3000000 (Decimal) |
IncrementalDataCachesInclusionUpdatingPeriodMilliseconds | Cliente | (DWORD Reg Key) | Ms | 300000 (Decimal) | HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient |
Incrementar para 6000000 (Decimal) |
IncrementalDataCachesExclusionUpdatingPeriodMilliseconds | Cliente | (DWORD Reg Key) | Ms | 300000 (Decimal) | HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient |
Incrementar para 6000000 (Decimal) |
Além disso, você também pode tentar aumentar o intervalo de sincronização do Outlook. Por padrão, esse intervalo é definido como 15 minutos. Para aumentar o interno, siga estas etapas:
- Abra o Cliente Web do CRM.
- Selecione Configurações, selecione Administração e selecione Configurações do Sistema.
- Selecione a guia Outlook e examine a opção Tempo mínimo entre sincronizações .
Um usuário Microsoft Dynamics CRM pode ajustar o valor de sincronização para esse servidor configurando até o valor mínimo definido nas opções de Microsoft Dynamics CRM pessoais do usuário no Outlook. Para atualizar o valor mínimo do Outlook, siga estas etapas:
- Abra Microsoft Outlook 2010.
- Selecione Arquivo, selecione CRM e, em seguida, selecione Opções.
- Na guia Sincronização , atualize o valor para sincronizar os itens crm na minha pasta do Outlook a cada opção de minutos 'x' .