Снижение производительности при использовании клиента 2011 Microsoft Dynamics CRM для Outlook

Переводы статьи Переводы статьи
Код статьи: 2585157 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

Проблема

Снижение производительности поиска 2011 Microsoft Dynamics CRM клиента, например, при переходе между папками CRM. При исследовании Microsoft Dynamics CRM клиент и сервер сетевой трафик, можно найти, что есть трафик даже при отсутствии активности пользователя Microsoft Dynamics CRM, происходящего.

Причина

Microsoft Dynamics CRM клиента Microsoft Outlook выполняется фоновое опроса действий, которые будут взаимодействовать с сервером и реагировать на изменения на стороне сервера, даже если нет никаких действий со стороны клиента.

Существуют кэши для различных функций Microsoft Dynamics CRM, такие как представления, адресной книги и напоминаний. По умолчанию интервал опроса для кэшей MAPI — каждые 15 минут.

Регулярного опроса создает Microsoft Dynamics CRM фоновой активности, и это действие может повлиять на производительность.

Решение

Существует набор значений реестра и его подразделы, которые могут быть изменены для настройки интервала опроса.

Следующая таблица содержит список Microsoft Dynamics CRM клиента для записи реестра для Outlook и подразделы, которые влияют на фоновой активности CRM. Тестирование и найти оптимальные значения для вашей среды. В качестве отправной точки, не существует Предлагаемые тестирования столбец, который удваивает значения по умолчанию.

Свернуть эту таблицуРазвернуть эту таблицу
Запись реестраКлиент серверТипЕдиница измеренияЗначение длительности по умолчаниюПараметр реестраПредлагаемые тестирования
NotificationPollInterval Клиент(Раздел реестра типа DWORD) Мс180000 (Дес.)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Шаг к 3600000 (дес.)
StateManagerPollIntervalКлиент(Раздел реестра типа DWORD)Мин.5 (Дес.)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Шаг 10 (дес.)
TagPollingPeriodКлиент(Раздел реестра типа DWORD)Мс300000 (Дес.)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\ {ORGGUID}
Увеличение до 600000 (дес.)
TagMaxAggressiveCyclesКлиент(Раздел реестра типа DWORD)Не применимо2
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\ {ORGGUID}
Значение 0
ActiveCachesUpdatingPeriodMillisecondsКлиент(Раздел реестра типа DWORD)Мс1500000 (Дес.)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Шаг к 3000000 (дес.)
IncrementalDataCachesInclusionUpdatingPeriodMillisecondsКлиент(Раздел реестра типа DWORD)Мс300000 (Дес.)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Шаг к 6000000 (дес.)
IncrementalDataCachesExclusionUpdatingPeriodMillisecondsКлиент(Раздел реестра типа DWORD)Мс300000 (Дес.)
HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
Шаг к 6000000 (дес.)

Дополнительная информация

Кроме того можно также попробовать увеличить интервал синхронизации Outlook. По умолчанию этот интервал устанавливается на 15 минут. Чтобы увеличить внутренний, выполните следующие действия.
  1. Откройте веб-клиент CRM.
  2. Нажмите кнопку Параметры, нажмите кнопку Администрирование, а затем нажмите кнопку Параметры системы.
  3. Нажмите кнопку Outlook вкладки и просмотрите Минимальное время между синхронизациями параметр.

Microsoft Dynamics CRM пользователь может скорректировать значение синхронизации для этого сервера, Настройка минимальное значение, которое определено в личных Microsoft Dynamics CRM параметры пользователя в Outlook. Чтобы обновить минимальное значение Outlook, выполните следующие действия:
  1. Откройте Microsoft Outlook 2010, русская версия.
  2. Нажмите кнопку Файл, нажмите кнопку CRM, а затем нажмите кнопку Параметры.
  3. В группе Синхронизация Вкладка, обновить значение Синхронизировать элементы CRM в моей папке Outlook каждые минут «x» параметр.

Свойства

Код статьи: 2585157 - Последний отзыв: 16 июля 2013 г. - Revision: 3.1
Информация в данной статье относится к следующим продуктам.
  • Microsoft Dynamics CRM 2011
Ключевые слова: 
kbmbsmigrate kbsurveynew kbmt KB2585157 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Данная статья переведена с использованием программного обеспечения Майкрософт для машинного перевода и, возможно, отредактирована посредством технологии Community Translation Framework (CTF). Корпорация Майкрософт предлагает вам статьи, обработанные средствами машинного перевода, отредактированные членами сообщества Майкрософт и переведенные профессиональными переводчиками, чтобы вы могли ознакомиться со всеми статьями нашей базы знаний на нескольких языках. Статьи, переведенные с использованием средств машинного перевода и отредактированные сообществом, могут содержать смысловое, синтаксические и (или) грамматические ошибки. Корпорация Майкрософт не несет ответственности за любые неточности, ошибки или ущерб, вызванные неправильным переводом контента или его использованием нашими клиентами. Подробнее об CTF можно узнать по адресу http://support.microsoft.com/gp/machine-translation-corrections/ru.
Эта статья на английском языке: 2585157

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com