Низкая производительность при использовании клиента Microsoft Dynamics CRM 2011 для Outlook

В этой статье описывается решение проблемы, из-за которой низкая производительность для Microsoft Dynamics CRM клиента 2011 для Outlook.

Область применения: Microsoft Dynamics CRM 2011 г.
Исходный номер базы знаний: 2585157

Симптомы

Производительность клиента Microsoft Dynamics CRM 2011 снижается. При изучении сетевого трафика Microsoft Dynamics CRM клиента и сервера вы обнаружите, что трафик есть, даже если нет Microsoft Dynamics CRM действий пользователя.

Причина

Клиент Microsoft Dynamics CRM для Microsoft Outlook выполняет фоновые действия опроса, которые взаимодействуют с сервером и реагируют на изменения на стороне сервера, даже если действия на стороне клиента отсутствуют.

Существуют кэши для различных Microsoft Dynamics CRM функций, таких как адресная книга, напоминания и представления. Интервал опроса по умолчанию для кэшей MAPI составляет каждые 15 минут.

Регулярный опрос создает Microsoft Dynamics CRM фонового действия, и это действие может повлиять на производительность.

Решение

Существует набор значений реестра и подразделов, которые можно изменить для настройки интервалов опроса.

В следующей таблице приведен список записей и подразделов реестра Microsoft Dynamics CRM клиента Для Outlook, которые влияют на фоновую деятельность CRM. Протестируйте и найдите оптимальные значения для своей среды. В качестве отправной точки есть столбец Рекомендуемое тестирование , который удваивает значения по умолчанию.

Запись реестра Сервер или клиент Тип Единица измерения Длительность или значение по умолчанию Подраздел реестра Предлагаемое тестирование
NotificationPollInterval Клиент (ключ reg DWORD) Мс 180000 (десятичное) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Приращение к 3600000 (десятичное)
StateManagerPollInterval Клиент (ключ reg DWORD) Min 5 (вещественное); HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Приращение к 10 (десятичное)
TagDisabled (этот ключ отключает автоматическое Email тегов) Клиент (ключ reg DWORD) Неприменимо 0 HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Задайте значение 1
TagPollingPeriod Клиент (ключ reg DWORD) Мс 300000 (десятичное) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Приращение к 600000 (десятичное)
TagMaxAggressiveCycles Клиент (ключ reg DWORD) Неприменимо 2 HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient\{ORGGUID} Задайте значение 0.
ActiveCachesUpdatingPeriodMilliseconds Клиент (ключ reg DWORD) Мс 1500000 (десятичное) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Приращение к 3000000 (десятичное)
IncrementalDataCachesInclusionUpdatingPeriodMilliseconds Клиент (ключ reg DWORD) Мс 300000 (десятичное) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Приращение к 6000000 (десятичное)
IncrementalDataCachesExclusionUpdatingPeriodMilliseconds Клиент (ключ reg DWORD) Мс 300000 (десятичное) HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient Приращение к 6000000 (десятичное)

Кроме того, можно также попытаться увеличить интервал синхронизации Outlook. По умолчанию этот интервал установлен в 15 минут. Чтобы увеличить внутренний уровень, выполните следующие действия.

  1. Откройте веб-клиент CRM.
  2. Выберите Параметры, Администрирование, а затем — Параметры системы.
  3. Перейдите на вкладку Outlook и проверьте параметр Минимальное время между синхронизациями .

Пользователь Microsoft Dynamics CRM может изменить значение синхронизации для этого сервера до минимального значения, определенного в параметрах личных Microsoft Dynamics CRM пользователя в Outlook. Чтобы обновить минимальное значение Outlook, выполните следующие действия.

  1. Откройте Microsoft Outlook 2010, русская версия.
  2. Выберите Файл, выберите CRM, а затем — Параметры.
  3. На вкладке Синхронизация обновите значение параметра Синхронизировать элементы CRM в папке Outlook каждые x минуты .