Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

Consider the following scenario:

  • You install a host instance of Microsoft BizTalk Server 2010 on a computer.

  • The connection to a BizTalk-related database is lost. The connection is resumed after the connection is lost for a period of one minute.

In this scenario, the host instance of BizTalk Server does not resume operation. Additionally, the following events are logged in the Application log or in the System log:
Note This issue does not occur in earlier versions of BizTalk Server.

Cause


This issue occurs because BizTalk Server 2010 does not report an unexpected termination to Service Control Manager (SCM).

When the database connection is lost, the host instance enters a stopped state and then tries to restart within one minute. However, the restart operation fails, and BizTalk Server 2010 does not report the unexpected termination to SCM. Additionally, SCM handles the unexpected termination as a user-initiated service stop operation. Therefore, SCM does not resume the host instance of BizTalk Server 2010 from the stopped state.

Resolution

Cumulative update information

The hotfix that resolves this issue is included in cumulative update package 2 for BizTalk Server 2010.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:

2573000 Cumulative update package 2 for BizTalk Server 2010

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information about service packs and cumulative update packages for BizTalk Server, visit the following Microsoft website:

General information about service packs and cumulative update packages for BizTalk ServerFor more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:

2003907 Information about BizTalk Server hotfixes

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×