Article ID: 258745 - Last Review: October 28, 2006 - Revision: 3.3 XIMS: Internet Mail Service Displays SMTP Banner SlowlyThis article was previously published under Q258745 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
SYMPTOMS
After you make a connection to an Exchange Server computer Internet Mail Service on port 25, the Simple Mail Transfer Protocol (SMTP) banner may not be displayed quickly, which may cause certain SMTP applications to time out.
CAUSE
This issue can occur because Exchange Server performs a reverse lookup on all connections. A reverse lookup may take several seconds because of a lack of or incorrectly configured Domain Name System (DNS) servers.
RESOLUTION
To resolve this issue, increase Internet Mail Service performance by disabling reverse resolution. To do this, you need to edit the registry. WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. If you use Regedit.exe:
MORE INFORMATION
Reverse resolution occurs when the name of the host that delivered an incoming SMTP message is resolved and placed in the message header by the Internet Mail Service. When reverse resolution is disabled, the Internet Mail Service does not resolve the host name in the upper-most Received From field of the SMTP message header. If the address is in Internet Protocol (IP) form, it remains in IP form.
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