RIPrep.exe agrega rutas de acceso duplicadas en el registro

Seleccione idioma Seleccione idioma
Id. de artículo: 258862 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
importante : este artículo contiene información acerca de cómo modificar el registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información sobre cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

Síntomas

Cuando utilice RIPrep.exe para crear una imagen de instalación de Windows 2000 Professional y la clave OemPnpdriversPath se especifica en el archivo de Sysprep.inf, las entradas que coloca en esta clave del registro
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows: DevicePath
se duplican cuando se coloca en el registro. Por ejemplo, una clave OemPnpDriversPath que tiene el valor
OemPnpDriversPath = drivers\nic; drivers\video
resultados en los valores siguientes que se escriben en la clave de registro OemPnpdriversPath :
SystemRoot \inf;\ SystemDrive \drivers\nic SystemDrive \drivers\video \drivers\nic SystemDrive ; SystemDrive \drivers\video

Causa

Este comportamiento se produce porque Riprep.exe entra incorrectamente los valores proporcionados por la clave OemPnpDriversPath en el registro.

Solución

Advertencia : si utiliza incorrectamente el Editor del registro, pueden surgir problemas graves que conlleven la reinstalación del sistema operativo. Microsoft no garantiza que pueda solucionar los problemas resultantes del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.

Tener estos valores duplicados en el registro para hacer el proceso de instalación tardar unos minutos más según el número de rutas que se han especificado mediante la clave OemPnpDriversPath . Los valores duplicados no parecen afectar negativamente a instalación de cualquier otra manera. Sin embargo, puesto que las rutas especificadas se utilizan durante la vida del equipo cuando se instala hardware nuevo, quizás desee cambiar estos valores.

Para cambiar los valores duplicados, siga estos pasos:
  1. Inicie Regedt32.exe y, a continuación, cargue la sección software desde el siguiente directorio de imagen de RiPrep (tipo de prueba para el nombre de clave):
    RemoteInstall\Setup\ language \Images\ dir_name \i386\Mirror1\UserData\WINNT\system32\config
  2. Modifique la clave TEST\Microsoft\Windows\CurrentVersion\Devicepath para quitar las rutas de dispositivos adicionales después de la entrada de \inf SystemRoot predeterminada.

    Nota : todas las entradas deben comenzar por SystemDrive y deben estar separadas por punto y coma (;). Por ejemplo:
    SystemDrive\Drivers\Nic; SystemDrive \drivers\video
  3. Guarde el subárbol del Registro descargándolo desde Regedt32.exe.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo.

Propiedades

Id. de artículo: 258862 - Última revisión: jueves, 06 de febrero de 2014 - Versión: 3.2
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Professional Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbfix kbprb kbsetup KB258862 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 258862

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com