ファイルを開くときに"インターネットのセキュリティ設定が 1 つ以上のファイルを開くことができませんでした"エラー

警告

廃止され、サポート対象外となった Internet Explorer 11 デスクトップ アプリケーションは、特定のバージョンの Windows 10 で Microsoft Edge の更新プログラムを通じて完全に無効になります。 詳細については、「Internet Explorer 11 デスクトップ アプリの廃止に関する FAQ」をご覧ください。

この記事では、Windows 7 でインターネット エクスプローラーを使用してファイルを開いたときに発生するエラー メッセージを解決するための方法について説明します。

元の製品バージョン:インターネット エクスプローラー、Windows 7
元の KB 番号: 2588679

現象

Windows 7 でインターネット エクスプローラーを使用してファイルを開こうとすると、次のエラー メッセージが表示されます。

これらのファイルを開くことができません。
インターネット のセキュリティ設定により、1 つ以上のファイルが開けないようにしました。

エラー メッセージ ダイアログ ボックスのスクリーンショット。

原因

この問題は、次の条件が満たされているために発生する可能性があります。

  • 開こうとしているファイルの種類は安全でないと見なされます。
  • [アプリケーションの起動と安全でないファイルのセキュリティ] 設定は、ファイルの送信元に関連付けられているゾーンに対して [無効] に設定されています。

解決策 1: インターネット エクスプローラー セキュリティ ゾーンの設定を既定のレベルにリセットする

インターネット エクスプローラーセキュリティ ゾーンの設定を既定のレベルにリセットするには、次の手順に従います。

  1. Internet Explorer を開始します。
  2. [ ツール] をクリックし、[ インターネット オプション] をクリックします。
  3. [セキュリティ] タブをクリックします。
  4. [ すべてのゾーンを既定のレベルにリセットする] をクリックし、[OK] をクリック します

解決策 2: インターネットのエクスプローラー設定をリセットする

注:

この記事の手順では、問題が完全に解決されない場合があります。 たとえば、現在のインターネット エクスプローラー設定がグループ ポリシー オブジェクト (GPO) によって適用されている場合、これらの手順では問題が解決されない可能性があります。 この記事で説明されている問題の解決に関してさらにサポートが必要な場合は、Microsoft カスタマー サポートにお問い合わせください。

詳細

Windows XP Service Pack 2 以降のバージョンを実行しているローカル コンピューターにファイルをダウンロードすると、セキュリティ ゾーン識別子がファイル のプロパティと共に格納されます。 この識別子は、ファイルが取得されたインターネット エクスプローラー セキュリティ ゾーンに対応します。

ダウンロードしたファイルが安全でないファイルの種類として識別されると、対応するセキュリティ ゾーンの [アプリケーションと安全でないファイルの起動 ] オプションに対して、[ 有効]、[ プロンプト]、または [無効] のいずれかのオプションが照会されます。 [アプリケーション と安全でないファイルの起動 ] オプションが [無効] に設定されている場合、[現象] セクションに記載されているダイアログが表示されます。

安全でないファイルの種類の詳細については、次を参照してください。

ゾーン識別子をファイルに適用するために使用されるプロセスの詳細については、「 Microsoft Windows の添付ファイル マネージャーに関する情報」を参照してください。

インターネット エクスプローラー セキュリティ ゾーンの詳細については、「高度なユーザー向けのインターネット エクスプローラー セキュリティ ゾーンのレジストリ エントリ」を参照してください。