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Directory Service Does Not Start If Disk Is Full

Article ID:259278
Last Review:February 28, 2007
Revision:2.2
This article was previously published under Q259278
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SYMPTOMS

The following error message may occur when you start a Windows 2000-based Active Directory domain controller:
Lsass.exe - System Error

Directory Services could not start because of the following error: There is not enough space on the disk. Error Status: 0xc000007f. Please click OK to shutdown this system and reboot into Directory Service Restore Mode, check the event logs for more detailed information.
When this occurs, the following events are recorded in the Event log for the directory service:
Event ID: 1393
Attempts to update the Directory Service database are failing with error 112. Since Windows will be unable to log on users while this condition persists, the Netlogon service is being paused. Check to make sure that adequate free disk space is available on the drives where the directory database and log files reside.

Event ID: 428
NTDS (272) The database engine is rejecting update operations due to low free disk space on the log disk.
The following warning message is recorded in the System log:
Event ID 2013:
The D: disk is nearing Capacity. You may need to delete some files.

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CAUSE

Active Directory cannot start if it runs out of disk space. Windows 2000 attempts to avoid this situation, but it can occur if you ignore warnings about low disk space in the System log or if you run large scripts against Active Directory for mass directory imports.

This behavior has been known to be caused by an issue with the NTBackup program not deleting old .edb log files. Please refer to this article for more information:
272425 (http://support.microsoft.com/kb/272425/EN-US/) Ntbackup.exe Does Not Truncate Active Directory Logs

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RESOLUTION

To resolve this issue, use any of the following methods.

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Method 1: Clear Space on the Drive

Use this method if you have one drive available and you cannot install additional drives in the server.
1.Click OK to acknowledge the error message so that the computer will reboot.
2.At the Boot menu, press F8.
3.Boot the domain controller into Directory Services Restore mode (Windows 2000 domain controllers only), and log on with the Directory Services Restore mode administrator account and password. (This is the password you assigned during the Dcpromo process).
4.Locate the drive containing the directory and log files. The directory (Ntds.dit) and log files are located in the \Winnt\Ntds folder on the root drive by default. However, the administrator may have changed their locations during the Dcpromo process.
5.Free some space on the drive. If there is no space to free, use method 2.
6.If you can free space on the drive, reboot the computer normally.

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Method 2: Move the Database or Log Files

Ntdsutil.exe has an option for moving either the database file or the database log file. This method is ideal when you cannot move data to another drive to free more space. If all drives are at capacity, it may be necessary to install an additional hard disk in the computer.
1.Boot the domain controller in Directory Services Restore mode and log on with the Directory Services Restore mode administrator account and password (this is the password you assigned during the Dcpromo process).
2.At a command prompt, type ntdsutil.exe. You receive the following prompt:
ntdsutil:
3.Type files to receive the following prompt:
file maintenance:
4.Type info. Note the path of the database and log files.
5.To move the database, type move db to %s (where %s is the target folder).
6.To move the log files, type move logs to %s (where %s is the target folder).
7.Type quit twice to return to the command prompt.
8.Reboot the computer normally.

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STATUS

This behavior is by design.

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APPLIES TO
Microsoft Windows 2000 Server
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Datacenter Server

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Keywords: 
kbenv kberrmsg kbprb KB259278

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