Identificativo articolo: 259416 - Ultima modifica: lunedì 25 settembre 2006 - Revisione: 5.0

OL2000: (IMO) La password non viene mantenuta in Windows 2000 o Windows XP

NOTA: queste procedure sono valide solo se Outlook è stato installato con l'opzione Solo posta Internet. Per determinare il tipo di installazione in uso, scegliere Informazioni su Microsoft Outlook dal menu ?. Dovrebbe essere visualizzato "Solo posta Internet" se è installata questa opzione.

Per informazioni sulle differenze tra i client di posta elettronica Microsoft Outlook Express e Microsoft Outlook, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
257824  (http://support.microsoft.com/kb/257824/ ) OL2000: Differenze tra Outlook e Outlook Express

IMPORTANTE: in questo articolo vengono fornite informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986  (http://support.microsoft.com/kb/256986/ ) Descrizione del Registro di sistema di Microsoft Windows

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Sintomi

Quando si esegue Outlook in un computer basato su Microsoft Windows 2000 o Microsoft Windows XP e ci si connette al provider di servizi Internet (ISP) per scaricare i messaggi di posta elettronica da un server POP (Post Office Protocol), la password non viene mantenuta come invece è stato impostato.

Cause

Il Registro di sistema contiene informazioni errate nella sottochiave Protected Storage System Provider dell'account dell'utente.

Risoluzione

Per salvare la password è necessario eseguire il backup del Registro di sistema, rimuovere le informazioni relative all'account utente e reinserire la password.

AVVISO: l'errato utilizzo dell'editor del Registro di sistema può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. L'utilizzo dell'editor del Registro di sistema è a rischio e pericolo dell'utente.

Fare riferimento alla procedura corretta per il sistema operativo in uso.

Come eseguire il backup del Registro di sistema

Windows 2000

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare regedt32 nella casella Apri, quindi scegliere OK.
  2. Individuare e fare clic sulla seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
  3. Scegliere Salva chiave dal menu Registro di sistema.
  4. Nella casella Nome file digitare un nome univoco per la chiave.
  5. Nella casella Salva in fare clic su un percorso per il file, quindi scegliere Salva.
  6. Scegliere Esci dal menu Registro di sistema.

Windows XP

  1. Fare clic sul pulsante Start, scegliere Esegui, digitare regedt32 nella casella Apri, quindi scegliere OK.
  2. Individuare e fare clic sulla seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
  3. Scegliere Esporta dal menu File.
  4. Nella casella Nome file digitare un nome univoco per la chiave.
  5. Nella casella Salva in fare clic su un percorso per il file, quindi scegliere Salva.
  6. Scegliere Esci dal menu File.

Come rimuovere le informazioni relative all'account utente

Windows 2000

  1. Chiudere tutti i programmi in esecuzione.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedt32 nella casella Apri, quindi scegliere OK.
  3. Individuare e fare clic sulla seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
  4. Scegliere Autorizzazioni dal menu Protezione.
  5. Fare clic sulla chiave di registro dell'utente attualmente connesso e verificare che le autorizzazioni Lettura e Controllo completo siano entrambe impostate su Consenti.
  6. Scegliere il pulsante Avanzate, assicurarsi che l'utente attualmente connesso sia selezionato, che nella colonna Autorizzazioni sia indicato "Controllo completo" e che nella colonna Applica a sia specificato La chiave selezionata e le sottochiavi.
  7. Selezionare la casella di controllo Reimposta le autorizzazioni su tutti gli oggetti figlio e abilita la propagazione delle autorizzazioni ereditabili.
  8. Scegliere Applica, quindi quando verrà chiesto se si desidera continuare.
  9. Scegliere OK, quindi di nuovo OK.
  10. Fare doppio clic sulla chiave Protected Storage System Provider per espanderla, fare clic sulla cartella della sottochiave utente direttamente sotto la chiave Protected Storage System Provider, scegliere Elimina dal menu Modifica, quindi scegliere nella finestra di dialogo del messaggio di avviso.

    La cartella della sottochiave utente avrà un aspetto simile all'esempio riportato di seguito:
    S-1-5-21-124525095-708259637-1543119021-16701
    NOTA: per ciascuna identità potrebbe esistere una sottochiave nella chiave Protected Storage System Provider. Per risolvere questo problema in tutte le identità, eliminare tutte le cartelle delle sottochiavi utente nella chiave Protected Storage System Provider.
  11. Scegliere Esci dal menu Registro di sistema, quindi riavviare il computer.

Windows XP

  1. Chiudere tutti i programmi in esecuzione.
  2. Fare clic sul pulsante Start, scegliere Esegui, digitare regedt32 nella casella Apri, quindi scegliere OK.
  3. Individuare e fare clic sulla seguente chiave del Registro di sistema:
    HKEY_CURRENT_USER\Software\Microsoft\Protected Storage System Provider
  4. Scegliere Autorizzazioni dal menu Modifica.
  5. Fare clic sulla chiave di registro dell'utente attualmente connesso e verificare che le autorizzazioni In lettura e Controllo completo siano entrambe impostate su Consenti.
  6. Scegliere il pulsante Avanzate, assicurarsi che l'utente attualmente connesso sia selezionato, che nella colonna Autorizzazioni sia indicato Controllo completo e che nella colonna Applica a sia specificato La chiave selezionata e le sottochiavi.
  7. Selezionare la casella di controllo Sostituisci le autorizzazioni su tutti gli oggetti figlio con le autorizzazioni appropriate qui specificate.
  8. Scegliere Applica, quindi quando verrà chiesto se si desidera continuare.
  9. Scegliere OK, quindi di nuovo OK.
  10. Fare doppio clic sulla chiave Protected Storage System Provider per espanderla, fare clic sulla cartella della sottochiave utente direttamente sotto la chiave Protected Storage System Provider, scegliere Elimina dal menu Modifica, quindi scegliere nella finestra di dialogo del messaggio di avviso.

    La cartella della sottochiave utente avrà un aspetto simile all'esempio riportato di seguito:
    S-1-5-21-124525095-708259637-1543119021-16701
    NOTA: per ciascuna identità potrebbe esistere una sottochiave nella chiave Protected Storage System Provider. Per risolvere questo problema in tutte le identità, eliminare tutte le cartelle delle sottochiavi utente nella chiave Protected Storage System Provider.
  11. Scegliere Esci dal menu File, quindi riavviare il computer.

Come immettere nuovamente la password

NOTA: questa procedura funziona sia in Windows 2000 che in Windows XP.
  1. Fare clic sul pulsante Start, scegliere Impostazioni, quindi Pannello di controllo.
  2. Fare doppio clic sull'icona Posta elettronica, quindi fare clic sulla scheda Posta elettronica.
  3. Nella colonna Account selezionare l'account dell'ISP, quindi scegliere Proprietà.
  4. Fare clic su Server, digitare la password nella casella Password, quindi fare clic su Memorizza password.
  5. Scegliere OK, quindi Chiudi.
  6. Chiudere il Pannello di controllo e avviare Outlook.
  7. Scegliere Invia e ricevi dal menu Strumenti per verificare se la password è stata mantenuta.
NOTA: se altri utenti di Windows 2000 o Windows XP presentano problemi con la memorizzazione della password, reinserire la password, quindi selezionare la casella Memorizza password per i profili di tali utenti.

Le informazioni in questo articolo si applicano a
  • Microsoft Outlook 2000 Standard Edition
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