回復エージェントの EFS 秘密キーをエクスポートできません。

文書翻訳 文書翻訳
文書番号: 259732 - 対象製品
すべて展開する | すべて折りたたむ

現象

暗号化されたデータの回復を実行するときは、証明書のエクスポート ウィザード] の「秘密キーのエクスポート」] セクションは完全にスキップされますかや、秘密キーのエクスポート] 画面で、 秘密キーを [Yes/はい] にエクスポート オプションがアクティブでない選択することはできません。 いいえ、秘密キーはエクスポートしない ] オプションは、唯一の有効な選択です。 秘密キーをエクスポートするオプションがアクティブでないの場合は、次のエラー メッセージが表示されます。
注意: 関連付けられた秘密キーが見つかりません。 証明書のみをエクスポートできます。
通常、秘密キーをエクスポートするオプションは"秘密キーのエクスポート] で、証明書のエクスポート ウィザードのセクションは利用可能な。

原因

この現象は管理者のプロファイルが別のユーザーのプロファイルに上書きされた場合に発生はするがあります。 ローカル管理者グループに属しているユーザーのユーザー プロファイルを介して別のユーザーのプロファイルにコピーことができます。 これは通常、最小限の労力でプロファイルをレプリケートする行われます。 コンピューターこれはローカル管理者のプロファイルを場合、有効な EFS 回復エージェントとして、管理者は認識できなくします。

またありますこの動作エクスポート可能な証明書を発行しない証明書サーバーの要求を行った場合。 この限りではあれば既に発行された新しい証明書を要求します。

重要 : すべてのデータが暗号化されていないされるまで、既存の証明書を削除しないでし re-encrypted とします。

: デフォルトのドメインのメンバーでないスタンドアロンの Windows 2000 Professional ベース コンピューターの EFS 回復エージェントはローカルの管理者です。

解決方法

回復エージェントの秘密キーを復元するには、いずれか、次の方法の使用します。
  • 管理者のプロファイルが上書きされる前に作成されたバックアップから、管理者のユーザー プロファイルを復元します。
  • EFS を使用して、データの前に行ったバックアップからデータが暗号化を復元します。
プロファイルは上書きされず、EFS 回復エージェントから秘密キーを抽出する必要があります。 これが、スタンドアロン コンピューターである場合他の回復エージェントが利用できません。 利用可能な他の回復エージェントがないと EFS 秘密キーがバックアップされていない場合、データは回復できません。

詳細

Windows 2000 における EFS の追加についてはをクリック資料以下の記事の「サポート技術情報」(Microsoft Knowledge Base) を表示します。
241201暗号化ファイル システムの秘密キーをバックアップする方法
255742暗号化されたデータ ファイルを回復する方法
223316暗号化ファイル システムに関するヒント集
242296ハウツー解説: 暗号化されたデータの回復エージェントは、EFS 秘密キーを復元するには
EFS に関連する追加情報は、次の Microsoft の Web サイトで入手できます。
http://www.microsoft.com/technet/security/prodtech/windows2000/w2kccadm/dataprot/w2kadm21.mspx

プロパティ

文書番号: 259732 - 最終更新日: 2007年10月31日 - リビジョン: 3.4
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
キーワード:?
kberrmsg kbenv kbprb kbmt KB259732 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:259732
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com