Cómo solucionar problemas de permisos de inicio de servicio

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Para obtener una versión de este artículo para Microsoft Windows XP, consulte 314357.
Aviso
Este artículo se aplica a Windows 2000. El soporte técnico para Windows 2000 finaliza el 13 de julio de 2010. El Centro de soluciones de fin de soporte técnico de Windows 2000 representa un punto de partida para la planificación de una estrategia de migración desde Windows 2000. Para obtener información adicional, consulte la directiva del ciclo de vida de soporte técnico de Microsoft.
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Síntomas

Si el servicio no se inicia debido a un error de inicio de sesión, pueden aparecer los siguientes mensajes de error.

Cuando reinicia el servidor, pueden aparecer los siguientes mensajes de error en el registro de sucesos del sistema:
  • Origen: Administrador de control de servicios
    Identificador de evento: 7000
    Descripción:
    Se produjo un error al iniciar el servicio %servicio% debido al error siguiente:
    El servicio no se inició debido a un error de inicio de sesión.

    Los datos no estarán disponibles.Fuente: Administrador de control de servicios
    Identificador de evento: 7013
    Descripción:
    No se pudo iniciar sesión con la contraseña actual y se mostró el error siguiente:
    Error de inicio de sesión: nombre de usuario desconocido o contraseña incorrecta.

    Los datos no estarán disponibles.
Cuando intente iniciar el servicio de forma manual, es posible que aparezca el mensaje de error siguiente:
Microsoft Management Console
No es posible iniciar el servicio %servicio% en el equipo local.
Error 1069: El servicio no se inició debido a un error de inicio de sesión.
NOTA: El mensaje de error se produce aunque la cuenta de usuario sea válida.

Causa

Este comportamiento puede producirse por cualquiera de los siguientes motivos:
  • Se cambió la contraseña en la cuenta configurada para iniciar sesión en el servicio.
  • La fecha de la contraseña en el Registro es incorrecta.
  • El derecho de inicio de sesión como un servicio está revocado para la cuenta de usuario indicada.

Solución

Para resolver estos problemas, puede configurar el servicio para usar la cuenta de sistema integrada, cambie la contraseña para la cuenta de usuario indicada con el fin de que coincida la contraseña actual para dicho usuario o restaure el derecho de usuario para iniciar sesión como un servicio.

Cómo configurar los derechos de usuario

Si se revoca el derecho a iniciar sesión como un servicio para la cuenta de usuario especificada, restaure el derecho realizando los siguientes pasos:

Controlador de dominio

Si el usuario está en un dominio de Active Directory:
  1. Inicie el complemento Usuarios y equipos de Active Directory de Microsoft Management Console (MMC).
  2. Haga clic con el botón secundario en la unidad organizativa (UO) en que se otorga al usuario el derecho de iniciar sesión como servicio. De forma predeterminada, se encuentra en la unidad organizativa Controladores de dominio.
  3. Haga clic con el botón secundario del contenedor y, a continuación, haga clic en Propiedades.
  4. En la pestaña Directiva de grupo, haga clic en Directiva predeterminada de controladores de dominio y, a continuación, haga clic en Modificar. Esto iniciará el Administrador de directivas de grupo.
  5. Expanda el objeto de la Configuración del equipo haciendo clic en el signo más (+) junto al objeto de la directiva. Bajo el objeto Configuración del equipo, expanda Configuración de Windows y, a continuación, expanda Configuración de seguridad.
  6. Expanda Directivas locales y, a continuación, haga clic en Asignación de derechos de usuario.
  7. En el panel derecho, haga clic con el botón secundario en Iniciar sesión como servicio y, a continuación, haga clic en Seguridad.
  8. Agregue a la directiva el usuario y haga clic en Aceptar.
  9. Cierre el Administrador de directivas de grupo, las propiedades de Directiva de grupo y salga del complemento Usuarios y equipos de Active Directory de Microsoft Management Console (MMC).

Servidor miembro

Si el usuario es miembro de un servidor miembro independiente:
  1. Inicie el complemento Configuración de seguridad local de MMC.
  2. Expanda Directivas locales y, a continuación, haga clic en Asignación de derechos de usuario.
  3. En el panel derecho, haga clic con el botón secundario en Iniciar sesión como servicio y, a continuación, haga clic en Seguridad.
  4. Agregue a la directiva el usuario y haga clic en Aceptar.
  5. Cierre el complemento Configuración de seguridad local MMC.

Cómo configurar la información de inicio de sesión del servicio

Para configurar la contraseña para la cuenta de usuario especificada de forma que coincida con la contraseña actual para ese usuario, siga los siguientes pasos:
  1. Haga clic en Inicio, seleccione Configuración, haga clic en Panel de control y, a continuación, haga doble clic en Herramientas administrativas.
  2. Haga doble clic en Servicios.
  3. Haga clic con el botón secundario en el servicio y, a continuación, haga clic en Propiedades.
  4. En la pestaña Iniciar sesión, cambie la contraseña y, a continuación, haga clic en Aplicar.
  5. En la pestaña General, haga clic en Iniciar para reiniciar el servicio.
  6. Salga de la herramienta Servicios.

Cómo configurar el servicio para que se inicie con la cuenta de sistema integrada

Si el servicio sigue sin funcionar con la cuenta de usuario especificada, configure el servicio para iniciar sesión en la cuenta de sistema incorporada siguiendo los pasos siguientes:
  1. Haga clic en Inicio, seleccione Configuración, haga clic en Panel de control y, a continuación, haga doble clic en Herramientas administrativas.
  2. Haga doble clic en Servicios.
  3. Haga clic con el botón secundario en el servicio y, a continuación, haga clic en Propiedades.
  4. En la pestaña Iniciar sesión, haga clic en Cuenta de sistema local y, a continuación, haga clic en Aceptar.

    NOTA: Normalmente no es necesario configurar un servicio para interactuar con el escritorio, por lo que no es necesario activar la casilla Permitir a los servicios que interactúen con el escritorio.
  5. En la pestaña General, haga clic en Iniciar para reiniciar el servicio.
  6. Salga de la herramienta Servicios.
Cuando intenta abrir las propiedades de un servicio desde la herramienta Servicios del Panel de control, el equipo puede dejar de responder (se bloquea) o puede recibir el mensaje de error siguiente:
El servidor RPC no está disponible.
Este problema se puede producir si el servicio Llamada a procedimiento remoto (RPC) no se inicia debido a un error de inicio de sesión con ese servicio o un servicio de dependencia. Algunos servicios tienen servicios de dependencia que no se inician hasta que sus servicios de dependencia se inician primero (por ejemplo, el servicio Workstation).

Si no puede iniciar la herramienta de Servicios, configure el servicio para usar la cuenta de sistema integrada siguiendo estos pasos:
  1. Inicie el Editor del Registro (Regedit.exe).Importante Esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. Sin embargo, la modificación incorrecta del Registro puede producir graves problemas. Por tanto, asegúrese de seguir estos pasos cuidadosamente. Para obtener mayor protección, realice una copia de seguridad del Registro antes de modificarlo. De esta forma, puede restaurarlo si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad del Registro y restaurarlo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    322756 Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows

  2. Busque el valor ObjectName en la siguiente clave de registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ServiceName
  3. En el menú Edición, haga clic en Modificar.
  4. En el cuadro Información del valor, escriba localsystem y, a continuación, haga clic en Aceptar.
  5. Cierre el Editor del Registro.
  6. Intente reiniciar el servicio. Es posible que tenga que reiniciar el equipo para que algunos servicios se reinicien correctamente.
Si no puede iniciar el Editor del Registro, puede modificar la información de la cuenta de servicio realizando una instalación paralela. Para obtener información adicional acerca de instalaciones paralelas, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
165748 Cómo deshabilitar un servicio o un dispositivo que impida que se inicie Windows NT
Aunque la mayoría de los servicios del sistema están configurados para utilizar las credenciales de la cuenta del sistema para iniciar sesión de forma predeterminada, puede configurarlas para utilizar en su lugar una cuenta de usuario específica. Cuando se cambia la contraseña de usuario, el campo de información de contraseña no se actualiza automáticamente en el servicio.

Más información

Puede iniciar el servicio con una cuenta del sistema local o especificando una cuenta de usuario específica y su contraseña. Si decide especificar una cuenta de usuario y una contraseña, es importante que el nombre de la cuenta y la contraseña sean siempre los mismos. Por ejemplo, no se le debería solicitar cambiar la contraseña de la cuenta ni cambiar el nombre. Si se producen estas dos situaciones (u otras similares), también deberá actualizar las credenciales de inicio de sesión correspondientes al servicio.
Nota: es un artículo de "PUBLICACIÓN RÁPIDA" creado directamente por la organización de soporte técnico de Microsoft. La información aquí contenida se proporciona como está, como respuesta a problemas que han surgido. Como consecuencia de la rapidez con la que lo hemos puesto disponible, los materiales podrían incluir errores tipográficos y pueden ser revisados en cualquier momento sin previo aviso. Vea las Condiciones de uso para otras consideraciones

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Id. de artículo: 259733 - Última revisión: miércoles, 08 de enero de 2014 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palabras clave: 
kbenv kberrmsg kbprb KB259733

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