Comment faire pour dépanner les autorisations de démarrage de service

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Cet article s'applique à Windows 2000. Le support pour Windows 2000 a pris fin le 13 juillet 2010. Le Centre de solutions - Clôture du support Windows 2000 est un point de départ pour votre stratégie de migration à partir de Windows 2000. Pour plus d'informations, reportez-vous à la politique de support de Microsoft.
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Sommaire

Symptômes

Lorsqu'un service ne démarre pas en raison d'un échec d'ouverture de session, les messages d'erreur suivants peuvent s'afficher.

Lorsque vous redémarrez le serveur, les messages d'erreur suivants peuvent s'afficher dans le journal des événements système :
  • Source : Gestionnaire de contrôle des services
    ID d'événement : 7000
    Description :
    Le service %service% n'a pas pu démarrer à cause de l'erreur suivante :
    L'échec d'une ouverture de session a empêché le démarrage du service.

    Aucune donnée ne sera disponible. Source : Gestionnaire de contrôle des services
    ID d'événement : 7013
    Description :
    La tentative d'ouverture de session avec le mot de passe actuel a échoué avec l'erreur :
    Échec d'ouverture de session : utilisateur inconnu ou mot de passe incorrect.

    Aucune donnée ne sera disponible.
Lorsque vous essayez de démarrer le service manuellement, le message d'erreur suivant peut s'afficher :
Microsoft Management Console
Impossible de démarrer le service %service% sur l'ordinateur local.
Erreur 1069 : L'échec d'une ouverture de session a empêché le démarrage du service.
REMARQUE : Le message d'erreur se produit même si le compte d'utilisateur est un utilisateur valide.

Cause

Ce problème peut se produire car :
  • Le mot de passe est modifié sur le compte sur lequel service est configuré pour ouvrir une session.
  • Les données de mot de passe dans le Registre sont endommagées.
  • Le droit d'ouvrir une session en tant que service est annulé pour le compte d'utilisateur spécifié.

Résolution

Pour résoudre ces problèmes, vous pouvez configurer le service pour qu'il utilise le compte système intégré, modifier le mot de passe du compte d'utilisateur spécifié pour qu'il corresponde au mot de passe actuel de cet utilisateur, ou restaurer le droit de l'utilisateur à ouvrir une session en tant que service.

Comment configurer les droits d'utilisateur

Si le droit d'ouvrir une session en tant que service est annulé pour le compte d'utilisateur spécifié, restaurez-le en procédant comme suit :

Contrôleur de domaine

Si l'utilisateur est dans un domaine Active Directory :
  1. Démarrez la console MMC (Microsoft Management Console) Utilisateurs et ordinateurs Active Directory.
  2. Cliquez avec le bouton droit sur l'unité d'organisation (OU) sur laquelle le droit d'utilisateur d'ouvrir une session en tant que service est accordé. Par défaut, il s'agit de l'unité d'organisation Contrôleurs de domaine.
  3. Cliquez avec le bouton droit sur le conteneur, puis cliquez sur Propriétés.
  4. Sous l'onglet Stratégie de groupe, cliquez sur Stratégie des contrôleurs de domaine par défaut, puis sur Modifier. Cette opération démarre le Gestionnaire de stratégie de groupe.
  5. Développez l'objet Configuration de l'ordinateur en cliquant sur le signe plus (+) en regard de l'objet de stratégie. Sous l'objet Configuration de l'ordinateur, développez Paramètres Windows, puis Paramètres de sécurité.
  6. Développez Stratégies locales, puis cliquez sur Attribution des droits utilisateur.
  7. Dans le volet droit, cliquez avec le bouton droit sur Ouvrir une session en tant que service, puis cliquez sur Sécurité.
  8. Ajoutez l'utilisateur à la stratégie, puis cliquez sur OK.
  9. Quittez le Gestionnaire de stratégie de groupe, fermez les propriétés Stratégie de groupe, puis fermez le composant logiciel enfichable MMC Utilisateurs et ordinateurs Active Directory.

Serveur membre

Si l'utilisateur est membre d'un serveur membre autonome :
  1. Démarrez le composant logiciel enfichable MMC Paramètres de sécurité locaux.
  2. Développez Stratégies locales, puis cliquez sur Attribution des droits utilisateur.
  3. Dans le volet droit, cliquez avec le bouton droit sur Ouvrir une session en tant que service, puis cliquez sur Sécurité.
  4. Ajoutez l'utilisateur à la stratégie, puis cliquez sur OK.
  5. Fermez le composant logiciel enfichable MMC Paramètres de sécurité locaux.

Comment faire pour configurer les informations d'ouverture de session du service

Pour configurer le mot de passe du compte d'utilisateur spécifié pour qu'il corresponde au mot de passe actuel de cet utilisateur, procédez comme suit :
  1. Cliquez sur Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Outils d'administration.
  2. Double-cliquez sur Services.
  3. Cliquez avec le bouton droit sur le service approprié, puis cliquez sur Propriétés.
  4. Sous l'onglet Ouvrir une session, modifiez le mot de passe, puis cliquez sur Appliquer.
  5. Sous l'onglet Général, cliquez sur Démarrer pour redémarrer le service.
  6. Fermez l'outil des services.

Comment faire pour configurer le service pour qu'il démarre avec le compte système intégré

Si le service ne fonctionne pas avec le compte d'utilisateur spécifié, vous pouvez le configurer pour qu'il démarre avec le compte système intégré en procédant comme suit :
  1. Cliquez sur Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Outils d'administration.
  2. Double-cliquez sur Services.
  3. Cliquez avec le bouton droit sur le service approprié, puis cliquez sur Propriétés.
  4. Sous l'onglet Connexion, cliquez sur Compte système local, puis sur Appliquer.

    REMARQUE : En général, vous n'avez pas besoin de configurer un service pour interagir avec le Bureau ; vous pouvez donc laisser l'option Autoriser le service à interagir avec le Bureau désactivée.
  5. Sous l'onglet Général, cliquez sur Démarrer pour redémarrer le service.
  6. Fermez l'outil des services.
Lorsque vous essayez d'ouvrir les propriétés d'un service au moyen de l'outil Services du Panneau de configuration, l'ordinateur est susceptible de se bloquer et de ne plus répondre, et vous pouvez recevoir le message d'erreur suivant :
Le serveur RPC n'est pas disponible
Ce message d'erreur peut s'afficher si le service RPC (remote procedure call) n'a pas démarré en raison de l'échec d'une ouverture de session avec ce service ou un service dépendant. Certains services ont des services dépendants et ne peuvent pas démarrer avant leur services dépendants (par exemple, la Station de travail).

Si l'outil Services ne démarre pas, configurez le service pour qu'il démarre avec le compte système intégré, en procédant comme suit :
  1. Démarrez l'Éditeur du Registre (Regedit.exe).Important Cette section, méthode ou tâche explique la procédure à suivre pour modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre scrupuleusement ces étapes. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
    322756 Procédure de sauvegarde et de restauration du Registre dans Windows

  2. Recherchez la valeur ObjectName dans la clé de Registre suivante :
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ServiceName
  3. Dans le menu Edition, cliquez sur Modifier.
  4. Dans la zone Données de la valeur, tapez localsystem, puis cliquez sur OK.
  5. Quittez l'Éditeur du Registre.
  6. Essayez de redémarrer le service. Vous devrez peut-être redémarrer l'ordinateur pour redémarrer correctement certains services.
Si vous ne pouvez pas démarrer l'Éditeur du Registre, vous pouvez modifier les informations de compte de service en effectuant une installation parallèle. Pour plus d'informations sur les installations parallèles, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
165748 Comment faire pour désactiver un service ou un périphérique qui empêche le démarrage de NT
Bien que la plupart des services système ouvrent leur session sur le compte système local par défaut, vous pouvez les configurer pour qu'ils utilisent un compte d'utilisateur spécifique. Lorsque le mot de passe d'un utilisateur est modifié, les informations de mot de passe ne sont pas automatiquement mises à jour pour les services.

Plus d'informations

Vous pouvez démarrer un service avec le compte système local ou en spécifiant un compte d'utilisateur et un mot de passe spécifiques. Si vous décidez d'indiquer un compte d'utilisateur et un mot de passe, il est important de ne pas modifier le nom de compte et le mot de passe. Par exemple, ce compte ne doit pas être tenu de modifier son mot de passe ni d'être renommé. Si ces deux événements (ou des événements similaires) se produisent, vous devez également mettre à jour les informations d'identification du service.
Remarque Il s'agit d'un article de « PUBLICATION RAPIDE » rédigé directement au sein du service de support technique Microsoft. Les informations qui y sont contenues sont fournies en l'état, en réponse à des problèmes émergents. En raison du délai rapide de mise à disposition, les informations peuvent contenir des erreurs typographiques et, à tout moment et sans préavis, faire l'objet de révisions. Pour d'autres considérations, consultez les Conditions d'utilisation.

Propriétés

Numéro d'article: 259733 - Dernière mise à jour: mercredi 8 janvier 2014 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professionnel
Mots-clés : 
kbenv kberrmsg kbprb KB259733
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