Connecting to a Windows Virtual PC virtual machine fails with error: Cannot start virtual application

Article ID: 2598988 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:

· Windows XP is installed in a Windows Virtual PC virtual machine.

· The Windows XP installation is joined to the domain.

· After joining the domain, when you double-click the XP virtual machine to connect to the VM, you receive the following error:

Cannot start virtual application

If you click OK and double-click the virtual machine again, the following error occurs:

Integration features have been disabled

You can log on to continue without these features. To enable the integration features, you can shut down the virtual machine and start it again.

If you click OK, the virtual machine window will launch in basic mode.

If you close and re-open the virtual machine, the errors occur again.

Note: The “Cannot start virtual application”error can also occur when attempting to launch a virtual application.

CAUSE

This issue can occur if the Remote Desktop feature in the Windows XP installation has been disabled by a group policy. Windows Virtual PC uses the Remote Desktop feature to connect to the virtual machine. If this feature is disabled, the errors listed in the symptom section will occur when connecting to the virtual machine.

RESOLUTION

Once you’re able to connect to the virtual machine in Basic Mode, perform the following steps in the Windows XP installation:

1. Click Start and then click Run.

2. Type Regedit and then click OK.

3. Navigate to the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services

4. If the fDenyTSConnections registry value is set to 1, change the value to 0 and then click OK.

5. Modify the group policy being applied to this machine to prevent the Remote Desktop feature from being disabled again.

6. Close and re-open the virtual machine window to confirm that the errors no longer occur.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Article ID: 2598988 - Last Review: August 15, 2011 - Revision: 2.0
APPLIES TO
  • Windows Virtual PC
Keywords: 
KB2598988

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