Artikel-ID: 260067 - Geändert am: Samstag, 12. Mai 2007 - Version: 2.7

Windows hängt beim Herunterfahren mit zugeordneten Laufwerken

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Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
260067  (http://support.microsoft.com/kb/260067/EN-US/ ) Windows Stops Responding During Shutdown with Mapped Drives
Wichtig: Dieser Artikel enthält Informationen zum Bearbeiten der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie im folgenden Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/DE/ ) Beschreibung der Microsoft Windows-Registrierung
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn Sie sehr viele Netzlaufwerke zugeordnet haben, d. h. diesen einen Laufwerksbuchstaben zugewiesen haben, reagiert der Computer möglicherweise beim Herunterfahren nicht mehr (hängt). Das Auftreten dieses Problem ist umso wahrscheinlicher, je mehr Laufwerke Sie zuordnen. Das Problem wurde bisher ab acht zugeordneten Laufwerken beobachtet.

Hinweis. In folgenden Situationen liegt eine geringe Wahrscheinlichkeit für das Auftreten dieses Problems in Windows 98 vor:
  • Sie aktualisieren den Bildschirmtreiber und starten Windows anschließend neu.
  • Sie ändern die Schriftgröße der Anzeige und starten Windows anschließend neu.
  • Eine 16-Bit-Anwendung ruft die Win16 API-Funktion ExitWindows mit dem Flag EW_RESTARTWINDOWS auf.
Hinweis: Für eine möglichst effektive Suche in der Microsoft Knowledge Base verwenden Sie bitte Schlüsselwörter, die einen Bezug zu Ihrem Problem aufweisen. Wenn Sie Informationen zur Problembehandlung benötigen und dieser Artikel Ihnen nicht die erforderlichen Informationen bietet, durchsuchen Sie die Microsoft Knowledge Base mithilfe der im folgenden Artikel der Microsoft Knowledge Base aufgeführten Tipps:
242450  (http://support.microsoft.com/kb/242450/DE/ ) Tipps für Suchanfragen in der Microsoft Knowledge Base anhand von Suchbegriffen

Ursache

Dieses Problem kann auftreten, da während des Herunterfahrens eine WM_DEVICECHANGE-Meldung an alle Fenster oberster Ebene gesendet wird. Diese Meldung informiert jedes Fenster über ein DBT_DEVICEREMOVECOMPLETE-Ereignis. Wenn ein Fenster nicht auf die gesendete Systemmeldung reagiert, reagiert der Computer nicht mehr (hängt).

Unter den genannten Bedingungen wird das Betriebssystemkernel möglicherweise heruntergefahren, obwohl sich noch Systemmeldungen in der Warteschlange für die Übermittlung befinden. Dadurch werden alle Vorgänge zur Verarbeitung von Eingaben angehalten, was dazu führt, dass die Fenster nicht mehr reagieren (und die Datei "Msgsrv32" hängt).

Lösung

Ein Update zur Behebung dieses Problems ist inzwischen von Microsoft erhältlich; dieses Update wurde jedoch ausschließlich zur Behebung des in diesem Artikel beschriebenen Problems entwickelt. Deshalb sollten Sie nur Systeme aktualisieren, bei denen dieses spezielle Problem auftritt. Dieses Update wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft, auf das nächste Service Pack zu warten, das diesen Hotfix enthält.

Wenn Sie das Problem sofort beheben möchten, wenden Sie sich an Microsoft Product Support Services, um das Update zu erhalten. Die Telefonnummern des Technischen Supports lauten:

Deutschland: 0180 567 23 30
Österreich: 01 50222 23 30
Schweiz: 0848 80 23 30

Alternativ erhalten Sie auch eine vollständige Liste mit Telefonnummern der Microsoft Product Support Services unter der folgenden Adresse im World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;DE;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;de;cntactms)
Die englische Version dieses Updates sollte die folgenden Dateiattribute aufweisen (oder ein späteres Datum besitzen):
Datum       Zeit    Version    Größe    Dateiname   Plattform
----------------------------------------------------------------------------- 
04/21/2000  11:33a  4.10.2227   55,296  User32.dll  Windows 98 Second Edition
04/19/2000  04:02p  4.10.2227  549,760  User.exe    Windows 98 Second Edition
	

Hinweis: Derzeit sind keine weiteren Updates für Windows 98 geplant. Bitte lesen Sie die Informationen im Abschnitt zur Problembehandlung.

Abhilfe

Aktualisieren Sie auf Microsoft Windows Millennium Edition (Me), oder trennen Sie alle zugeordneten Netzlaufwerke vor dem Herunterfahren von Windows, um dieses Problem zu umgehen.

Status

Microsoft hat bestätigt, dass es sich hierbei um ein Problem in Windows 98 Second Edition handelt.

Dieses Problem wurde in Windows Millennium Edition behoben.

Weitere Informationen

Achtung: Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallierung des Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.

Nach dem Installieren des Updates wird für 1.000 Millisekunden (Standardwert) gewartet wird, bevor das Herunterfahren des Kernels eingeleitet wird, wenn erkannt wird, dass sich noch Systemmeldungen in der Warteschlange befinden. Dieser Wert kann unter Windows 95 (alle Versionen) nicht geändert werden, wo er 1.500 Millisekunden beträgt. In Windows 98 Second Edition können Sie diesen Standardwert mithilfe des folgenden Registrierungseintrags überschreiben:
Schlüssel: HKEY_CURRENT_USER\Control Panel\Desktop
Wert: ShutDownWaitTime
Typ: DWORD
Daten: Anzahl der Millisekunden bis zum Herunterfahren des Kernels
Dieser Artikel und das darin beschriebene Update Tritt an die Stelle des folgenden Microsoft Knowledge Base-Artikels:
242934  (http://support.microsoft.com/kb/242934/DE/ ) Windows reagiert nicht mehr bei Übertragung einer Systemnachricht während des Herunterfahrens
Weitere Informationen darüber, wie Sie die Erweiterung zum Herunterfahren für Windows 98 Second Edition erhalten und installieren, finden Sie im folgenden Artikel der Microsoft Knowledge Base:
239887  (http://support.microsoft.com/kb/239887/DE/ ) Windows 98 Second Edition Erweiterung zum Herunterfahren
Weitere Informationen zur Behandlung von Problemen beim Herunterfahren in Windows 98 und Windows 98 Second Edition finden Sie im folgenden Artikel der Microsoft Knowledge Base:
202633  (http://support.microsoft.com/kb/202633/DE/ ) Beheben von Problemen beim Herunterfahren von Windows 98
Weitere Informationen zu Updates für Windows 98 und Windows 98 Second Edition finden Sie im folgenden Artikel der Microsoft Knowledge Base:
206071  (http://support.microsoft.com/kb/206071/DE/ ) Allgemeine Informationen über Windows 98- und Windows 98 Second Edition-Updates
Weitere Informationen zu Updates für Windows 95 finden Sie im folgenden Artikel der Microsoft Knowledge Base:
161020  (http://support.microsoft.com/kb/161020/DE/ ) Implementierung von Windows 95-Updates

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 95
  • Microsoft Windows 98 Standard Edition
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