現象
次のような状況で問題が発生します。
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Exchange Server 2010 Service Pack 1 (SP1) 環境で Microsoft Office Outlook がオンライン モードで実行されています。
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ユーザーが Outlook を使用して、メールボックス内のいくつかの添付ファイルが付いたアイテムを開きます。
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ユーザーが、添付ファイルを削除してからアイテムを保存します。
この場合、Microsoft Exchange RPC クライアント アクセス サービスがクラッシュします。さらに、Exchange Server 2010 クライアント アクセス サーバーのアプリケーション ログに次のイベントが記録されます。
ログの名前: アプリケーション
ソース: MSExchange Common
日付: 日付
イベント ID: 4999
タスクのカテゴリ: 全般
レベル: エラー
キーワード: クラシック
ユーザー: N/A
コンピューター: コンピューター名
説明:
プロセス ID プロセス ID のワトソン博士のレポートが送信されます。パラメーター: E12、ビルドの種類、バージョン番号、M.E.RpcClientAccess.Service、M.E.Data.Storage、M.E.D.S.MemoryPropertyBag.TryGetStoreProperty、M.E.D.Storage.NotInBagPropertyErrorException、XXXX、バージョン番号.
ErrorReportingEnabled: False
注: この問題が発生した場合、ドメインのオンライン Outlook ユーザーが、Exchange Server から切断されます。
原因
この問題は、ユーザーが添付ファイルを削除した後に PropertyBag オブジェクトがクリアされることが原因で発生します。
プロパティが再読み込みされず、NotInBagPropertyErrorException 例外が発生します。そのため、RPC クライアント アクセス サービスがクラッシュします。
解決方法
この問題を解決するには、次の更新プログラムのロールアップ パッケージをインストールします。
2608646 Exchange Server 2010 Service Pack 1 用の更新プログラムのロールアップ 6 について
状況
マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。
詳細
DeleteAttachment 要素の詳細については、以下のマイクロソフト Web サイトを参照してください。
DeleteAttachment 要素に関する一般的な情報NotInBagPropertyErrorException クラスの詳細については、次のマイクロソフト Web サイトを参照してください。