You may experience My Picture issues when you use Lync in Office 365 dedicated

Article ID: 2604334 - View products that this article applies to.
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Symptoms

When you use the Microsoft Lync client in Microsoft Office 365 dedicated, you experience one or more of the following issues:
  • You cannot set the My Picture option.
  • You cannot see My Picture.
  • You cannot see pictures of other users.

Cause

This issue may occur for one or more of the following reasons:
  • The thumbnailPhoto attribute is not populated correctly in the source Active Directory schema.
  • The thumbnailPhoto attribute is not populated correctly in the managed Active Directory schema.
  • The Lync server is configured incorrectly to pull the correct information from the Active Directory schema or from Microsoft SharePoint MySite.
  • SharePoint servers do not update the MySite picture correctly.
  • Group Policy prevents end-users from setting the My Picture feature.
  • A global policy prevents end-users from changing the My Picture feature by using SharePoint MySite.

Resolution

Troubleshooting Prerequisites 


To make sure that the My picture feature works, one or more of the following criteria must be met:  
  • The feature must be enabled for your organization. If you are not sure about this, work with your Service Delivery Manager (SDM) to make sure that the feature is enabled.
  • You must have access permission to the Active Directory schema to verify various account object attributes.
  • If you use the MySite Personal Photo option, you must use one of the following versions of Microsoft Office SharePoint Server: 
    • Office SharePoint Server 2007 or a later version, together with a maintained SharePoint MySite. 

Troubleshooting Steps

You cannot change the photo in the Lync Client

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

To troubleshoot the issue, follow these steps:
  1. Make sure that you don't have a Group Policy setting that prevents the feature from being changed in the Lync client.
  2. Make sure that you're using the thumbnailPhoto attribute. Make sure that the attribute is populated in the source and in managed Active Directory schemas as outlined in the Lync service description. Also, make sure that the uploaded folder does not exceed the 30 kilobyte (KB) size limit.
  3. In the Lync client, open the My Picture option. To do this, use one of the following methods:
    • Click the photo.
    • Click the gear icon, point to Tools, click Options, and then click My Picture.
  4. Check the option that is selected. There are only three options:
    • Do not show my picture
    • Default corporate

      That is, obtain a picture from the user's MySite. 
    • Show a picture from a web address

  5. Determine whether the Edit in MySite option can be accessed from the Lync client. If the Edit in MySite option cannot be accessed, confirm whether this option was enabled or disabled at the time that the My Picture feature was added. If you are not sure about this, work with your SDM to verify that. However, if the feature is enabled, and if clicking Edit in MySite hyperlink does not open your MySite profile through a web browser, you must deploy the following registry key:
    Collapse this tableExpand this table
    Subkey Data type Value name Value data
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\common\Portal\Link Providers\MySiteHost
    REG_SZURLYour My Site URL: For example, http:// mysite.contoso.com
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\common\Portal\Link Providers\MySiteHost
    REG_SZDisplayNameYour display name: For example, My site
  6. Check whether you can update your photo by using the SharePoint MySite profile. Change the photo, and then wait 24 hours for Lync to display the new photo.
  7. Check whether you can update your photo by using the Show a picture from a web address option from the Lync client.

    Note Make sure that the URL ends with the file name of the photo, as the following example:
    http://www.example.com/mypicture.jpg
The Lync client cannot upload a photo. It can only display a photo from an Active Directory attribute (that is, a photo updatable through OWA now), from a website, or from SharePoint MySite.



Escalation steps

  1. Please contact Microsoft Online Services Support by online submission or by telephone.
  2. Provide the following information to Microsoft Online Services Support:
    1. Screen shots of your My Picture settings in the Lync client.
    2. A screen shot of your thumbnailPhoto attribute.
    3. The CR number, if it is a newly added feature.

You cannot see a picture of a contact in the contact list

To troubleshoot this issue, follow these steps:
  1. Make sure that the Lync client is set to either the Contacts view or the Activity Feeds view. The Conversations view does not display a contact picture or a photo.
  2. Completely exit the Lync client.
  3. Locate the following folder:
    • For Lync 2013:  
      %userprofile%\AppData\Local\Microsoft\Office\15.0\Lync\sip_<username@domain>\
    • In Windows 7 or in Windows Vista:
      %userprofile%\AppData\Local\Microsoft\Communicator\sip_<username@domain>\
    • In Windows XP:
      %userprofile%\Local Settings\Application Data\Microsoft\Communicator\sip_ <username@domain>\
    Note The placeholder <username@domain> represents the user's domain account.
  4. Delete the PresencePhoto cache file.
  5. Restart the Lync client.
  6. Try to reproduce the issue.
  7. If the issue still occurs, make sure that the PresencePhoto cache file is repopulated. 
Escalation steps

  1. Please contact Microsoft Online Services Support by online submission or by telephone.
  2. Provide the following information to Microsoft Online Services Support:
    1. A screen shot of your thumbnailPhoto attribute.
    2. Screen shots of your PresencePhoto cache file properties.
    3. The CR number, if it is a newly added feature.

More information

For more information about the My Picture feature in Lync, about how you can manage photos, and about how photos are downloaded to clients, go to the following Microsoft website:
General information about Microsoft Lync 2010 photo experience

Properties

Article ID: 2604334 - Last Review: July 26, 2013 - Revision: 14.0
Applies to
  • Microsoft Business Productivity Online Dedicated
  • Microsoft Business Productivity Online Suite Federal
  • Microsoft Lync Online
  • Microsoft SharePoint Online
Keywords: 
vkbportal226 KB2604334

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