Error message when you run the "Let us help you troubleshoot your calendar" utility in Exchange 2010: "LogLocation is not specified"

Article ID: 2604978 - View products that this article applies to.
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Symptoms

Consider the following scenarios.

Scenario 1
  • You install Microsoft Exchange Server 2010.
  • You start Microsoft Outlook Web App (OWA).
  • You click Options, and then you click See All Options.
  • You click Settings, and then you click Calendar.
  • You click Let us help you troubleshoot your calendar.
  • You type a subject, and then you click Send My Calendar Logs.
Scenario 2
  • You install Microsoft Exchange Server 2010.
  • You start the Exchange Management Shell (EMS).
  • You run the Get-CalendarDiagnosticLog cmdlet.
In these scenarios, you may receive an error message that resembles the following:
LogLocation is not specified. Specify a log location using the "LogLocation" parameter or set the "LogLocation" value under the registry "SOFTWARE\Microsoft\ExchangeServer\v14\CalendarLogs" key.

Cause

This issue occurs if the LogLocation registry subkey is not configured.

Note By default, the LogLocation registry subkey is not configured.

Resolution

To resolve this issue, create the LogLocation registry subkey.

Note If this error occurs in Outlook Web App or in Exchange Control Panel (ECP), create the LogLocation registry subkey on the server that has the Client Access server (CAS) role. If the error occurs in EMS, create the LogLocation registry subkey on the server to which EMS is connected.

To create the LogLocation registry subkey, follow these steps.
  1. Click Start, click Run, type regedit, and then press Enter.
  2. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\ExchangeServer\v14
  3. Right-click v14, click New, and then click Key.
  4. Type CalendarLogs, and then press Enter.
  5. Right-click CalendarLogs, click New, and then click String Value.
  6. Type LogLocation, and then press Enter.
  7. Right-click LogLocation, and then click Modify.
  8. In the Value Data box, type the file system location for the log file, and then click OK.

    Note The default file system location is as follows:
    \Program Files\Microsoft\Exchange Server\V14\Logging\Calendar Repair Assistant
  9. Exit Registry Editor.

Properties

Article ID: 2604978 - Last Review: July 19, 2012 - Revision: 1.0
Applies to
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
Keywords: 
kbsurveynew kbprb kbtshoot KB2604978

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