PRB : Message d'erreur: « Impossible de charger traducteur ou bibliothèque »

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Symptômes

Lorsque vous installez un logiciel qui tente de modifier la configuration de ODBC ou installer les composants ODBC, tels que Microsoft Data Access Components, service packs ou Microsoft Access, ou vous configurez une source de données ODBC par le biais de l'administrateur ODBC, le message d'erreur suivant s'affiche :
Impossible de charger le traducteur ou bibliothèque d'installation.
Ce message peut être accompagné par un des messages d'erreur suivants :
Impossible de configurer le pilote ODBC <driver name=""></driver>.

Les routines d'installation du <driver name=""></driver> n'a pas pu être chargé en raison du code d'erreur système 126.

Pilote n'a pas pu être chargé en raison du code d'erreur système 1157.
Ces messages peuvent inclure un nom de pilote, comme "Microsoft Access Driver {*.mdb} » « SQL Server », ou « Microsoft ODBC pour Oracle ODBC pilote."

Cause

Il existe deux causes possibles de ce problème :
  • Paramètres de Registre incorrectes pour les composants MDAC.
  • Fichiers .dll incompatible.
Ces problèmes peuvent se manifester en raison d'une installation de logiciels plus anciens qui a modifié les paramètres de Registre de pilotes ODBC ou par le remplacement de certains fichiers .dll avec des versions incompatibles.

Résolution

Important Cette section, la méthode ou la tâche qui va suivre contient des étapes qui vous indiquent la méthode pour modifier le Registre de Windows. Toutefois, des problèmes sérieux peuvent survenir si vous modifiez le Registre de façon incorrecte. Par conséquent, assurez-vous de suivre ces étapes avec une attention toute particulière. Afin de couvrir votre système d'une protection supplémentaire, veuillez sauvegarder le Registre avant d'intervenir pour y apporter des modifications. Ainsi, si à la suite des modifications un problème devait survenir, vous pourrez toujours restaurer le Registre. Pour obtenir des informations sur la marche à suivre pour sauvegarder ou restaurer la Base de Registre, cliquez sur le lien (numéro) ci-dessous et afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment sauvegarder et restaurer le Registre dans Windows

Résolution de problème de paramètres de Registre incorrectes :

  1. Démarrez l'éditeur du Registre (Regedt32.exe).
  2. Recherchez la clé suivante dans le Registre :
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI
    Informations d'installation de pilotes ODBC sont stockées dans cette clé. Assurez-vous que tous les fichiers de pilote ODBC requis sont dans le dossier approprié, tel que décrit par les clés de Registre. Par exemple, supposons que vous avez les informations suivantes dans votre Registre pour le pilote ODBC Microsoft Access :
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Microsoft Access Driver (*.mdb)

    Pilote = C:\WINNT\System\Odbcjt32.dll
    Le programme d'installation = C:\WINNT\System\Odbcjt32.dll
    Cela provoque une erreur si le fichier Odbcjt32.dll se trouve dans le dossier C:\WINNT\System32. Vous pouvez modifier les valeurs de clé de Registre à C:\WINNT\System32\odbcjt32.dll Pour résoudre ce problème. Vérifiez également que le fichier Odbcinst.ini comporte les entrées appropriées de la même façon.

    Toute valeur incorrecte dans HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI sous la clé d'installation provoquera cette erreur.
SQL Server ODBC pilote, la clé de Registre, le chemin d'accès et les DLL sont les suivants :
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.Serveur INI\SQL

Pilote = C:\WINNT\system32\SQLSRV32.dll
Le programme d'installation = C:\WINNT\system32\sqlsrv32.dll
Microsoft ODBC pour Oracle pilote, la clé de Registre, le chemin d'accès et les DLL sont les suivants :
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Microsoft ODBC pour Oracle

Pilote = C:\Windows\System32\msorcl32.dll
Le programme d'installation = C:\Windows\System32\msorcl32.dll

Résolution de problème de fichiers .dll incompatible :

Réinstallez votre version actuelle de MDAC, ou installez la dernière version. Consultez la section « Références » de cet article pour plus d'informations sur la reconfiguration d'une installation de MDAC. La dernière version de MDAC peut être téléchargée sur le site Web de Microsoft à l'adresse suivante :
http://msdn.Microsoft.com/en-us/Data/aa937729.aspx

Références

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
307255 INFO : Le vérificateur de composants : diagnostiquer et reconfigurer des Installations MDAC
232060 Comment faire : Installation de MDAC Guide de dépannage
243069 INFO : Liste d'utile MDAC Installation Articles connexes

Propriétés

Numéro d'article: 260558 - Dernière mise à jour: vendredi 5 avril 2013 - Version: 6.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Data Access Components 2.1
  • Microsoft Data Access Components 2.5
Mots-clés : 
kbdatabase kbprb kbmt KB260558 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 260558
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