PRB: Messaggio di errore: "Impossibile caricare la libreria di impostazione o del convertitore"

Traduzione articoli Traduzione articoli
Identificativo articolo: 260558 - Visualizza i prodotti a cui si riferisce l?articolo.
IMPORTANTE: in questo articolo sono contenute informazioni su come modificare il Registro di sistema. Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986 Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

Sintomi

Quando si installa un prodotto software che tenta di modificare la configurazione o si installano componenti ODBC, ad esempio Microsoft Data Access Components, service pack o Microsoft Access, oppure si configura un'origine dati ODBC tramite il componente Amministrazione ODBC, viene visualizzato un messaggio di errore analogo al seguente:
Impossibile caricare la libreria di impostazione o del convertitore.
Questo messaggio potrebbe essere accompagnato da un messaggio di errore analogo a uno dei seguenti:
Impossibile configurare il driver ODBC <nome_driver>.

Impossibile caricare le routine di impostazione per il driver <nome_driver>. Errore di sistema codice 126.

Impossibile caricare il driver. Errore di sistema codice 1157.
In questi messaggi può essere incluso un nome di driver, ad esempio "Microsoft Access Driver {*.mdb}"

Cause

Di seguito sono riportate le due possibili cause di questo problema:
  • Impostazioni del Registro di sistema non corrette per i componenti MDAC.
  • File DLL incompatibili.
Questi problemi possono essere insorti a causa dell'installazione di un prodotto software precedente che ha modificato le impostazioni del Registro di sistema dei driver ODBC o che ha sostituito alcuni file DLL con versioni incompatibili.

Risoluzione

AVVISO: l'errato utilizzo dell'editor del Registro di sistema può causare gravi problemi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non è in grado di garantire la risoluzione di problemi causati dall'errato utilizzo dell'editor del Registro di sistema. L'utilizzo dell'editor del Registro di sistema è a rischio e pericolo dell'utente.


Risoluzione per il problema causato da impostazioni del Registro di sistema non corrette:
  1. Avviare l'editor del Registro di sistema (Regedt32.exe).
  2. Individuare la seguente chiave nel Registro di sistema:
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI
    Le informazioni sull'installazione per i driver ODBC sono memorizzate in questa chiave. Assicurarsi che tutti i file dei driver ODBC necessari siano nella cartella corretta, secondo quanto descritto nelle chiavi del Registro di sistema. Si supponga, ad esempio, che nel Registro di sistema siano presenti le seguenti informazioni per il driver ODBC di Microsoft Access:
    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\Microsoft Access Driver (*.mdb)

    Driver = C:\WINNT\System\Odbcjt32.dll
    Setup = C:\WINNT\System\Odbcjt32.dll
    Queste impostazioni causano un errore se il file Odbcjt32.dll si trova nella cartella C:\WINNT\System32. Per risolvere il problema, è possibile modificare i valori del Registro di sistema in C:\WINNT\System32\odbcjt32.dll. Verificare inoltre allo stesso modo che le voci relative al file Odbcinst.ini siano corrette.

    Qualsiasi valore errato della chiave Setup in HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI causerà questo errore.

Risoluzione del problema relativo ai file DLL incompatibili:
Reinstallare la versione corrente di MDAC o installare la versione più recente. Per ulteriori informazioni sulla riconfigurazione di un'installazione MDAC, vedere la sezione "Riferimenti" di questo articolo. È possibile scaricare la versione più recente di MDAC dal seguente sito Web Microsoft (informazioni in lingua inglese):
http://msdn.microsoft.com/dataaccess

Riferimenti

Per ulteriori informazioni, fare clic sui numeri degli articoli della Microsoft Knowledge Base riportati di seguito:
307255 Component Checker: Diagnosi di problemi e riconfigurazione di installazioni MDAC
232060 HOWTO: Guida per la risoluzione dei problemi relativi all'installazione di MDAC
243069 INFO: Elenco di articoli utili relativi all'installazione di MDAC

Proprietà

Identificativo articolo: 260558 - Ultima modifica: giovedì 5 ottobre 2006 - Revisione: 3.0
Le informazioni in questo articolo si applicano a
  • Microsoft Data Access Components 2.0
  • Microsoft Data Access Components 2.1
  • Microsoft Data Access Components 2.5
Chiavi: 
kbdatabase kbprb KB260558
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com