Update: DTS "E-Mail senden" auf Postfach füllen und Outlook nicht Siehe oder E-Mails löschen

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# FEHLER: 57661 (SQLBUG_70)
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Problembeschreibung

Wenn Sie ein Paket, die Aufgabe von SQL Server-Data Transformation Services (DTS) senden Nachrichten verwendet erstellen, um Nachrichten zu senden, auffüllt Postfach des Absenders stetig da DTS-Fehlermeldungen wie z. B. Berichte:
Paket kann nicht ausgeführt werden, da Postfach voll ist.
Wenn Sie Microsoft Outlook SentItem Ordner des Absenders überprüfen und überprüfen Sie die Postfachgröße, die Postfachgröße ist jedoch nahe 0 KB, und nichts befindet sich im Postfach des Absenders vom Outlook Standpunkt aus.

Überprüfen Sie Größe des Postfachs des Absenders in der administrativen Exchange Server-Konsole zeigt die richtige Größe des Postfachs. Können nicht sehen Sie jedoch die Nachrichten, die das Postfach überlasten, da diese Nachrichten aus Outlook und Exchange Server ausgeblendet sind.

Ursache

Die Outlook und Exchange-Clients können keine Elemente unter dem Stammverzeichnis des Exchange Server-Informationsspeichers anzeigen. Wenn DTS-Nachricht die Nachricht sendet, hält DTS die Nachricht im Stammordner des Absenders ist (Quelle), die zu Postfach auf dem Exchange-Server ist. Daher kann keine Outlook-Client des Absenders anzeigen oder diese Nachrichten löschen.

Abhilfe

Verwenden Sie das Microsoft Exchange-Dienstprogramm MDB Viewer, um die ausgeblendeten e-Mail-Nachrichten anzuzeigen, die das Postfach zu füllen. MDB Viewer können auch diese Nachrichten löschen.

Gehen Sie zum Stammordner des Postfachs überprüfen, für die Verwendung von DTS-Nachricht konfiguriert ist, folgendermaßen vor:
  1. Kopieren Sie die folgenden Dateien auf einen Computer, auf dem Outlook installiert ist:

    • Mdbvu32.exe
    • Propvu32.dll
    • Statvu32.dll
    • Tbvlu32.dll
    • Xvport.dll

    Das Mdbvu32-Dienstprogramm und die zugehörigen DLL-Dateien auf Exchange Server 5.5-CD finden in entweder den \Server\Support\Utils\I386-Ordner oder den Ordner \Server\Support\Utils\Alpha.
  2. Überprüfen Sie, ob ein Profil für das Postfach des Benutzers, vorhanden ist, dass das Profil als Standardprofil aktiviert ist und, dass ein Benutzer (mit Berechtigung Postfach des Benutzers) erfolgreich die Client-Arbeitsstation angemeldet ist.
  3. Stellen Sie sicher, dass Outlook derzeit nicht auf der Arbeitsstation ausgeführt wird.
  4. Starten Sie MDB Viewer, indem Sie die MDBVU32.exe ausführbare Datei doppelklicken.
  5. Wenn das Dialogfeld MAPILogonEx geöffnet wird, aktivieren Sie das Kontrollkästchen Explicit MAPI-Profil , und klicken Sie dann auf OK .
  6. Wenn im Dialogfeld Profil auswählen angezeigt wird, wählen Sie das in den vorherigen Schritten erstellte Profil, und klicken Sie dann auf OK .

    Hinweis : Wenn im Dialogfeld Profil auswählen angezeigt wird, Sie sind wahrscheinlich bereits angemeldet zu einem Profil. Beenden, melden Sie sich der Client und das Profil und versuchen Sie es dann erneut.
  7. Menü MDB Viewer Testanwendung klicken Sie MDB und wählen Sie dann die Option OpenMessageStore aus.
  8. Wählen Sie im Dialogfeld Select Message Store To Open den Anzeigenamen Systemaufsicht (Server) , und klicken Sie dann auf Öffnen . (Offenen Modus sollte Best Access standardmäßig, den Sie als Standard lassen möchten.)
  9. Menü MDB Viewer-Testanwendung klicken Sie auf MDB und dann auf Open Root Folder .

    Am dieses Schritt sehen Sie, dass die Nachricht von DTS "DTStest1" im Stammverzeichnis der durch DTS verwendete Profil befindet. Das Stammverzeichnis ist auf der Clientseite ausgeblendet, so verwenden Sie Outlook. Sie können diese Meldung nicht sehen, aber es ist in diesem Postfach auch nach dem an den Empfänger senden gespeichert. Dies erklärt, warum das Postfach ist voll, aber Outlook konnte nicht sehen, was in diesem Postfach.
  10. Aktivieren Sie in das Fenster MAPI_FOLDER ROOT zweite das benannte Operation verfügbar . Wählen Sie Vorgang , und klicken Sie dann auf Funktion aufrufen . Wählen Sie die Funktion mit dem Namen LpFld_DeleteMEssages , und klicken Sie auf Funktion aufrufen , die ausgewählte Nachricht im Stammverzeichnis zu löschen.

Status

Microsoft hat ein Problem in SQL Server 7.0 dazu bestätigt. Dieses Problem wurde in Standard Service Pack 3 für Microsoft SQL Server 7.0 behoben. Weitere Informationen finden Sie im folgenden Artikel der Microsoft Knowledge Base:
274799INF: Wie Sie Service Pack 3 für Microsoft SQL Server 7.0 und Microsoft Data Engine (MSDE) 1.0 erhalten
Wenden Sie sich an Ihren primären Supportanbieter, um weitere Informationen zu erhalten.

Weitere Informationen

Wenn Sie den Task Mail senden in der Benutzeroberfläche von DTS-Designer verwenden, wird e-Mail standardmäßig nicht im Ordner Gesendete Objekte gespeichert. Der DTS-Benutzeroberfläche müssen keine Option, um dieses Verhalten in der aktuellen Version zu ändern. Sie können das Verhalten jedoch ändern, indem mittels Microsoft Visual Basic-Code:
Dim myPackage As New DTS.Package
Dim oCustomTask3 as DTS.SendMailTask
Set oTask = myPackage.Tasks.New("DTSSendMailTask")
Set oCustomTask3 = oTask.CustomTask
oCustomTask1.SaveMailInSentItemsFolder = False
				
Weitere Informationen finden Sie die Artikel der Microsoft Knowledge Base:
308758Update: SQL Agent Mail E-Mail Root Directory des Postfachs Quelle geschrieben werden verursachen

Eigenschaften

Artikel-ID: 261133 - Geändert am: Sonntag, 23. Februar 2014 - Version: 3.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft SQL Server 7.0 Standard Edition
  • Microsoft Exchange Active Server Components 5.0, wenn verwendet mit:
    • Microsoft Windows NT 4.0
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Maschinell übersetzter Artikel
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 261133
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