REVISIÓN: DTS "enviar correo" rellenos de buzón y Outlook no puede ver o eliminar mensajes de correo electrónico

Seleccione idioma Seleccione idioma
Id. de artículo: 261133 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Nº DE ERROR: 57661 (SQLBUG_70)
Expandir todo | Contraer todo

Síntomas

Cuando crea un paquete que utiliza la tarea Enviar correo de servicios de transformación de datos (DTS) de SQL Server para enviar mensajes, buzón de un remitente llena continuamente porque DTS informes como mensajes de error:
No se puede ejecutar el paquete porque buzón está lleno.
Sin embargo, si revise carpeta de Microsoft Outlook SentItem del remitente y compruebe el tamaño de buzón, el tamaño del buzón está cerca de 0 KB y nada está en el buzón del remitente desde punto de vista del Outlook.

Si selecciona tamaño del buzón del remitente desde la consola Administrador de Exchange Server, se muestra el tamaño correcto del buzón. Sin embargo, no puede ver los mensajes que llenan el buzón porque ocultan los mensajes de Outlook y Exchange Server.

Causa

Los clientes de Outlook y Exchange no pueden ver los elementos bajo el directorio raíz del almacén de Exchange Server Information. Después de enviar correo de DTS envía el mensaje, DTS mantiene el mensaje en la carpeta raíz del remitente es (origen) de buzón de Exchange Server. Por lo tanto, cliente de Outlook del remitente no se puede ver o eliminar estos mensajes.

Solución

Utilice la utilidad de Microsoft Exchange, MDB Viewer para ver los mensajes de correo electrónico ocultos que llenan el buzón. También puede utilizar MDB Viewer para eliminar los mensajes.

Siga estos pasos para comprobar la carpeta raíz del buzón está configurado para utilizar por DTS enviar correo:
  1. Copie los archivos siguientes a un equipo en el que está instalado Outlook:

    • Mdbvu32.exe
    • Propvu32.dll
    • Statvu32.dll
    • Tbvlu32.dll
    • Xvport.dll

    Puede encontrar la utilidad Mdbvu32 y archivos DLL que lo acompaña del CD-ROM de Exchange Server 5.5 en la carpeta de \Server\Support\Utils\I386 o en la carpeta \Server\Support\Utils\Alpha.
  2. Compruebe que existe un perfil de buzón del usuario, que el perfil está seleccionado como el perfil predeterminado y que un usuario (que tiene permiso para el buzón del usuario) se registra correctamente en la estación de trabajo cliente.
  3. Asegúrese de que Outlook no se está ejecutando actualmente en la estación de trabajo.
  4. Haga doble clic en el archivo ejecutable MDBVU32.exe iniciar MDB Viewer.
  5. Cuando se abre el cuadro de diálogo MAPILogonEx , seleccione la casilla de verificación MAPI Explicit perfil y, a continuación, haga clic en Aceptar .
  6. Cuando se muestra el cuadro de diálogo Elegir perfil , seleccione el perfil que creó en los pasos anteriores y, a continuación, haga clic en Aceptar .

    Nota : si no aparece el cuadro de diálogo Elegir perfil , probablemente ya haya iniciado sesión a un perfil. Salir, cerrar el cliente y el perfil de la sesión y vuelva a intentarlo.
  7. En el menú MDB Viewer Test Application , haga clic en Microsoft Access y, a continuación, seleccione la opción OpenMessageStore .
  8. En el cuadro de diálogo Seleccionar mensaje almacén para abrir , seleccione el nombre de presentación de operador (servidor) y, a continuación, haga clic en Abrir . (Modo abierto debe predeterminado Access mejor, lo que desea dejar como valor predeterminado).
  9. En el menú MDB Viewer Test Application , haga clic en Microsoft Access y, a continuación, haga clic en Open Root Folder .

    En este paso, verá que el mensaje enviado por DTS "DTStest1" se encuentra en el directorio raíz del perfil utilizado por DTS. El directorio raíz está oculto en el lado del cliente, por lo que utilice Outlook. No se puede ver este mensaje, pero se almacena en ese buzón después de enviarlo al destinatario. Esto explica por qué el buzón está lleno, pero Outlook no pudo ver nada en este buzón.
  10. Dentro de la ventana MAPI_FOLDER ROOT , active la casilla segunda denominada Operación disponibles . Seleccionar operación y, a continuación, haga clic en Llamadas de función . Seleccione la función denominada lpFld_DeleteMEssages y, a continuación, haga clic en Llamada de función para eliminar el mensaje seleccionado en el directorio raíz.

Estado

Microsoft ha confirmado que se trata de un problema en SQL Server 7.0. Este problema se ha corregido en EE.UU. Service Pack 3 para Microsoft SQL Server 7.0. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
274799INF: Cómo obtener el Service Pack 3 para Microsoft SQL Server 7.0 y Microsoft Data Engine (MSDE) 1.0
Para obtener más información, póngase en contacto con su proveedor principal de soporte técnico.

Más información

Si utiliza la tarea Enviar correo en el Diseñador DTS GUI, correo no se guarda en la carpeta Elementos enviados de forma predeterminada. La GUI de DTS no tiene una opción para cambiar este comportamiento en la versión actual. Sin embargo, puede cambiar el comportamiento mediante el código de Microsoft Visual Basic:
Dim myPackage As New DTS.Package
Dim oCustomTask3 as DTS.SendMailTask
Set oTask = myPackage.Tasks.New("DTSSendMailTask")
Set oCustomTask3 = oTask.CustomTask
oCustomTask1.SaveMailInSentItemsFolder = False
				
Para obtener información adicional, haga clic en el número de artículo siguiente para ver el artículo en Microsoft Knowledge Base:
308758REVISIÓN: SQL Agent Mail puede causar el correo electrónico para agregarse al directorio raíz del buzón de origen

Propiedades

Id. de artículo: 261133 - Última revisión: domingo, 23 de febrero de 2014 - Versión: 3.1
La información de este artículo se refiere a:
  • Microsoft SQL Server 7.0 Standard Edition
  • Microsoft Exchange Active Server Components 5.0 sobre las siguientes plataformas
    • Microsoft Windows NT 4.0
Palabras clave: 
kbnosurvey kbarchive kbmt kbbug kbfix kbsqlprog KB261133 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 261133

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com